You are not logged in.

#1 2013-07-10 12:57:56

acgtyrant
Member
From: Hangzhou, China
Registered: 2013-04-09
Posts: 54
Website

[Solved]My urxvt eccounts a very crazy phenomenon

Sorry for my poor English, please look at the picture below:

https://lh3.googleusercontent.com/-pYV8 … _scrot.png

It only happends when I using ssh to access my remote vps via urxvt. If I do the same thing with other terminal emulators, nothing goes wrong.

By the way, everything is good when I was using the AUR package rxvt-unicode-chinese, version is 9.18-1. After I replaced it with rxvt-unicode, version is 9.18-7, the crazy phenomenon happened. So could it be a new BUG?


-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Last edited by acgtyrant (2013-07-11 02:50:34)


I am Chinese! I love Arch Linux!

Offline

#2 2013-07-10 13:12:00

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [Solved]My urxvt eccounts a very crazy phenomenon

Could you please say what exactly is wrong here? I see you're using command completion, but I don't see what's wrong with it.

Offline

#3 2013-07-10 13:17:31

acgtyrant
Member
From: Hangzhou, China
Registered: 2013-04-09
Posts: 54
Website

Re: [Solved]My urxvt eccounts a very crazy phenomenon

It will create a new line when I type one key everytime.

The urxvt automatically returns too many lines like the picture while I was just typing: "su" + tab key + "pac" + tab key + "-".

Last edited by acgtyrant (2013-07-10 13:21:42)


I am Chinese! I love Arch Linux!

Offline

#4 2013-07-10 13:19:18

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [Solved]My urxvt eccounts a very crazy phenomenon

Ah, I thought you're also pressing 'tab' to get command completion.

Offline

#5 2013-07-10 18:15:57

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,374
Website

Re: [Solved]My urxvt eccounts a very crazy phenomenon

No, it's not a bug; more likely you don't have the correct terminfo on the remote machine.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#6 2013-07-11 02:10:31

acgtyrant
Member
From: Hangzhou, China
Registered: 2013-04-09
Posts: 54
Website

Re: [Solved]My urxvt eccounts a very crazy phenomenon

@jasonwryan But I have said that it does not happen in other terminal, except rxvt-unicode.


I am Chinese! I love Arch Linux!

Offline

#7 2013-07-11 02:28:43

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,374
Website

Re: [Solved]My urxvt eccounts a very crazy phenomenon

Yes, so either copy across the terminfo for rxvt-unicode to the remote machine, or install it there...

You can check by diffing the infocmp for rxvt-unicode on both machines.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#8 2013-07-11 02:32:41

acgtyrant
Member
From: Hangzhou, China
Registered: 2013-04-09
Posts: 54
Website

Re: [Solved]My urxvt eccounts a very crazy phenomenon

@jasonwryan Ah, I understand what you are saying now. I am not familiar with terminfo, but I will try it.


I am Chinese! I love Arch Linux!

Offline

#9 2013-07-11 02:50:06

acgtyrant
Member
From: Hangzhou, China
Registered: 2013-04-09
Posts: 54
Website

Re: [Solved]My urxvt eccounts a very crazy phenomenon

Great, I install urxvt in the remoe machine and reboot. No cray phenomenon now.

Thank you!


I am Chinese! I love Arch Linux!

Offline

Board footer

Powered by FluxBB