You are not logged in.

#1 2013-01-15 23:22:00

welpert
Member
From: the Netherlands
Registered: 2011-01-11
Posts: 73

xfce4-mixer doesn't unmute alsa after setting volume to 0% and back up

Hey guys,

I'm no newbie to Arch, so maybe I just need some cold water in my face because I'm overlooking something obvious.. Yesterday I did a complete re-install from an arch bootstrap script and got everything running just the way I want again - except for one thing.

I am running Xfce as my DE with the xfce4-mixer applet in the tray to control the Master channel's volume using the mouse scroll wheel. This always used to work fine for me. Alsa is up and running and I get sound. The only thing is that when I completely turn down the volume by scrolling down over the speaker icon in the tray (because my phone rings for instance) and then scroll it back up again, alsa somehow seems stuck in mute mode. I have to open a terminal window and use alsamixer each time to unmute the volume again hmm.

This seems like strange behavior on the part of xfce-mixer to me, and it is not something I have encountered before. Anyone have some tips or tricks to fix this weirdness?

Thanks,

welpert


“Great art is horseshit, buy tacos.” - Charles Bukowski

freenode/archlinux: nl-trisk

Offline

#2 2013-01-15 23:31:59

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,017

Re: xfce4-mixer doesn't unmute alsa after setting volume to 0% and back up

Maybe you can mute and unmute with middle click? It works in some mixers.

Offline

#3 2013-01-16 00:17:39

welpert
Member
From: the Netherlands
Registered: 2011-01-11
Posts: 73

Re: xfce4-mixer doesn't unmute alsa after setting volume to 0% and back up

lucke wrote:

Maybe you can mute and unmute with middle click? It works in some mixers.

Alas, no luck.. But scrolling up from 'muted' should have the same effect as middle-clicking, at least I assume both actions activate the same unmute function somewhere in the code..


EDIT: For now I'm going to use volwheel. But.. please don't hesitate if you know the answer bacause I like xfce4-mixer's simplicity.

Last edited by welpert (2013-01-17 11:32:42)


“Great art is horseshit, buy tacos.” - Charles Bukowski

freenode/archlinux: nl-trisk

Offline

#4 2013-07-12 09:06:12

inoxllor
Member
Registered: 2013-07-12
Posts: 1

Re: xfce4-mixer doesn't unmute alsa after setting volume to 0% and back up

Try this cmd on terminal to unmute:
pactl set-sink-mute 1 0

Offline

#5 2013-07-12 09:43:10

crazyg4merz
Member
Registered: 2013-04-14
Posts: 40

Re: xfce4-mixer doesn't unmute alsa after setting volume to 0% and back up

u should try xfce-volumed from AUR or cobine it with pulseaudio and xfce-volumed-pulse. Should modify your default card from xfconf to pulseaudio. Worked for me before. But a little bit tricky, had to configure and reboot a couple times to get it working. Goodluck :-)

Offline

Board footer

Powered by FluxBB