You are not logged in.

#1 2013-06-23 11:04:44

argoneus
Member
Registered: 2013-06-23
Posts: 2

Cannot use AMD Hybrid Graphics (Intel + AMD), X doesn't start

Hello,

I have tried installing the AMD (7570M) proprietary drivers to use on my laptop (HP ProBook 4340s) along with the integrated Intel graphics (i5 with Intel HD4000). I followed the guide here.

I have installed catalyst-total-pxp on my machine along with the xorg-server and xf86-video-intel from the xorg113 repository. Then I ran "sudo aticonfig --initial", which created xorg.conf in /etc/X11 and added "nomodeset" to my GRUB. I also made sure to blacklist radeon and add "fglrx" to modules-load.

The problem is, now my laptop doesn't boot, it just shows a blinking "_" in the corner. So I opened tty1 and tried to "startx" from root. But it gave an error and referred me to a log. Here are the contents of the log:

[    26.821] 
X.Org X Server 1.13.4
Release Date: 2013-04-17
[    26.822] X Protocol Version 11, Revision 0
[    26.823] Build Operating System: Linux 3.8.10-1-ARCH x86_64 
[    26.824] Current Operating System: Linux arch 3.9.7-1-ARCH #1 SMP PREEMPT Thu Jun 20 22:45:32 CEST 2013 x86_64
[    26.824] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=f69a7f8b-8fee-4f1a-b6e9-9f5af9881e7c ro nomodeset acpi_backlight=vendor quiet
[    26.826] Build Date: 28 April 2013  01:19:17PM
[    26.826]  
[    26.827] Current version of pixman: 0.30.0
[    26.828] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    26.828] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    26.831] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Jun 23 12:32:19 2013
[    26.832] (==) Using config file: "/etc/X11/xorg.conf"
[    26.832] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    26.832] (==) ServerLayout "aticonfig Layout"
[    26.832] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    26.832] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    26.832] (**) |   |-->Device "aticonfig-Device[0]-0"
[    26.832] (==) Automatically adding devices
[    26.832] (==) Automatically enabling devices
[    26.832] (==) Automatically adding GPU devices
[    26.833] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    26.833] 	Entry deleted from font path.
[    26.833] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    26.833] 	Entry deleted from font path.
[    26.833] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    26.833] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    26.833] 	Entry deleted from font path.
[    26.833] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    26.833] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
[    26.833] (**) ModulePath set to "/usr/lib/xorg/modules/updates,/usr/lib/xorg/modules"
[    26.833] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    26.833] (II) Loader magic: 0x7fbc20
[    26.833] (II) Module ABI versions:
[    26.833] 	X.Org ANSI C Emulation: 0.4
[    26.833] 	X.Org Video Driver: 13.1
[    26.833] 	X.Org XInput driver : 18.0
[    26.833] 	X.Org Server Extension : 7.0
[    26.834] (--) PCI:*(0:0:2:0) 8086:0126:103c:17f1 rev 9, Mem @ 0xd0000000/4194304, 0xc0000000/268435456, I/O @ 0x00004000/64
[    26.834] (--) PCI: (0:1:0:0) 1002:6841:103c:17f1 rev 0, Mem @ 0xb0000000/268435456, 0xd0900000/131072, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
[    26.835] Initializing built-in extension Generic Event Extension
[    26.835] Initializing built-in extension SHAPE
[    26.835] Initializing built-in extension MIT-SHM
[    26.836] Initializing built-in extension XInputExtension
[    26.836] Initializing built-in extension XTEST
[    26.837] Initializing built-in extension BIG-REQUESTS
[    26.837] Initializing built-in extension SYNC
[    26.838] Initializing built-in extension XKEYBOARD
[    26.838] Initializing built-in extension XC-MISC
[    26.838] Initializing built-in extension SECURITY
[    26.839] Initializing built-in extension XINERAMA
[    26.839] Initializing built-in extension XFIXES
[    26.840] Initializing built-in extension RENDER
[    26.840] Initializing built-in extension RANDR
[    26.840] Initializing built-in extension COMPOSITE
[    26.855] Initializing built-in extension DAMAGE
[    26.868] Initializing built-in extension MIT-SCREEN-SAVER
[    26.880] Initializing built-in extension DOUBLE-BUFFER
[    26.892] Initializing built-in extension RECORD
[    26.904] Initializing built-in extension DPMS
[    26.916] Initializing built-in extension X-Resource
[    26.927] Initializing built-in extension XVideo
[    26.938] Initializing built-in extension XVideo-MotionCompensation
[    26.949] Initializing built-in extension XFree86-VidModeExtension
[    26.960] Initializing built-in extension XFree86-DGA
[    26.971] Initializing built-in extension XFree86-DRI
[    26.981] Initializing built-in extension DRI2
[    26.981] (II) "glx" will be loaded by default.
[    26.981] (II) LoadModule: "glx"
[    26.981] (II) Loading /usr/lib/xorg/modules/updates/extensions/libglx.so
[    26.982] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    26.982] 	compiled for 6.9.0, module version = 1.0.0
[    26.992] Loading extension GLX
[    26.992] (II) LoadModule: "fglrx"
[    26.992] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[    27.001] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    27.002] 	compiled for 1.4.99.906, module version = 12.10.5
[    27.002] 	Module class: X.Org Video Driver
[    27.002] (II) Loading sub module "fglrxdrm"
[    27.002] (II) LoadModule: "fglrxdrm"
[    27.002] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    27.002] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    27.002] 	compiled for 1.4.99.906, module version = 12.10.5
[    27.002] (II) AMD Proprietary Linux Driver Version Identifier:12.10.05
[    27.002] (II) AMD Proprietary Linux Driver Release Identifier: 12.104                               
[    27.002] (II) AMD Proprietary Linux Driver Build Date: Mar 28 2013 21:07:25
[    27.002] (++) using VT number 1

[    27.002] (WW) Falling back to old probe method for fglrx
[    27.006] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    27.007] ukiDynamicMajor: found major device number 251
[    27.007] ukiDynamicMajor: found major device number 251
[    27.007] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    27.007] ukiOpenDevice: node name is /dev/ati/card0
[    27.007] ukiOpenDevice: open result is 9, (OK)
[    27.007] ukiOpenByBusid: ukiOpenMinor returns 9
[    27.007] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    27.007] (--) Chipset Supported AMD Graphics Processor (0x6841) found
[    27.008] (II) fglrx: intel VGA device detected, load intel driver.
[    27.008] (II) LoadModule: "intel"
[    27.008] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    27.008] (II) Module intel: vendor="X.Org Foundation"
[    27.008] 	compiled for 1.13.2.901, module version = 2.21.3
[    27.008] 	Module class: X.Org Video Driver
[    27.008] 	ABI class: X.Org Video Driver, version 13.1
[    27.008] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[    27.008] (II) AMD Video driver is signed
[    27.009] (II) fglrx(0): pEnt->device->identifier=0x212f5c0
[    27.010] 
Fatal server error:
[    27.010] atiddxProbe: fail to probe intel VGA device
[    27.010] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    27.010] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    27.010] (EE) 

I will be glad for any help, I hope I have not missed any important information. Thanks in advance!

EDIT:

If it helps, here are the contents of all the files in xorg:

xorg.conf

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

10-evdev.conf

#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

10-quirks.conf

# Collection of quirks and blacklist/whitelists for specific devices.


# Accelerometer device, posts data through ABS_X/ABS_Y, making X unusable
# http://bugs.freedesktop.org/show_bug.cgi?id=22442 
Section "InputClass"
        Identifier "ThinkPad HDAPS accelerometer blacklist"
        MatchProduct "ThinkPad HDAPS accelerometer data"
        Option "Ignore" "on"
EndSection

20-catalystpxp.conf

Section "Files"
	ModulePath   "/usr/lib/xorg/modules/updates"
	ModulePath   "/usr/lib/xorg/modules"
EndSection

Last edited by argoneus (2013-06-23 11:08:17)

Offline

#2 2013-06-26 20:24:17

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: Cannot use AMD Hybrid Graphics (Intel + AMD), X doesn't start

I'm pretty sure that you installed intel-dri, but have you tried uxa/sna intel accell?

Offline

#3 2013-06-26 20:25:23

argoneus
Member
Registered: 2013-06-23
Posts: 2

Re: Cannot use AMD Hybrid Graphics (Intel + AMD), X doesn't start

Yes, I tried adding the Intel device to the configs and tried both uxa/sna.

Offline

#4 2013-07-13 09:06:45

tillux
Member
Registered: 2012-03-04
Posts: 5

Re: Cannot use AMD Hybrid Graphics (Intel + AMD), X doesn't start

I'm getting the same error on my hp pavilion dm4 2100sg using XOrg 1.14 and catalyst + pxp from Vi0L0's repository (i.e. not using catalyst-total-pxp.from AUR).

Offline

#5 2013-07-19 19:35:34

pirat9600q
Member
Registered: 2013-07-19
Posts: 9

Re: Cannot use AMD Hybrid Graphics (Intel + AMD), X doesn't start

I had the same problem with same error " fail to probe intel VGA device ". Here is my solution.
The problem is that you need intel driver work even if you want to use discrete videocard. Intel driver needs KMS enabled to work, but you disabled it. You have to enable KMS :
edit your GRUB config.

$ sudo nano /etc/default/grub

and remove nomodeset from GRUB_CMDLINE_LINUX.
Update grub(root needed)

# grub-mkconfig -o /boot/grub/grub.cfg
# reboot

Thats all! It worked for me.

P.S. sorry for my english

Last edited by pirat9600q (2013-07-19 19:40:31)

Offline

Board footer

Powered by FluxBB