You are not logged in.

#1 2013-07-11 20:23:07

billodwyer
Member
Registered: 2013-06-15
Posts: 16

After suspend wireless doesn't work

I use wicd for my connection management, and xfce4-power-manager for suspending my laptop.
I can't seem to get the internet to reconnect after my laptop suspends, and I have to restart my computer to regain connectivity again.

What advice do people have?

Offline

#2 2013-07-12 00:28:04

ryley
Member
Registered: 2013-06-24
Posts: 7

Re: After suspend wireless doesn't work

Which card do you have? And which driver are you using for it? Can your laptop see any wireless networks when you resume and not connect to them? Or does it fail to find any wireless networks?

I think some out of tree wireless drivers can require you to remove the module before suspending and then reprobe it during wakeup. That might not be relevant though...

Offline

#3 2013-07-13 02:08:53

billodwyer
Member
Registered: 2013-06-15
Posts: 16

Re: After suspend wireless doesn't work

This is the output of lspci | grep -i wireless

02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]

I'm not really sure how to get driver information.

Basically when I wake my laptop from suspend, wicd gives me a message saying I'm disconnected from the wifi and starts trying to reconnect but never succeeds. The icon in my tray shows the disconnected icon, but the tooltip says connected.

Offline

#4 2013-07-13 03:09:08

cris9288
Member
Registered: 2013-01-07
Posts: 347

Re: After suspend wireless doesn't work

try lspci -vk to get info about what device is using what module/driver.

EDIT: Also, have you checked journalctl or dmesg for anything interesting after resuming?

Last edited by cris9288 (2013-07-13 03:09:51)

Offline

#5 2013-07-13 13:18:54

billodwyer
Member
Registered: 2013-06-15
Posts: 16

Re: After suspend wireless doesn't work

lspci -vk output:

02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]
	Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN
	Flags: bus master, fast devsel, latency 0, IRQ 44
	Memory at d2400000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

I'll do a suspend and post exactly what happens shortly.

Offline

#6 2013-07-16 16:47:32

billodwyer
Member
Registered: 2013-06-15
Posts: 16

Re: After suspend wireless doesn't work

Finally got around to making a note of all that happens after a suspend:
A notification pops up, saying "establishing connection" but later goes on to say "disconnected"
The icon in the system tray says "Connected to HideYoKidsHideYoWifi (IP: ...)
Opening up the wicd interface shows no networks at all, and the status bar at the bottom says "Connection failed: bad password"

Journalctl didn't turn up anything of use, but perhaps this dmesg output holds something of value?

[ 1498.170303] iwlwifi 0000:02:00.0: ctx->vif =   (null), vif = f4b57c60
[ 1498.170306] iwlwifi 0000:02:00.0: 	ID = 0:	ctx = f3071d94	ctx->vif =   (null)
[ 1498.257699] iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
[ 1498.349970] usb 2-5: reset high-speed USB device number 2 using ehci-pci
[ 1498.459964] ata1: SATA link down (SStatus 0 SControl 300)
[ 1498.466623] ata6: SATA link down (SStatus 0 SControl 300)
[ 1498.639964] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 1498.644955] ata5.00: ACPI cmd 00/00:00:00:00:00:a0 (NOP) rejected by device (Stat=0x51 Err=0x04)
[ 1498.650413] ata5.00: ACPI cmd 00/00:00:00:00:00:a0 (NOP) rejected by device (Stat=0x51 Err=0x04)
[ 1498.650419] ata5.00: configured for UDMA/133
[ 1502.416641] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 1502.619719] ata2.00: ACPI cmd 00/00:00:00:00:00:b0 (NOP) rejected by device (Stat=0x51 Err=0x04)
[ 1502.623252] ata2.00: ACPI cmd 00/00:00:00:00:00:b0 (NOP) rejected by device (Stat=0x51 Err=0x04)
[ 1502.623798] ata2.00: configured for UDMA/133
[ 1502.623909] sd 1:0:0:0: [sda] Starting disk
[ 1502.665305] PM: resume of devices complete after 4531.446 msecs
[ 1502.677848] PM: Finishing wakeup.
[ 1502.695443] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1502.677851] Restarting tasks ... done.
[ 1502.723515] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[ 1502.754424] video LNXVIDEO:00: Restoring backlight state
[ 1502.886725] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[ 1503.169542] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1503.177158] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[ 1503.322259] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[ 1503.378007] atl1c 0000:01:00.0: irq 46 for MSI/MSI-X
[ 1503.390581] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 1508.043059] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1508.051173] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[ 1508.181656] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[ 1509.307521] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1509.315132] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[ 1509.451578] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[ 1509.494740] atl1c 0000:01:00.0: irq 46 for MSI/MSI-X
[ 1509.507813] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 1509.546701] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1509.554328] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[ 1509.694031] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[ 1511.795985] wlp2s0: authenticate with 00:8e:f2:6a:52:18
[ 1511.797693] wlp2s0: send auth to 00:8e:f2:6a:52:18 (try 1/3)
[ 1511.814583] wlp2s0: authenticated
[ 1511.816562] wlp2s0: associate with 00:8e:f2:6a:52:18 (try 1/3)
[ 1511.820510] wlp2s0: RX AssocResp from 00:8e:f2:6a:52:18 (capab=0x411 status=0 aid=5)
[ 1511.824403] wlp2s0: associated
[ 1511.824430] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
[ 1521.824838] wlp2s0: deauthenticating from 00:8e:f2:6a:52:18 by local choice (reason=3)
[ 1521.831040] cfg80211: Calling CRDA to update world regulatory domain
[ 1522.359037] wlp2s0: authenticate with 00:8e:f2:6a:52:18
[ 1522.369092] wlp2s0: send auth to 00:8e:f2:6a:52:18 (try 1/3)
[ 1522.379947] wlp2s0: authenticated
[ 1522.383289] wlp2s0: associate with 00:8e:f2:6a:52:18 (try 1/3)
[ 1522.387002] wlp2s0: RX AssocResp from 00:8e:f2:6a:52:18 (capab=0x411 status=0 aid=5)
[ 1522.389993] wlp2s0: associated
[ 1532.390723] wlp2s0: deauthenticating from 00:8e:f2:6a:52:18 by local choice (reason=3)
[ 1532.398463] cfg80211: Calling CRDA to update world regulatory domain
[ 1532.905194] wlp2s0: authenticate with 00:8e:f2:6a:52:18
[ 1532.915177] wlp2s0: send auth to 00:8e:f2:6a:52:18 (try 1/3)
[ 1532.925435] wlp2s0: authenticated
[ 1532.926552] wlp2s0: associate with 00:8e:f2:6a:52:18 (try 1/3)
[ 1532.931347] wlp2s0: RX AssocResp from 00:8e:f2:6a:52:18 (capab=0x411 status=0 aid=5)
[ 1532.934218] wlp2s0: associated
[ 1542.934671] wlp2s0: deauthenticating from 00:8e:f2:6a:52:18 by local choice (reason=3)
[ 1542.944512] cfg80211: Calling CRDA to update world regulatory domain
[ 1543.554377] wlp2s0: authenticate with 00:8e:f2:6a:52:18
[ 1543.564491] wlp2s0: send auth to 00:8e:f2:6a:52:18 (try 1/3)
[ 1543.574701] wlp2s0: authenticated
[ 1543.576623] wlp2s0: associate with 00:8e:f2:6a:52:18 (try 1/3)
[ 1543.580632] wlp2s0: RX AssocResp from 00:8e:f2:6a:52:18 (capab=0x411 status=0 aid=5)
[ 1543.583467] wlp2s0: associated
[ 1552.212643] wlp2s0: deauthenticating from 00:8e:f2:6a:52:18 by local choice (reason=3)
[ 1552.218190] cfg80211: Calling CRDA to update world regulatory domain
[ 1552.239456] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1552.247098] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[ 1552.380282] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[ 1552.451439] atl1c 0000:01:00.0: irq 46 for MSI/MSI-X
[ 1552.464547] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 1552.482853] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1552.490481] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[ 1552.640205] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[ 1553.515022] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1553.522745] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[ 1553.658099] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[ 1553.701544] atl1c 0000:01:00.0: irq 46 for MSI/MSI-X
[ 1553.714455] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 1554.771111] wlp2s0: authenticate with 00:8e:f2:6a:52:18
[ 1554.781861] wlp2s0: send auth to 00:8e:f2:6a:52:18 (try 1/3)
[ 1554.790981] wlp2s0: authenticated
[ 1554.793287] wlp2s0: associate with 00:8e:f2:6a:52:18 (try 1/3)
[ 1554.796967] wlp2s0: RX AssocResp from 00:8e:f2:6a:52:18 (capab=0x411 status=0 aid=5)
[ 1554.801131] wlp2s0: associated
[ 1554.801158] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
[ 1564.801522] wlp2s0: deauthenticating from 00:8e:f2:6a:52:18 by local choice (reason=3)
[ 1564.807685] cfg80211: Calling CRDA to update world regulatory domain
[ 1565.377094] wlp2s0: authenticate with 00:8e:f2:6a:52:18
[ 1565.379135] wlp2s0: send auth to 00:8e:f2:6a:52:18 (try 1/3)
[ 1565.385155] wlp2s0: authenticated
[ 1565.386620] wlp2s0: associate with 00:8e:f2:6a:52:18 (try 1/3)
[ 1565.390325] wlp2s0: RX AssocResp from 00:8e:f2:6a:52:18 (capab=0x411 status=0 aid=5)
[ 1565.393147] wlp2s0: associated
[ 1575.394109] wlp2s0: deauthenticating from 00:8e:f2:6a:52:18 by local choice (reason=3)
[ 1575.407599] cfg80211: Calling CRDA to update world regulatory domain
[ 1575.935042] wlp2s0: authenticate with 00:8e:f2:6a:52:18
[ 1575.945193] wlp2s0: send auth to 00:8e:f2:6a:52:18 (try 1/3)
[ 1575.950952] wlp2s0: authenticated
[ 1575.953287] wlp2s0: associate with 00:8e:f2:6a:52:18 (try 1/3)
[ 1575.956922] wlp2s0: RX AssocResp from 00:8e:f2:6a:52:18 (capab=0x411 status=0 aid=5)
[ 1575.962899] wlp2s0: associated
[ 1585.963280] wlp2s0: deauthenticating from 00:8e:f2:6a:52:18 by local choice (reason=3)
[ 1585.971002] cfg80211: Calling CRDA to update world regulatory domain
[ 1586.483396] wlp2s0: authenticate with 00:8e:f2:6a:52:18
[ 1586.493571] wlp2s0: send auth to 00:8e:f2:6a:52:18 (try 1/3)
[ 1586.501240] wlp2s0: authenticated
[ 1586.503231] wlp2s0: associate with 00:8e:f2:6a:52:18 (try 1/3)
[ 1586.511378] wlp2s0: RX AssocResp from 00:8e:f2:6a:52:18 (capab=0x411 status=0 aid=5)
[ 1586.514364] wlp2s0: associated
[ 1590.055629] wlp2s0: deauthenticating from 00:8e:f2:6a:52:18 by local choice (reason=3)
[ 1590.061121] cfg80211: Calling CRDA to update world regulatory domain
[ 1590.070697] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1590.078264] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[ 1590.207529] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[ 1590.271311] atl1c 0000:01:00.0: irq 46 for MSI/MSI-X
[ 1590.284503] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready

Offline

#7 2013-07-17 04:35:30

SuddenGun007
Member
Registered: 2012-04-06
Posts: 5

Re: After suspend wireless doesn't work

Reboot your computer so you have a connection. Go to terminal and type "ip link", suspend your computer and then retype it, what is the output before and after. I'm thinking it might be the interface is going down, and has to be upped again. I am having some trouble with wireless as well (netctl, wicd) because settings are inpersistent. So you can try "# ip link set 'wirelessinterfacenamehere' up"

Offline

Board footer

Powered by FluxBB