You are not logged in.

#26 2013-07-14 17:47:08

netpumber
Member
Registered: 2009-09-20
Posts: 127

Re: [SOLVED] Full system encryption with Luks + LVM + 6 HDDs

So. I've tried these two now and thats what i get back :

linux   /vmlinuz-linux root=/dev/lvmpool/root ro rootfstype=ext4  cryptdevice=/dev/disk/by-uuid/bc7dd991-8573-42be-9c7f-ab879eb9f0f7:crypt_system
linux   /vmlinuz-linux root=/dev/mapper/lvmpool-root ro rootfstype=ext4  cryptdevice=/dev/disk/by-uuid/bc7dd991-8573-42be-9c7f-ab879eb9f0f7:crypt_system
:: running early hook [udev]
:: running early hook [lvm2]
:: running hook [udev]
:: Triggering uevents...
[ 1.487942] ata6.00: exception Emask 0x12 SAct 0x0 SErr 0x380500 action 0x6 frozen
[ 1.4xxx] ata6.00: irq_stat 0x08000000, interface fatal error
[ 1.4xxx] ata6: SError: {UnrecovData Proto 10B8B Dispar BadCRC}
[ 1.4xxx] ata6.00: failed command: READ DMA
[ 1.4xxx] ata6.00: cmd c8/00:08:08:00:00:/00:00:00:00:00/e0 tag 0 dma 4096 in
                                  res   50/00:00:07:00:00/00:00:00:00:00/e0  Emask 0x12 (ATA bus error)
[ 1.4xxx] ata6.00: status: { DRDY }
[ 1.487942] ata6.00: exception Emask 0x12 SAct 0x0 SErr 0x380500 action 0x6 frozen
[ 1.4xxx] ata6.00: irq_stat 0x08000000, interface fatal error
[ 1.4xxx] ata6: SError: {UnrecovData Proto 10B8B Dispar BadCRC}
[ 1.4xxx] ata6.00: failed command: READ DMA
[ 1.4xxx] ata6.00: cmd c8/00:08:08:00:00:/00:00:00:00:00/e0 tag 0 dma 4096 in
                                  res   50/00:00:07:00:00/00:00:00:00:00/e0  Emask 0x12 (ATA bus error)
[ 1.4xxx] ata6.00: status: { DRDY }
[ 1.487942] ata6.00: exception Emask 0x12 SAct 0x0 SErr 0x380500 action 0x6 frozen
[ 1.4xxx] ata6.00: irq_stat 0x08000000, interface fatal error
[ 1.4xxx] ata6: SError: {UnrecovData Proto 10B8B Dispar BadCRC}
[ 1.4xxx] ata6.00: failed command: READ DMA
[ 1.4xxx] ata6.00: cmd c8/00:08:08:00:00:/00:00:00:00:00/e0 tag 0 dma 4096 in
                                  res   50/00:00:07:00:00/00:00:00:00:00/e0  Emask 0x12 (ATA bus error)
[ 1.4xxx] ata6.00: status: { DRDY }
[ 1.487942] ata6.00: exception Emask 0x12 SAct 0x0 SErr 0x380500 action 0x6 frozen
[ 1.4xxx] ata6.00: irq_stat 0x08000000, interface fatal error
[ 1.4xxx] ata6: SError: {UnrecovData Proto 10B8B Dispar BadCRC}
[ 1.4xxx] ata6.00: failed command: READ DMA
[ 1.4xxx] ata6.00: cmd c8/00:08:08:00:00:/00:00:00:00:00/e0 tag 0 dma 4096 in
                                  res   50/00:00:07:00:00/00:00:00:00:00/e0  Emask 0x12 (ATA bus error)
[ 1.4xxx] ata6.00: status: { DRDY }
Waiting 10 seconds for device /dev/mapper/lvmpool-root ...
ERROR: device '/dev/mapper/lvmpool-root' not found. Skipping fsck.
ERROR: Unable to find root device '/dev/mapper/lvmpool-root'/
You are being dropped to a recovery shell

Last edited by netpumber (2013-07-14 17:55:41)

Offline

#27 2013-07-14 17:50:45

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: [SOLVED] Full system encryption with Luks + LVM + 6 HDDs

You have no encrypt hook in your initramfs. You won't be able to do much with an encrypted root if you don't have this hook. You also need to fix the cable attaching the disk to the motherboard. Either it isn't seated properly, or there's a short in the wiring (this is what causes the DRDY errors and failed reads you see).

And please use code tags instead of quote'ing the output.....

Offline

#28 2013-07-14 18:20:26

netpumber
Member
Registered: 2009-09-20
Posts: 127

Re: [SOLVED] Full system encryption with Luks + LVM + 6 HDDs

I add the encrypt into HOOKS line but i m getting the same error except the DRDY cause i move the cables

HOOKS="base udev autodetect modconf block lvm2 encrypt filesystems keyboard fsck"

Offline

#29 2013-07-14 18:32:07

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: [SOLVED] Full system encryption with Luks + LVM + 6 HDDs

...did you regenerate the image before you rebooted again? You should see the 'encrypt' hook in the output of 'lsinitcpio -a' and you'll see the hook running at bootup after the second udev hook

Offline

#30 2013-07-14 18:51:28

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [SOLVED] Full system encryption with Luks + LVM + 6 HDDs

@falconindy,
Doesn't the OP need the encrypt hook before lvm2 since the volume group is only available once the encrypted container has been decrypted?

That is, shouldn't it be

HOOKS="base udev autodetect modconf block encrypt lvm2 filesystems keyboard fsck"

?

Last edited by cfr (2013-07-14 18:51:53)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#31 2013-07-14 18:53:02

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: [SOLVED] Full system encryption with Luks + LVM + 6 HDDs

No, not these days. The lvm2 hook is no longer stateful and ordering doesn't matter.

Offline

#32 2013-07-14 18:55:30

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [SOLVED] Full system encryption with Luks + LVM + 6 HDDs

Cool smile. Thanks. I just remembered when I set this up a while back that the wiki explained the order mattered i.e. different order for LVM-on-LUKS than for LUKS-on-LVM. But there's been at least one major upgrade to lvm2 since then and I am obviously out of date sad.

Last edited by cfr (2013-07-14 18:55:52)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#33 2013-07-14 19:07:35

netpumber
Member
Registered: 2009-09-20
Posts: 127

Re: [SOLVED] Full system encryption with Luks + LVM + 6 HDDs

falconindy wrote:

...did you regenerate the image before you rebooted again? You should see the 'encrypt' hook in the output of 'lsinitcpio -a' and you'll see the hook running at bootup after the second udev hook

You are right (i forgot to recreate the image).. Now the system seems to work. Thanks to all of you.

Offline

#34 2013-07-14 19:33:37

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [SOLVED] Full system encryption with Luks + LVM + 6 HDDs

Glad you figured it all out wink. Please mark the thread [solved] by editing your initial post and tagging the subject line. Thanks!


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB