You are not logged in.

#1 2013-07-20 07:24:54

digitalone
Member
Registered: 2011-08-19
Posts: 81

Booting of LTS kernel stucks at "running early hook [udev]"

Hi everyone. First of all, normal updated kernel works well.
I have problems with LTS kernel. At booting, it stucks at "running early hook [udev]" for 50/60 seconds, and then a message is showed. Something like:
"failed to load firmware: radeon"
"GPU acceleration disabled"
After that, systemd runs perfectly and KDE starts well. But I don't want to wait so much time to boot into LTS kernel, even if I usually use normal kernel (which haven't any issues).

So, what's wrong with LTS kernel? Why is there a problem with graphic card firmware and GPU acceleration?
Shouldn't LTS kernel be more stable then normal kernel?

I got an ATI Radeon HD 4650, and string "MODULES = radeon" is inside mkinitcpio.conf file.

Help me, thanks...

Offline

#2 2013-07-20 17:32:38

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,136

Re: Booting of LTS kernel stucks at "running early hook [udev]"

Well, you may want to check the output of systemd-analyze -blame for clues.  Also, read your journal.
Is the kernel you are running the one you have installed?  Compare the output of uname -a and pacman -Qi linux  ; ensure the versions match.
Also, check your /etc/fstab file and check to see if everything you think should be mounted is actually mounted (check the output of mount)  It may have been waiting for a non existent volume to mount.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#3 2013-07-21 08:38:59

digitalone
Member
Registered: 2011-08-19
Posts: 81

Re: Booting of LTS kernel stucks at "running early hook [udev]"

I wrote on my notebook the exact error message:

r600_cp: Failed to load firmware "radeon/RV770_pfp.bin"
[drm:rv770_startup] *ERROR* Failed to load firmware!
radeon 0000:01:00.0: disabling GPU acceleration
ewaller wrote:

Well, you may want to check the output of systemd-analyze -blame for clues.

# systemd-analyze blame
          6.227s wicd.service
          1.546s systemd-logind.service
          1.360s dev-hugepages.mount
          1.291s polkit.service
          1.239s systemd-modules-load.service
          1.150s systemd-tmpfiles-setup-dev.service
          1.130s dev-mqueue.mount
          1.039s systemd-udev-trigger.service
          1.009s lm_sensors.service
           809ms systemd-sysctl.service
           800ms systemd-vconsole-setup.service
           790ms alsa-restore.service
           775ms systemd-journal-flush.service
           719ms cpupower.service
           709ms systemd-remount-fs.service
           629ms laptop-mode.service
           509ms systemd-tmpfiles-setup.service
           430ms tmp.mount
           359ms systemd-user-sessions.service
           339ms systemd-update-utmp.service
           314ms upower.service
           286ms udisks2.service
           127ms ntpd.service
            78ms dev-disk-by\x2duuid-2a02aaed\x2d938a\x2d44dc\x2da7e5\x2d03133adefded.swap
            71ms systemd-random-seed-load.service
            70ms sys-kernel-debug.mount
            61ms systemd-udevd.service
             1ms sys-fs-fuse-connections.mount
ewaller wrote:

Also, read your journal.

Strange, I don't get many lines as on linux core kernel.

# journalctl -b
-- Logs begin at sab 2012-10-20 12:10:56 CEST, end at dom 2013-07-21 10:15:08 CEST. --
lug 21 10:08:43 archtoshiba systemd-journal[105]: Allowing runtime journal files to grow to 196.5M.
lug 21 10:08:43 archtoshiba systemd-journal[105]: Journal started
lug 21 10:08:43 archtoshiba systemd-modules-load[97]: Inserted module 'acpi_cpufreq'
lug 21 10:08:43 archtoshiba systemd-modules-load[97]: Inserted module 'cpufreq_powersave'
lug 21 10:08:45 archtoshiba systemd-journal[105]: Allowing system journal files to grow to 4.0G.
lug 21 10:08:47 archtoshiba laptop-mode[552]: Laptop mode
lug 21 10:08:47 archtoshiba laptop-mode[553]: enabled, active
lug 21 10:08:48 archtoshiba laptop-mode[675]: Laptop mode
lug 21 10:08:48 archtoshiba laptop-mode[676]: enabled, active
lug 21 10:08:48 archtoshiba systemd[1]: Found device TOSHIBA_MK3263GSXN.                                               
lug 21 10:08:48 archtoshiba systemd[1]: Activating swap /dev/disk/by-uuid/2a02aaed-938a-44dc-a7e5-03133adefded...      
lug 21 10:08:48 archtoshiba systemd[1]: Activated swap /dev/disk/by-uuid/2a02aaed-938a-44dc-a7e5-03133adefded.         
lug 21 10:08:48 archtoshiba systemd[1]: Starting Swap.                                                                 
lug 21 10:08:48 archtoshiba systemd[1]: Reached target Swap.                                                           
lug 21 10:08:48 archtoshiba systemd[1]: Starting System Initialization.                                                
lug 21 10:08:48 archtoshiba systemd[1]: Reached target System Initialization.                                          
lug 21 10:08:48 archtoshiba systemd[1]: Starting ACPID Listen Socket.
lug 21 10:08:48 archtoshiba systemd[1]: Listening on ACPID Listen Socket.
lug 21 10:08:48 archtoshiba systemd[1]: Starting D-Bus System Message Bus Socket.
lug 21 10:08:48 archtoshiba systemd[1]: Listening on D-Bus System Message Bus Socket.
lug 21 10:08:48 archtoshiba systemd[1]: Starting Sockets.
lug 21 10:08:49 archtoshiba systemd[1]: Starting Wicd a wireless and wired network manager for Linux...
lug 21 10:08:49 archtoshiba systemd[1]: Starting D-Bus System Message Bus...
lug 21 10:08:49 archtoshiba systemd[1]: Started D-Bus System Message Bus.
lug 21 10:08:49 archtoshiba systemd[1]: Starting Permit User Sessions...
lug 21 10:08:49 archtoshiba systemd[1]: Started Restore Sound Card State.
lug 21 10:08:49 archtoshiba systemd[1]: Started Apply cpupower configuration.
lug 21 10:08:49 archtoshiba acpid[691]: starting up with proc fs
lug 21 10:08:49 archtoshiba acpid[691]: 4 rules loaded
lug 21 10:08:49 archtoshiba acpid[691]: waiting for events: event logging is off
lug 21 10:08:49 archtoshiba crond[707]: (CRON) INFO (Syslog will be used instead of sendmail.)
lug 21 10:08:49 archtoshiba laptop-mode[727]: enabled, active [unchanged]
lug 21 10:08:49 archtoshiba crond[707]: (root.pacsave) ORPHAN (no passwd entry)
lug 21 10:08:49 archtoshiba crond[707]: (CRON) INFO (running with inotify support)
lug 21 10:08:50 archtoshiba systemd[1]: Started Laptop Mode Tools.
lug 21 10:08:50 archtoshiba systemd[1]: Started Permit User Sessions.
lug 21 10:08:50 archtoshiba systemd[1]: Starting Getty on tty1...
lug 21 10:08:50 archtoshiba systemd[1]: Started Getty on tty1.
lug 21 10:08:50 archtoshiba systemd[1]: Starting Login Prompts.
lug 21 10:08:50 archtoshiba systemd[1]: Reached target Login Prompts.
lug 21 10:08:50 archtoshiba systemd[1]: Starting K Display Manager...
lug 21 10:08:50 archtoshiba systemd[1]: Started K Display Manager.
lug 21 10:08:50 archtoshiba systemd[1]: Started Initialize hardware monitoring sensors.
lug 21 10:08:51 archtoshiba systemd[1]: Started Login Service.
lug 21 10:08:51 archtoshiba systemd-logind[719]: New seat seat0.
lug 21 10:08:55 archtoshiba systemd[1]: Started Wicd a wireless and wired network manager for Linux.
lug 21 10:08:55 archtoshiba systemd[1]: Starting Network.
lug 21 10:08:55 archtoshiba systemd[1]: Reached target Network.
lug 21 10:08:55 archtoshiba systemd[1]: Starting Network Time Service...
lug 21 10:08:56 archtoshiba ntpd[744]: ntpd 4.2.6p5@1.2349-o Thu Jul 18 05:43:38 UTC 2013 (1)
lug 21 10:08:56 archtoshiba ntpd[746]: proto: precision = 0.768 usec
lug 21 10:08:56 archtoshiba ntpd[746]: ntp_io: estimated max descriptors: 1024, initial socket boundary: 16
lug 21 10:08:56 archtoshiba ntpd[746]: Listen and drop on 0 v4wildcard 0.0.0.0 UDP 123
lug 21 10:08:56 archtoshiba ntpd[746]: Listen normally on 1 lo 127.0.0.1 UDP 123
lug 21 10:08:56 archtoshiba ntpd[746]: peers refreshed
lug 21 10:08:56 archtoshiba ntpd[746]: Listening on routing socket on fd #18 for interface updates
lug 21 10:08:56 archtoshiba systemd[1]: Started Network Time Service.
lug 21 10:08:56 archtoshiba systemd[1]: Starting Multi-User System.
lug 21 10:08:56 archtoshiba systemd[1]: Reached target Multi-User System.
lug 21 10:08:56 archtoshiba systemd[1]: Starting Graphical Interface.
lug 21 10:08:56 archtoshiba systemd[1]: Reached target Graphical Interface.
lug 21 10:08:56 archtoshiba systemd[1]: Startup finished in 1min 8.978s (kernel) + 15.978s (userspace) = 1min 24.957s.
lug 21 10:08:56 archtoshiba ntpd[746]: Deferring DNS for 0.pool.ntp.org 1
lug 21 10:08:56 archtoshiba ntpd[746]: Deferring DNS for 1.pool.ntp.org 1
lug 21 10:08:56 archtoshiba ntpd[746]: Deferring DNS for 2.pool.ntp.org 1
lug 21 10:08:56 archtoshiba ntpd[749]: signal_no_reset: signal 17 had flags 4000000
lug 21 10:08:56 archtoshiba dhclient[750]: isc-dhclient-4.2.5-P1
lug 21 10:08:56 archtoshiba dhclient[753]: isc-dhclient-4.2.5-P1
lug 21 10:08:58 archtoshiba ntpd_intres[749]: host name not found: 0.pool.ntp.org
lug 21 10:08:58 archtoshiba ntpd_intres[749]: host name not found: 1.pool.ntp.org
lug 21 10:08:58 archtoshiba ntpd_intres[749]: host name not found: 2.pool.ntp.org
lug 21 10:08:59 archtoshiba systemd-bootchart[90]: Bootchart created: /run/log/bootchart-20130721-1008.svg
lug 21 10:09:05 archtoshiba wicd[697]: dhcpcd[782]: dhcpcd not running
lug 21 10:09:05 archtoshiba dhcpcd[782]: dhcpcd not running
lug 21 10:09:05 archtoshiba wicd[697]: Failed to connect to non-global ctrl_ifname: wlan0  error: No such file or direc
lug 21 10:09:05 archtoshiba wicd[697]: dhcpcd[788]: dhcpcd not running
lug 21 10:09:05 archtoshiba dhcpcd[788]: dhcpcd not running
lug 21 10:09:05 archtoshiba wicd[697]: Failed to connect to non-global ctrl_ifname: eth0  error: No such file or direct
lug 21 10:09:05 archtoshiba wicd[697]: dhcpcd[800]: dhcpcd not running
lug 21 10:09:05 archtoshiba dhcpcd[800]: dhcpcd not running
lug 21 10:09:05 archtoshiba wicd[697]: Failed to connect to non-global ctrl_ifname: wlan0  error: No such file or direc
lug 21 10:09:11 archtoshiba dhcpcd[826]: version 5.6.8 starting
lug 21 10:09:11 archtoshiba dhcpcd[826]: wlan0: rebinding lease of 192.168.0.8
lug 21 10:09:11 archtoshiba dhcpcd[826]: wlan0: acknowledged 192.168.0.8 from 192.168.0.1
lug 21 10:09:11 archtoshiba dhcpcd[826]: wlan0: checking for 192.168.0.8
lug 21 10:09:16 archtoshiba kdm[763]: :0[763]: pam_unix(kde:session): session opened for user giuseppe by (uid=0)
lug 21 10:09:16 archtoshiba dhcpcd[826]: wlan0: leased 192.168.0.8 for 86400 seconds
lug 21 10:09:16 archtoshiba systemd-logind[719]: New session 1 of user giuseppe.
lug 21 10:09:16 archtoshiba systemd-logind[719]: Linked /tmp/.X11-unix/X0 to /run/user/1000/X11-display.
lug 21 10:09:16 archtoshiba dhcpcd[826]: forked to background, child pid 854
lug 21 10:09:18 archtoshiba ntpd[746]: Listen normally on 2 wlan0 192.168.0.8 UDP 123
lug 21 10:09:18 archtoshiba ntpd[746]: peers refreshed
lug 21 10:09:18 archtoshiba ntpd[746]: new interface(s) found: waking up resolver
lug 21 10:09:20 archtoshiba ntpd_intres[749]: DNS 0.pool.ntp.org -> 178.23.121.165
lug 21 10:09:20 archtoshiba ntpd_intres[749]: DNS 1.pool.ntp.org -> 195.216.64.208
lug 21 10:09:20 archtoshiba ntpd_intres[749]: DNS 2.pool.ntp.org -> 85.234.197.1
lug 21 10:09:25 archtoshiba dbus-daemon[721]: dbus[721]: [system] Activating via systemd: service name='org.freedesktop
lug 21 10:09:25 archtoshiba dbus[721]: [system] Activating via systemd: service name='org.freedesktop.UPower' unit='upo
lug 21 10:09:25 archtoshiba systemd[1]: Starting Daemon for power management...
lug 21 10:09:25 archtoshiba dbus-daemon[721]: dbus[721]: [system] Successfully activated service 'org.freedesktop.UPowe
lug 21 10:09:25 archtoshiba dbus[721]: [system] Successfully activated service 'org.freedesktop.UPower'
lug 21 10:09:25 archtoshiba systemd[1]: Started Daemon for power management.
lug 21 10:09:25 archtoshiba dbus-daemon[721]: dbus[721]: [system] Activating via systemd: service name='org.freedesktop
lug 21 10:09:25 archtoshiba dbus[721]: [system] Activating via systemd: service name='org.freedesktop.PolicyKit1' unit=
lug 21 10:09:25 archtoshiba systemd[1]: Starting Authorization Manager...
lug 21 10:09:25 archtoshiba polkitd[932]: Started polkitd version 0.111
lug 21 10:09:26 archtoshiba polkitd[932]: Loading rules from directory /etc/polkit-1/rules.d
lug 21 10:09:26 archtoshiba polkitd[932]: Loading rules from directory /usr/share/polkit-1/rules.d
lug 21 10:09:26 archtoshiba polkitd[932]: Finished loading, compiling and executing 1 rules
lug 21 10:09:26 archtoshiba dbus-daemon[721]: dbus[721]: [system] Successfully activated service 'org.freedesktop.Polic
lug 21 10:09:26 archtoshiba dbus[721]: [system] Successfully activated service 'org.freedesktop.PolicyKit1'
lug 21 10:09:26 archtoshiba systemd[1]: Started Authorization Manager.
lug 21 10:09:26 archtoshiba polkitd[932]: Acquired the name org.freedesktop.PolicyKit1 on the system bus
lug 21 10:09:28 archtoshiba dbus-daemon[721]: dbus[721]: [system] Activating via systemd: service name='org.freedesktop
lug 21 10:09:28 archtoshiba dbus[721]: [system] Activating via systemd: service name='org.freedesktop.UDisks2' unit='ud
lug 21 10:09:28 archtoshiba systemd[1]: Starting Disk Manager...
lug 21 10:09:28 archtoshiba udisksd[982]: udisks daemon version 2.1.0 starting
lug 21 10:09:28 archtoshiba dbus-daemon[721]: dbus[721]: [system] Successfully activated service 'org.freedesktop.UDisk
lug 21 10:09:28 archtoshiba dbus[721]: [system] Successfully activated service 'org.freedesktop.UDisks2'
lug 21 10:09:28 archtoshiba systemd[1]: Started Disk Manager.
lug 21 10:09:28 archtoshiba udisksd[982]: Acquired the name org.freedesktop.UDisks2 on the system message bus
lug 21 10:09:28 archtoshiba dbus-daemon[721]: dbus[721]: [system] Activating service name='org.kde.powerdevil.backlight
lug 21 10:09:28 archtoshiba dbus[721]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using ser
lug 21 10:09:29 archtoshiba org.kde.powerdevil.backlighthelper[990]: QDBusConnection: system D-Bus connection created b
lug 21 10:09:29 archtoshiba dbus-daemon[721]: dbus[721]: [system] Successfully activated service 'org.kde.powerdevil.ba
lug 21 10:09:29 archtoshiba dbus[721]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
lug 21 10:09:31 archtoshiba dbus-daemon[721]: dbus[721]: [system] Activating via systemd: service name='org.freedesktop
lug 21 10:09:31 archtoshiba dbus[721]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus
lug 21 10:09:31 archtoshiba dbus-daemon[721]: dbus[721]: [system] Activation via systemd failed for unit 'dbus-org.free
lug 21 10:09:31 archtoshiba dbus[721]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.serv
lug 21 10:09:53 archtoshiba polkitd[932]: Registered Authentication Agent for unix-session:1 (system bus name :1.18 [/u
lug 21 10:10:05 archtoshiba systemd[1]: Mounting FUSE Control File System...
lug 21 10:10:05 archtoshiba systemd[1]: Mounted FUSE Control File System.
lug 21 10:12:34 archtoshiba systemd[1]: Time has been changed
lug 21 10:15:08 archtoshiba su[3134]: (to giuseppe) giuseppe on none
lug 21 10:15:08 archtoshiba su[3134]: pam_unix(su-l:session): session opened for user root by giuseppe(uid=1000)
ewaller wrote:

Is the kernel you are running the one you have installed?

I have normal kernel (linux) and LTS kernel (linux-lts) installed.

ewaller wrote:

Compare the output of uname -a and pacman -Qi linux  ; ensure the versions match.

# uname -a
Linux archtoshiba 3.0.85-1-lts #1 SMP Wed Jul 3 22:02:40 CEST 2013 x86_64 GNU/Linux

# pacman -Qi linux-lts
Nome           : linux-lts
Versione       : 3.0.85-1

They match.

ewaller wrote:

Also, check your /etc/fstab file and check to see if everything you think should be mounted is actually mounted (check the output of mount)  It may have been waiting for a non existent volume to mount.

# 
# /etc/fstab: static file system information
#
# <file system>        			   	<dir>			<type>	<options>	<dump>	<pass>
devpts                 			   	/dev/pts     		devpts	defaults 	0      	0
shm                    			   	/dev/shm     		tmpfs	nodev,nosuid   	0      	0
UUID=2a02aaed-938a-44dc-a7e5-03133adefded 	swap			swap 	defaults 	0 	0
UUID=6cd6d281-1936-4d6f-b790-f4b38fd848ce 	/ 			ext4	defaults 	0 	1
debugfs   					/sys/kernel/debug   	debugfs defaults  	0  	0
# mount
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
dev on /dev type devtmpfs (rw,nosuid,relatime,size=2009572k,nr_inodes=502393,mode=755)
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
/dev/sda6 on / type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,relatime)
devpts on /dev/pts type devpts (rw,relatime,mode=600,ptmxmode=000)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=25,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
tmpfs on /tmp type tmpfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)

I think there should be all.

So, what's now?

Last edited by digitalone (2013-07-21 08:48:18)

Offline

#4 2013-07-21 14:14:21

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,095
Website

Re: Booting of LTS kernel stucks at "running early hook [udev]"

get rid of devpts, shm and debugfs from your fstab -- systemd already mounts these for you.

Honestly, best advice I can give you is to stop using the lts kernel. Arch userspace is generally too new for it.

digitalone wrote:

Shouldn't LTS kernel be more stable then normal kernel?

No. This is a farce.

Offline

#5 2013-07-21 14:36:03

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Booting of LTS kernel stucks at "running early hook [udev]"

If you want an LTS kernel, and are willing it build it, there is the linux-lts34 package in the AUR.  I have used it in the past with great success. 

I have since moved to btrfs which requires that I stick with newer kernel versions and cannot use older ones because of changes.  But I used the 3.4 LTS kernel for a few months actually. What was nice is that it is actually new enough to enjoy the ability to use EFISTUB and gummiboot (like everything else on my machine).

Offline

#6 2013-07-23 07:42:30

digitalone
Member
Registered: 2011-08-19
Posts: 81

Re: Booting of LTS kernel stucks at "running early hook [udev]"

falconindy wrote:

get rid of devpts, shm and debugfs from your fstab -- systemd already mounts these for you.

Done.

falconindy wrote:

Honestly, best advice I can give you is to stop using the lts kernel. Arch userspace is generally too new for it.

digitalone wrote:

Shouldn't LTS kernel be more stable then normal kernel?

No. This is a farce.

So, why is it in core repo yet?

Offline

Board footer

Powered by FluxBB