You are not logged in.

#1 2013-07-18 21:57:15

beachcoder
Member
Registered: 2009-10-08
Posts: 97

[SOLVED] Wlan not working on my T400 / rfkill: WLAN hard blocked

Hello!

In the past, my WLAN worked fine on my T400.
Now, I did an update after a long time and get the following error messages:

$ ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill
$ netcfg my-wlan up 
:: my-wlan up                                                    [ BUSY ] Successfully initialized wpa_supplicant
rfkill: WLAN hard blocked
Could not set interface wlan0 flags (UP): Operation not possible due to RF-kill
                                                                       [FAILED]
$ rfkill list all
0: tpacpi_bluetooth_sw: Bluetooth
        Soft blocked: yes
        Hard blocked: yes
1: tpacpi_wwan_sw: Wireless WAN
        Soft blocked: yes
        Hard blocked: yes
2: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes

Does somebody have an idea how to fix this?
Please don't tell me to compile my own kernel, it's the current stock kernel:

Linux kestrel 3.9.9-1-ARCH #1 SMP PREEMPT Wed Jul 3 22:45:16 CEST 2013 x86_64 GNU/Linux

Thanks in advance!!

Last edited by beachcoder (2013-07-19 06:50:25)

Offline

#2 2013-07-19 00:39:02

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Wlan not working on my T400 / rfkill: WLAN hard blocked

Considering it is a ThinkPad, I assume you probably have a physical switch that controls the wifi, yes?  Typically that is what is meant by "hard blocked". 

In other words, a "soft block" is the machine saying that this device has been put down by software means, and it can bring it back up for you.  While a "hard block" is the machine saying that it knows there is a device there, but there is something beyond software control that is keeping it down.

Offline

#3 2013-07-19 01:40:07

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,199
Website

Re: [SOLVED] Wlan not working on my T400 / rfkill: WLAN hard blocked

I don't know why anyone would tell you to compile a kernel.  Unless it was as some sort of penance, or hazing.  It wouldn't be relevant to the problem.

Checking harware switches will be relevant, and running `rfkill unblock all` would be a usefull (and I would think obvious) first step.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2013-07-19 06:40:25

beachcoder
Member
Registered: 2009-10-08
Posts: 97

Re: [SOLVED] Wlan not working on my T400 / rfkill: WLAN hard blocked

Hello!

WonderWoofy wrote:

Considering it is a ThinkPad, I assume you probably have a physical switch that controls the wifi, yes?  Typically that is what is meant by "hard blocked".

Yes, it is a ThinkPad T400, but I can't see there any possibility to switch Wlan on or off by any function key. In the web, I found that "Fn+F5" should do that, but I pressed it several times and nothing happend, it is still "hard blocked". The WLAN-LED turned on in the past when it connected to a WLAN-network, but now it's aways off. In BIOS, WLAN-Features are activated, and I also didn't change anything of these here.

Trilby wrote:

Checking harware switches will be relevant, and running `rfkill unblock all` would be a usefull (and I would think obvious) first step.

Running `rfkill unblock all` doesn't change anything.

Thanks for any further help on this topic.

- beachcoder

Offline

#5 2013-07-19 06:49:30

beachcoder
Member
Registered: 2009-10-08
Posts: 97

Re: [SOLVED] Wlan not working on my T400 / rfkill: WLAN hard blocked

Mea culpa! I'm a stupid idiot...

Now I know where my "WLAN Hard Block"-button is.
Thanks a lot! wink

Offline

#6 2013-07-20 19:36:59

kzoli429
Member
Registered: 2013-07-20
Posts: 3

Re: [SOLVED] Wlan not working on my T400 / rfkill: WLAN hard blocked

Hi beachcoder,
I've just bought a used T400, and I'm in the process of installing Arch.
I'd be damn interested what THAT magic key combination you found to turn on Wlan as Fn+F5 doesn't seem to work.
Thanks in advance,

Offline

#7 2013-07-20 19:49:24

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Wlan not working on my T400 / rfkill: WLAN hard blocked

@kzoli429, please use the google.  When I search for "T400 wifi switch" I can get an answer from the very first result (as well as countless results after).  It is a physical switch, not a button combo.  The button combo is only in newer thinkpads I think.

Offline

#8 2013-07-20 19:51:39

kzoli429
Member
Registered: 2013-07-20
Posts: 3

Re: [SOLVED] Wlan not working on my T400 / rfkill: WLAN hard blocked

Oh hell,
I couldn't went to sleep without finding it; slide switch (RFKILL) on the front edge, left side near the firewire connector.
Day off tomorrow, thanks to Lenovo.

Offline

#9 2013-07-28 01:46:18

gtolden
Member
Registered: 2013-07-20
Posts: 13

Re: [SOLVED] Wlan not working on my T400 / rfkill: WLAN hard blocked

Ha, I just encountered the same issue with my dell vostro 5460. I couldn't use wifi either in windows or arch and windows suggested me to turn on the physical switch while there are just NO PHYSICAL SWITCH  BESIDES POWER BUTTON on this ultrabook.
Then I noticed the "Function Key enabled" in BIOS and thought there might be something with these. So I tried it (F2 on my laptop, with a picture of a signal tower), press it once and type "sudo rfkill list all", and here it goes:

$sudo rekill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
$sudo rekill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
$sudo rekill list all
0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
$sudo rekill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
$sudo rekill list all
0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
$sudo rekill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
$sudo rekill list all
0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
$sudo rekill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

SO problem solved, that remind us never ignore the keyboard when system tell you to find a physical swtich

cheers,
gtolden

Last edited by gtolden (2013-07-28 01:47:29)

Offline

Board footer

Powered by FluxBB