You are not logged in.

#1 2013-07-26 23:48:46

kyzys
Member
Registered: 2013-06-14
Posts: 9

[SOLVED] Compton Tearing Predicament

Hello I run compton at startup with the following options in order to fix tearing in video games and programs such as firefox.

compton --opengl --vsync opengl-swc --paint-on-overlay -b

However with compton running I get pretty bad tearing in urxvt.
I have tried many things such as enabling tripple buffering and other various nvidia settings, but it seems I need an opengl composite manager to have smooth games/firefox scrolling.
If anyone has any suggestions as to what to do, that would be fantastic. Thank you.

Edit: Solved by changing

URxvt*.depth:

from 32 to 24.

Last edited by kyzys (2013-07-27 20:49:51)

Offline

#2 2013-07-27 06:48:32

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [SOLVED] Compton Tearing Predicament

Have you installed vdpau yet (libva-vdpau-driver)?

https://wiki.archlinux.org/index.php/NV … 2FVAAPI.29

Have you turned on vsync (syncing to vblank is one of the options in nvidia-settings)?

Offline

#3 2013-07-27 07:32:25

xpander
Member
Registered: 2013-01-23
Posts: 56

Re: [SOLVED] Compton Tearing Predicament

allow flipping must be enabled from nvidia-settings to get the effect of that compton command in opengl games
there is still small tearing then, but its pretty small and you hardly notice that

Offline

#4 2013-07-27 08:11:43

brebs
Member
Registered: 2007-04-03
Posts: 3,456

Re: [SOLVED] Compton Tearing Predicament

Last time I tried compton, about 2 months ago - should be no tearing at all with:

compton -b --backend glx --vsync opengl-swc

The TripleBuffer option in xorg.conf is strange - in the past it has disabled vsync, but with nvidia 313.30 it has quite a nice kinda "mostly vsync" effect.

Flipping has no effect on vsync, in my experience. Flipping, if turned on, has caused my PC to hang roughly once a day, prior to nvidia 313.30

Edit: Bah, flipping is better, but still not perfectly reliable - I've disabled it again.

Last edited by brebs (2013-07-30 09:32:09)

Offline

#5 2013-07-27 15:19:55

kyzys
Member
Registered: 2013-06-14
Posts: 9

Re: [SOLVED] Compton Tearing Predicament

I have done the vdpau installation, have sync to vblank enabled and flipping enabled.
Everything runs fine except I get tearing in urxvt and xterm around 1/5th from the bottom very consistently.
If I kill Compton to edit files and such its alright but id rather not if at all possible.
Thank for all of the suggestions thus far

Last edited by kyzys (2013-07-27 16:05:49)

Offline

#6 2013-07-27 19:41:35

xpander
Member
Registered: 2013-01-23
Posts: 56

Re: [SOLVED] Compton Tearing Predicament

flipping has effect to my vsync with the same compton command as OP posted.
it tears like hell when flipping is disabled for me.. in opengl games that is. in desktop i dont notice the tearing.
with xterm i cant see any tearing also.. havent tried urxvt (dont know what it is)

Offline

#7 2013-07-27 20:48:10

kyzys
Member
Registered: 2013-06-14
Posts: 9

Re: [SOLVED] Compton Tearing Predicament

Solved by changing

URxvt*.depth:

from 32 to 24.
Thanks for all of the responses

Offline

#8 2014-11-21 16:13:55

dmp1ce
Member
Registered: 2014-05-30
Posts: 10

Re: [SOLVED] Compton Tearing Predicament

compton -b --backend glx --vsync opengl-swc

This solved my problem.  I would see tearing in full screen video games and movies.  Here is a good test to see if you have tearing https://www.youtube.com/watch?v=5xkNy9gfKOg  I just turn on compton when the tearing starts to bother me.

Shouldn't some full screen video games try to enable vsync for you?

Offline

#9 2014-11-23 12:19:11

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,190
Website

Re: [SOLVED] Compton Tearing Predicament

Please do not "necrobump" old threads, particularly solved ones.


Closed.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB