You are not logged in.

#1 2013-07-28 10:18:11

pcworld
Member
From: Germany
Registered: 2013-07-28
Posts: 6
Website

Forum registration question does not work if DST is enabled

The forum software didn't accept my output of

date -u +%V$(uname)|sha256sum|sed 's/\W//g'

until I deselected "Daylight Savings Time is in effect (advance time by 1 hour).".
I guess this is a bug, right? Or is it a way to keep users off this forum who don't find that out by themselves (which also means this thread will be deleted)?

Offline

#2 2013-07-28 10:58:45

WorMzy
Forum Moderator
From: England
Registered: 2010-06-16
Posts: 5,040

Re: Forum registration question does not work if DST is enabled

DST shouldn't make any difference, UTC is UTC.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#3 2013-07-28 10:59:51

pcworld
Member
From: Germany
Registered: 2013-07-28
Posts: 6
Website

Re: Forum registration question does not work if DST is enabled

WorMzy wrote:

DST shouldn't make any difference, UTC is UTC.

But apparently, it did. At least, after many many tries, registration worked as soon as I deselected the DST checkbox.

Offline

#4 2013-07-28 11:03:45

WorMzy
Forum Moderator
From: England
Registered: 2010-06-16
Posts: 5,040

Re: Forum registration question does not work if DST is enabled

What checkbox is this?

Can you post the output of 'timedatectl'.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#5 2013-07-28 11:07:06

pcworld
Member
From: Germany
Registered: 2013-07-28
Posts: 6
Website

Re: Forum registration question does not work if DST is enabled

"Daylight Savings Time is in effect (advance time by 1 hour)" on https://bbs.archlinux.org/register.php.
I don't have timedatectl on my OS, but it shouldn't have to do anything with my OS, since the sha256sum of "30Linux" didn't work with DST on the registration page enabled, but worked as soon as I deselected that checkbox.

Offline

#6 2013-07-28 17:27:59

WorMzy
Forum Moderator
From: England
Registered: 2010-06-16
Posts: 5,040

Re: Forum registration question does not work if DST is enabled

Ah, I see. I thought you were changing the DST setting on your OS, and that was changing the hash you get out of the command.

Yes, I'd agree that it is a bug.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

Board footer

Powered by FluxBB