You are not logged in.

#1 2005-12-22 22:04:26

kristian
Member
From: Norway
Registered: 2005-06-03
Posts: 24

All terminal-emulators fail to start. Alt-keys fails[solved]

I just did a fresh install from "Arch Linux base 7.0". And ran into a couple of problems.

None of the terminal-emulators I've installed works. I have tried urxvt, xterm and gnome-terminal. Gnome-termninal actually starts, but all I get is this errormassage:

There was an error creating the child process for this terminal

I'm getting a flashing cursor but no comandline. Nothing that I type  on my keyboard gets registered.

On top of that my alt-keys will not work. Witch means that I'm unable to leave X with ctrl-alt-F1. And I'm not able to type letters like: @ (without Character map (On norwegian keyboards @=AltGr+2 )

To sum it up: I have no access to the commandline. (while X is running) :cry:

Offline

#2 2005-12-23 14:21:21

kristian
Member
From: Norway
Registered: 2005-06-03
Posts: 24

Re: All terminal-emulators fail to start. Alt-keys fails[solved]

Problem solved. At leࢮast the terminal-emulators works. I had missed a few points in fstab. The right settings was found here

The clue is to find the right term to google for. In my case it was the errormessage gnome-terminal gave me (In the code-box above).

Just one error left to deal with. Alt keys still won't work.

Offline

#3 2005-12-23 14:38:27

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: All terminal-emulators fail to start. Alt-keys fails[solved]

kristian wrote:

On top of that my alt-keys will not work. Witch means that I'm unable to leave X with ctrl-alt-F1. And I'm not able to type letters like: @ (without Character map (On norwegian keyboards @=AltGr+2 )

Try commenting the "load dead keys" option in xorg.conf

Offline

#4 2005-12-23 14:53:36

kristian
Member
From: Norway
Registered: 2005-06-03
Posts: 24

Re: All terminal-emulators fail to start. Alt-keys fails[solved]

Thanks, it works now. I did several changes to the keyboardsection of xorg.conf. So I'm not sure if your tip was what I needed. My xorg.conf was generated by "hwd -x". I should have looked closer when I reviewed it before using it :oops:

Offline

Board footer

Powered by FluxBB