You are not logged in.

#1 2013-07-28 02:57:54

ignorant
Member
Registered: 2012-06-09
Posts: 50

Kernel 3.10 broken on Asus Zenbook Prime ux31a

After upgrading from kernel 3.9.8 to kernel 3.10.3 and rebooting today, I chose my boot entry from grub and saw root get fscked as usual, but as soon as the screen flickered (as far as I understand, that's usually a sign that the kernel has loaded the video drivers) I was presented with a blank screen. I alt+sysrq+REISUB'd out, powered off at the next grub screen, booted up again and got the same result. Eventually, I booted a liveusb arch image and downgraded my kernel to 3.9.8, rebooted, and the problem was gone. After poking around through journalctl, there doesn't appear to be any logs at all. Any other ux31a users having this issue?

edit: After some googling, I've found at least on other person with a similar, but different (I do not have an external monitor), issue: http://ubuntuaddict.com/kernel-3-10-x-r … -only.html

Last edited by ignorant (2013-07-28 04:45:54)

Offline

#2 2013-07-28 03:21:51

chliny
Member
Registered: 2012-08-26
Posts: 1

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

I have the same problem,and my laptop is acer aspre 4752g

Offline

#3 2013-07-29 06:33:59

damur
Member
Registered: 2013-07-29
Posts: 1

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

On my UX31A screen backlight is off after boot. I can switch it on with fn+f6. But it's still buggy

Offline

#4 2013-07-30 01:50:37

lakerssuperman
Member
Registered: 2013-07-30
Posts: 23

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

I get the same issue on openSUSE running any kernel in the 3.10 and now the 3.11-rc series.  The computer is still booting, but the display isn't being turned on beyond the backlight.  This thread seems to deal with this issue, but the problem persists even in the 3.11-rc3 kernel I just compiled.

https://bugs.launchpad.net/ubuntu/+sour … bug/946311

Offline

#5 2013-07-31 13:15:48

Maggeych
Member
Registered: 2013-05-27
Posts: 9

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

Same problem here with an Asus Zenbook UX32VD... Blank screen after boot, backlight is on and I seem to be able to login, open a console and reboot via keyboard shortcuts.
I guess I'll have to downgrade with the liveusb as well.

Offline

#6 2013-08-01 08:19:34

Rmx
Member
Registered: 2013-08-01
Posts: 1

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

Same problem on my ASUS Zenbook Prime UX31A: since Arch has updated the kernel from version 3.9 to version 3.10, the display shuts off after the early stages of booting.

I tried several solutions found on the internet (kernel parameters, mkinitcpio.conf, ...), and there are only two that work for me:

1. Add "i915.modeset=0" or "nomodeset" kernel parameters, but then X11 doesn't work anymore as it now depends on KMS
2. Downgrade the kernel to a previous version (3.9.9) and lock the linux and linux-headers packages (best current solution)...

Last edited by Rmx (2013-08-01 08:20:22)

Offline

#7 2013-08-01 11:16:17

karras
Member
Registered: 2013-07-07
Posts: 16

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

Same problems with my ASUS UX31VD after a fresh installation. Screen stays blank after boot and I am able to reboot by entering the credentials "blind".
When using an external monitor, HDMI in my case, the screen is displayed correctly.

I've opened a post on "Installation" some days ago: https://bbs.archlinux.org/viewtopic.php?id=167297

Last edited by karras (2013-08-01 11:26:07)

Offline

#8 2013-08-01 16:54:39

jolivier
Member
Registered: 2012-05-30
Posts: 14

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

I have the same problem on my Zenbook Prime UX31A, has any of you succeeded in solving it using the video= kernel parameter as described https://wiki.archlinux.org/index.php/Ke … de_Setting or https://wiki.archlinux.org/index.php/ATI? I tried video=eDP-1:e video=HDMI-A-1:d but could only disable all my screens.

Offline

#9 2013-08-02 04:06:56

lakerssuperman
Member
Registered: 2013-07-30
Posts: 23

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

I forgot to mention that booting with "nomodeset" gave me a working screen on boot.  Unfortunately, this also disabled Opengl desktop effects in KDE.  Not an ideal situation.  I have not tried anything beyond that, but I will read over those links.

Offline

#10 2013-08-02 04:11:29

lakerssuperman
Member
Registered: 2013-07-30
Posts: 23

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

https://ask.fedoraproject.org/question/ … ernel-310/

Seems the Fedora folks are having some issues as well.

Offline

#11 2013-08-02 18:11:15

Blacktremolo
Member
Registered: 2013-08-02
Posts: 1

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

This issue started to occur to me today after I upgraded the BIOS from rev. 208 to rev. 209.

Offline

#12 2013-08-05 19:24:31

karras
Member
Registered: 2013-07-07
Posts: 16

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

Have a look at: https://bugzilla.kernel.org/show_bug.cgi?id=59841

My screen works fine when booting (gummiboot) with bios compatibility support module enabled. Not a solution but a temporary workaround till the patch is implemented in the latest kernel.

Last edited by karras (2013-08-05 19:25:50)

Offline

#13 2013-08-06 00:33:18

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

Have you all tried to setup early KMS?  That is, having i915 included in and loaded early by the initramfs?  Just specify MODULES="i915" in /etc/mkinitpcio.conf and regernate.

Offline

#14 2013-08-06 00:44:50

archtaku
Member
Registered: 2010-07-02
Posts: 84

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

I had not. I added it and this seems to have taken care of the issue. I wonder what changed that this was not necessary before.

Offline

#15 2013-08-06 02:22:30

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

This has been a hit or miss necessity for some time now.  It is included in the wiki page on Intel graphics.

Offline

#16 2013-08-06 05:26:56

archtaku
Member
Registered: 2010-07-02
Posts: 84

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

.... Well, that was shortlived. Next reboot was back to the old problem, had to roll back again.

Offline

#17 2013-08-17 22:45:54

alexey
Member
Registered: 2012-03-29
Posts: 56

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

Same problem. Tried many things: early kms, removing all i915 settings from /etc/modprobe.d/*. tried latest 3.10.6 kernel.. no luck
nomodeset works but no X (no fb)

Last edited by alexey (2013-08-17 22:46:19)

Offline

#18 2013-08-20 02:33:19

gsf747
Member
Registered: 2013-07-16
Posts: 3

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

Offline

#19 2013-08-20 22:00:51

Venemo
Member
From: Budapest, Hungary
Registered: 2013-08-20
Posts: 4

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

gsf747 wrote:

Yes, it's the exact same issue.

Offline

#20 2013-08-25 23:54:46

alexey
Member
Registered: 2012-03-29
Posts: 56

Re: Kernel 3.10 broken on Asus Zenbook Prime ux31a

Hi Guys,

Please check my thread regarding this problem, i used a small hack to fix this issue:

https://bbs.archlinux.org/viewtopic.php … 1#p1316891

Offline

Board footer

Powered by FluxBB