You are not logged in.

#1 2013-07-31 17:54:25

From: berlin
Registered: 2012-01-13
Posts: 95

[SOLVED] [AO_ALSA] Write error: Broken pipe

Hey *!
i have a problem with my sound. it's kinda weird. when i watch a movie with
mplayer i get frequently this error:

[AO_ALSA] Write error: Broken pipe
[AO_ALSA] Trying to reset soundcard.

in this case it was a .mp4-file. the music frequently pauses (because of the error) until mplayer
crashes after ~20min. the strange thing is that its happening with my
onboard-chip and my external soundcard (NI Audio 2) and alsamixer shows Pulseaudio and if i switch the devices to HDA Intel w/ Conexant ID 5051 up .

my hardware ($ lspci -k):

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
	Subsystem: Lenovo Device 20f2
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

lenovo x200 w/ archlinux 64 w/ herbstluftwm (no DE that does magic and stuff) and optionally a Native Instruments Audio2(driver compiled in kernel since 2.6.?).

my sound related packages:

 flexo at scruffy in ~ 
$ yaourt -Q | grep alsa
extra/alsa-firmware 1.0.27-2
extra/alsa-oss 1.0.25-1
extra/alsa-plugins 1.0.27-1
extra/alsa-tools 1.0.27-4
extra/pulseaudio-alsa 2-2
flexo at scruffy in ~ 
$ yaourt -Q | grep pulse     
extra/libcanberra-pulse 0.30-4
extra/libpulse 4.0-2
extra/pulseaudio 4.0-2
extra/pulseaudio-alsa 2-2
flexo at scruffy in ~ 
$ yaourt -Q | grep pavu 
extra/pavucontrol 2.0-1

my sound related loaded modules:

flexo at scruffy in ~ 
$ lsmod | grep snd
snd_hda_intel          35341  3 
snd_hda_codec         146194  1 snd_hda_intel
snd_hwdep               6300  1 snd_hda_codec
snd_pcm                76357  2 snd_hda_codec,snd_hda_intel
snd_page_alloc          7202  2 snd_pcm,snd_hda_intel
snd_timer              18526  1 snd_pcm
snd                    58790  12 snd_hwdep,snd_timer,snd_pcm,snd_hda_codec,snd_hda_intel,thinkpad_acpi
soundcore               5418  1 snd 

the things is tried(similar to thread with no luck:


$ cat /etc/modprobe.d/alsa.conf 
options snd-hda-intel model=generic position_fix=1 power_save=0 power_save_controller=Y

with model=thinkapd and laptop, w/ and w/o powersave and position fix and slots. I didn't tried to deinstall pulseaudio because of the comfort it serves with more than one soundcard.

EDIT: forgot to mention that it appears with linux-ck (repo-ck) and linux (stock ARCH kernel). i didn't use an custom /etc/asound.conf or pulse confs.

Any suggestions?
Thanks, flexo

EDIT: seems that i solved the problem by reinstalling complete alsa/pulseaudio/audio/mplayer/codecs, removing all cookies and cache-files and add to $HOME/.mplayer/conf


Last edited by flexo3001 (2013-08-02 16:39:08)

Fight war not wars, destroy power not people!


Board footer

Powered by FluxBB