You are not logged in.

#1 2013-08-02 22:00:21

DevPug
Member
Registered: 2013-07-26
Posts: 7

Steam needs to be online to update?

As you can see, my internet is just fine, but Steam can't seem to find it. I just downloaded it from the official repository (also picked up all the recommended packages, suggested by the wiki). No matter how I open Steam (from terminal or icon), it briefly flashes the update screen, then follows with "Fatal error: Steam needs to be online to update."

Has anyone else had this problem recently? I've seen other complaints about this error, but they are outdated by several months or apply to a different Linux distro, and often don't have any solution!

Offline

#2 2013-08-02 22:21:20

DevPug
Member
Registered: 2013-07-26
Posts: 7

Re: Steam needs to be online to update?

Alright, so it randomly started downloading, and then stopped again.

Here is the original error:

Running Steam on arch  64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0_client)
Installing breakpad exception handler for appid(steam)/version(1.0_client)
Installing breakpad exception handler for appid(steam)/version(1.0_client)
Installing breakpad exception handler for appid(steam)/version(1.0_client)
Installing breakpad exception handler for appid(steam)/version(1.0_client)
Assert( Assertion Failed: Illegal termination of worker thread 'Thread(0x0x9cd69f0/0x0xf5a1fb4' ):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/tier0/threadtools.cpp:3024

Installing breakpad exception handler for appid(steam)/version(1.0_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/assert_20130802181444_1.dmp
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2013-08-02 18:14:33] Startup - updater built Apr 30 2013 10:04:24
[2013-08-02 18:14:33] Verifying installation...
[2013-08-02 18:14:33] Unable to read and verify install manifest /home/bigpug/.local/share/Steam/package/steam_client_ubuntu12.installed
[2013-08-02 18:14:33] Verification complete
[2013-08-02 18:14:33] Downloading Update...
[2013-08-02 18:14:33] Checking for available update...
[2013-08-02 18:14:39] Package file strings_all.zip.223ae7c1117de9ac21e92bc719c645dc9ce161c1 missing or incorrect size
[2013-08-02 18:14:39] Package file resources_all.zip.be469e8af8dc3ce6147f7bad396108e18a1a20f6 missing or incorrect size
...
[2013-08-02 18:14:39] Downloading update (0 of 162,370 KB)...
[2013-08-02 18:14:40] Error: Download of package (runtime_part0_ubuntu12) failed after 0 bytes (0).
[2013-08-02 18:14:40] Download Complete.
[2013-08-02 18:14:40] Error: Steam needs to be online to update.  Please confirm your network connection and try again.
[2013-08-02 18:14:42] Shutdown
CWorkThreadPool::~CWorkThreadPool: work complete queue not empty, 6 items discarded.
/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/tier0/threadtools.cpp (3024) : Assertion Failed: Illegal termination of worker thread 'Thread(0x0x9cd69f0/0x0xf5a1fb4'
Installing bootstrap /home/bigpug/.local/share/Steam/bootstrap.tar.xz
Running Steam on arch  64-bit
STEAM_RUNTIME has been set by the user to: /home/bigpug/.local/share/Steam/ubuntu12_32/steam-runtime
Installing breakpad exception handler for appid(steam)/version(0_client)
Installing breakpad exception handler for appid(steam)/version(1.0_client)
Installing breakpad exception handler for appid(steam)/version(1.0_client)
Finished uploading minidump (out-of-process): success = yes
response: CrashID=bp-af1e25cd-f2b2-49f6-8f34-571dd2130802
Installing breakpad exception handler for appid(steam)/version(1.0_client)
Installing breakpad exception handler for appid(steam)/version(1.0_client)
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2013-08-02 18:14:45] Startup - updater built Apr 30 2013 10:04:24
[2013-08-02 18:14:45] Verifying installation...
[2013-08-02 18:14:45] Unable to read and verify install manifest /home/bigpug/.local/share/Steam/package/steam_client_ubuntu12.installed
[2013-08-02 18:14:45] Verification complete
[2013-08-02 18:14:45] Downloading Update...
[2013-08-02 18:14:45] Checking for available update...
[2013-08-02 18:14:46] Package file strings_all.zip.223ae7c1117de9ac21e92bc719c645dc9ce161c1 missing or incorrect size
[2013-08-02 18:14:46] Package file resources_all.zip.be469e8af8dc3ce6147f7bad396108e18a1a20f6 missing or incorrect size
[2013-08-02 18:14:46] Package file tenfoot_all.zip.8a17505b3fb0016f4992f01edf0b96721d3b0822 missing or incorrect size
...
[2013-08-02 18:14:46] Downloading update (0 of 162,370 KB)...
[2013-08-02 18:14:46] Downloading update (60 of 162,370 KB)...
[2013-08-02 18:14:46] Downloading update (373 of 162,370 KB)...

And then later it stopped!

[2013-08-02 18:16:53] Error: Download of package (bins_ubuntu12) failed after 0 bytes (0).
[2013-08-02 18:16:53] Download Complete.
[2013-08-02 18:16:53] Error: Steam needs to be online to update.  Please confirm your network connection and try again.
[2013-08-02 18:16:55] Shutdown
/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/tier0/threadtools.cpp (3024) : Assertion Failed: Illegal termination of worker thread 'Thread(0x0xa21d9f0/0x0xf59f7b4'
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/assert_20130802181656_1.dmp
Finished uploading minidump (out-of-process): success = yes
response: CrashID=bp-3d5183ad-5cce-4b89-8a78-970332130802

I mean, it's great that SOMETIMES it works, but if anyone knows why it suddenly stops...?

Offline

#3 2013-08-02 23:56:19

DevPug
Member
Registered: 2013-07-26
Posts: 7

Re: Steam needs to be online to update?

Sigh. It eventually updated (I just kept closing and opening it until it worked). NOW it's convinced it has an openGL issue.

My Intel drivers are all updated, I have Mesa, and multilib is enabled... What now, Steam?

Offline

#4 2013-08-03 00:08:05

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 5,698
Website

Re: Steam needs to be online to update?

Please use the edit button to add information to your last post if no one else has replied since then. Also post the actual error instead of "now it's convinced it has an openGL issue".

Offline

#5 2013-08-03 07:14:20

ChemBro
Member
Registered: 2008-10-22
Posts: 677

Re: Steam needs to be online to update?

DevPug wrote:

My Intel drivers are all updated, I have Mesa, and multilib is enabled... What now, Steam?

32bit version of your video driver. Steam is a 32bit application (with support for 64bit games), thus it needs the 32bit driver.

Offline

Board footer

Powered by FluxBB