You are not logged in.

#1 2004-01-27 15:47:16

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

gaim has 12 remote overflows in current version

hi,

There have been a dozen overflows reported to be in gaim. I'm not capable to say how serious this is. Details can be found here:

http://security.e-matters.de/advisories/012004.html

a patch done by FreeBSD-Team is here:
http://security.e-matters.de/patches/gaim-0.75-fix.diff

thogh its claimed to be different from fixes done in gaim CVS.
Here is a modified PKGBUILD - note pkgrel is already increased.

# Maintainer: dorphell <dorphell@archlinux.org>
# Contributor: Lucien Immink <l.immink@student.fnt.hvu.nl>
pkgname=gaim
pkgver=0.75
pkgrel=2
pkgdesc="A GTK+-based messaging client"
url="http://gaim.sourceforge.net"
depends=('startup-notification' 'gtk2' 'libao' 'gnutls' 'tk')
source=(http://umn.dl.sourceforge.net/sourceforge/gaim/gaim-$pkgver.tar.bz2
                http://security.e-matters.de/patches/ga … -fix.diff)

build() {
  cd $startdir/src/$pkgname-$pkgver
  patch -p0 -i ../gaim-0.75-fix.diff
  ./configure --prefix=/usr
  make || return 1
  make DESTDIR=$startdir/pkg install
  rm $startdir/pkg/usr/lib/perl5/*/$CARCH-linux/perllocal.pod
}

I will post the same texte to the bugtracker.

bye neri

Offline

#2 2004-03-03 09:03:00

jf/
Member
Registered: 2003-10-26
Posts: 79

Re: gaim has 12 remote overflows in current version

i suppose that this is now gaim 0.75-2? (http://www.archlinux.org/packages.php?s … ate=&pp=50)

Offline

#3 2004-03-03 10:51:27

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: gaim has 12 remote overflows in current version

jf/ wrote:

i suppose that this is now gaim 0.75-2? (http://www.archlinux.org/packages.php?s … ate=&pp=50)

Hi,

yepp it is. If you like to know such things you can look at the cvs entries, eg.:
http://cvs.archlinux.org/cgi-bin/cvsweb … ot=Current

or, as written, this one is in the bugtracker, try a search like this:
http://bugs.archlinux.org/index.php?str … perpage=20

and you will get this:
http://bugs.archlinux.org/index.php?do=details&id=413

just to show how it works smile
bye neri

Offline

#4 2004-03-04 01:11:59

jf/
Member
Registered: 2003-10-26
Posts: 79

Re: gaim has 12 remote overflows in current version

ah, yes! ok, great thanks...  smile

Offline

#5 2004-04-24 10:30:03

galen
Member
From: Canada
Registered: 2003-07-02
Posts: 135
Website

Re: gaim has 12 remote overflows in current version

if gaim were a horse... .bang

there is always PSI jabber
and voice chat with teamspeak2


Off to using Peanut and Slackware, no hard feelings but I need my CD to burn, PDA and scanner to connect and arch won't do it.

[img]http://www.flightsimhq.org/images/war-is-bushit_s.jpg[/img]

Offline

#6 2004-04-24 15:15:14

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: gaim has 12 remote overflows in current version

galen wrote:

and voice chat with teamspeak2

galen, teamspeak is not Free Software. Am I wrong?

Try this project instead: http://sourceforge.net/projects/speak-freely/

Offline

#7 2004-08-11 06:30:09

cs25x
Member
Registered: 2004-05-04
Posts: 150

Re: gaim has 12 remote overflows in current version

speak freely does not appear in the list of arch linux packages. That treamspeak looks interesting. It does not appear in the list of arch linux packages, so they are equal in that regard. In fact I have never managed to get speak freely to work, so I think I will give teamspeak a whirl. thanks for mentioning it, Galen  tongue


--(*(cs25x--));

Offline

Board footer

Powered by FluxBB