You are not logged in.

#1 2013-08-06 21:07:49

btorb
Member
Registered: 2012-08-06
Posts: 28

[solved] fail to boot after fresh install

I just re-installed Arch inux on one of my machines. I had arch and ubuntu before, but for some reason I decided it was better to install Archlinux from scratch on that disk again. So I followed the beginner's manual and all seemed fine. Up to the moment that I had to reboot: after rebooting syslinux was not loaded.

So, clearly the bootloader failed to install. So I tried a few more time: loading arch from the USB, chrooting into the installation and tried to reinstall first syslinux (no success) and then grub (no success either). (On my other laptop i only have archlinux and load via syslinux. That works perfect so syslinux is my first choice)

As a remark: i started by writing a new partition scheme with GPT using cgdisk as recommended in the beginner's manual.

Since installing the base system is fairly easy, I tried installing everything again including making a new partition table. I wanted to make one with MBR but fdisk essentially also used GPT for no clear reason.

Anyway, the result remains the same: I cannot boot the installed system. Anybody any suggestions?

Last edited by btorb (2013-08-07 06:24:19)

Offline

#2 2013-08-06 21:30:41

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [solved] fail to boot after fresh install

How did you try to install the bootloaders?  I have no idea about grub, as I think that it generates the image before writing it, but with syslinux I know that there are at least three ways to do it.  You can use the syslinux-install_update script, you can use the extlinux command, or you can determine exactly what MBR image you need and simply dd it to the disk.  I find that although the other two are very convenient and mostly reliable, dd'ing the image never fails.

Offline

#3 2013-08-07 00:05:39

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: [solved] fail to boot after fresh install

Any USB disk plugged in that might prevent syslinux or grub from loading? (I have a couple HDDs that do that, on two different computers, even though there is no boot partition on them… Maybe that’s because one is encrypted and the other is GPT, and the BIOS can’t read them?)

Which makes me think, maybe your bios doesn’t like GPTs?

Offline

#4 2013-08-07 00:40:04

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [solved] fail to boot after fresh install

Can you say exactly what you see when you try to boot? It may matter whether you see anything on the screen and, if so, what exactly.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#5 2013-08-07 05:32:00

btorb
Member
Registered: 2012-08-06
Posts: 28

Re: [solved] fail to boot after fresh install

Thanks for To start with the partitioning, I made exactly the same partitions as giving in the example (with the exception that the disk sizes differ a bit):

Part. #     Size        Partition Type            Partition Name
----------------------------------------------------------------
            1007.0 KiB  free space
   1        15.0 GiB    Linux filesystem
   2        123.45 GiB  Linux filesystem
WonderWoofy wrote:

How did you try to install the bootloaders?  I have no idea about grub, as I think that it generates the image before writing it, but with syslinux I know that there are at least three ways to do it.  You can use the syslinux-install_update script, you can use the extlinux command, or you can determine exactly what MBR image you need and simply dd it to the disk.  I find that although the other two are very convenient and mostly reliable, dd'ing the image never fails.

At first, I tried the way described in the beginner's guide:

# pacman -S gptfdisk 
# pacman -S syslinux
# syslinux-install_update -i -a -m

Clearly, I changed the syslinux.cfg so that root=/dev/sda1 in accordance to my computer. Rebooting didn't seem to pick up syslinux and my computer got stuck.

Then I continued to try to install syslinux manually as described on the help page. I booted from the USB image, chrooted into the new installation, and used

# extlinux --install /boot/syslinux" #no need to "mkdir /boot/syslinux" as it already existed
# sgdisk /dev/sda --attributes=1:set:2
# dd bs=440 conv=notrunc count=1 if=/usr/lib/syslinux/gptmbr.bin of=/dev/sda
## rebooted, no syslinux found either, so I booted the image, chrooted again and then tried
# syslinux-install_update -i -m

But that also failed.

stqn wrote:

Which makes me think, maybe your bios doesn’t like GPTs?

In the meanwhile, I had tried to use a MBR partition table, but I couldn't get that to work:

# fdisk /dev/sda

the above command gave a warning about GPT being experimental in fdisk, so it clearly did use GPT. (Also indicated by the fact that I needed gptdisk again in order to run "syslinux-install_update -i -a -m"). I tried to install grub but also without any success. So, How could I really enforce using MBR?

cfr wrote:

Can you say exactly what you see when you try to boot?

Bios goes through all the options for booting and ends up trying to make a connection to boot via the network. When that (obviously) also fails, I get a screen from bios asking from which device I want to boot. Selecting the hard disk blanks the screen for a second before returing to the screen offering the choice of device from which to boot. It clearly does not find any bootloader :-(

It's the first time that I ever encounter this problem. Before, on that laptop I had arch and ubuntu running and had installed grub2 from arch and all worked well.

Offline

#6 2013-08-07 06:23:46

btorb
Member
Registered: 2012-08-06
Posts: 28

Re: [solved] fail to boot after fresh install

It seems that three things went wrong.

First, fdisk started with a GPT, which should be changed to MBR by pressing "o", then creating your tables and save ("w") the table.

Second, syslinux automatically installed the gptmbr.bin, so you manually have to install the mbr-version:

# dd bs=440 count=1 conv=notrunc if=/usr/lib/syslinux/mbr.bin of=/dev/sda

Third, the automatic syslinux-install_update did not toggle the bootable bit correctly, this I did manually by booting from the usb, then

fdisk /dev/sda
press a [enter]
press 1 [enter]
w [enter]

Now after rebooting it shows the syslinux bootloader. hurray!

Last edited by btorb (2013-08-07 09:00:41)

Offline

Board footer

Powered by FluxBB