You are not logged in.

#1 2005-12-26 06:23:45

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,443

Sata DVD not recognized

Still my SATA DVD does not show up. I read a howto at thinkwiki, that gives solutions:

DVD drive not recognized

The ata_piix SATA driver grabs ownership over the IDE ports when it is loaded, but (by default) does not support PATA ATAPI devices such as the Ultrabay optical drives. Thus, if the ide driver is compiled as a module and loaded after ata_piix, the DVD drive will not be recognized by either driver.

Either of the following configurations will work:

    * For kernel 2.6.14 and newer: enable ATAPI support in the SATA system using libata.atapi_enabled=1 (see below; this is experimental).
    * Compile IDE into the kernel (non-module).
    * Compile both IDE and SATA as modules and make sure IDE is loaded first (the module is called 'ide_generic').

I dunno if ide and sata are compiled in as module, but I guess they are. How can I have one module is loaded before the other, as they are both managed with initrd?


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

Board footer

Powered by FluxBB