You are not logged in.

#1 2005-12-26 01:55:24

fatbird
Member
From: Springboro, PA
Registered: 2005-12-20
Posts: 17

Kernel panic after running mkinitrd

I did a pacman -Syu today and edited lilo to add /boot/initrd26.img then ran lilo and rebooted.  My system got hung on the Gnome splash screen for a long time and after a couple of minutes finished loading but the splash screen stayed on and the system monitor showed 100% cpu usage when it should have been zero.

When I ran lsmod I had 150 modules loaded rather than the previous 50.  Welcome to kernel 2.6.14.  I didn't necessarily think this was my problem but thought it was worth looking into.  I read the initrd wiki and decided to edit mkinitrd.conf and run mkinitrd auto.

When I rebooted I got a kernel panic with the last lines reading:

RAMDISK: Couldn't find valid RAM disk image starting at 0.
VFS: Cannot open root device "308" or unknown-block(3,8)
Please append a correct "root" boot option
Kernel panic - not syncing: VFS: Unable to ount root fs on unknown-block(3,8)

I booted into Ubuntu on the same machine and chroot'ed to /mnt/arch (where I have arch mounted under Ubuntu) .  I edited mkinitrd.conf back to its original state and ran mkinitrd auto.  I should be back to where I was before but when I rebooted I still get a kernel panic.

To summarize: system booted OK, ran mkinitrd, kernel panic, restored initrd, still panic.

Help!

Offline

#2 2005-12-26 02:34:40

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Kernel panic after running mkinitrd

What's in your bootloader's config file?

Offline

#3 2005-12-26 05:13:26

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Kernel panic after running mkinitrd

With lilo you need to re-run it if you change the initrd.

Offline

#4 2005-12-26 10:53:01

fatbird
Member
From: Springboro, PA
Registered: 2005-12-20
Posts: 17

Re: Kernel panic after running mkinitrd

Gullible Jones wrote:

What's in your bootloader's config file?

Here it is.  I booted OK with this config twice before changing the initrd.  It resides in my arch partition.

#
# /etc/lilo.conf
#
boot=/dev/hda
map=/boot/System.map26
bitmap=/boot/lilo.bmp
bmp-colors=16,,,0,,
bmp-table=20,10,1,8
bmp-timer=2,29,188,0

lba32

prompt
delay=100
timeout=100

default="Arch_0.7_Wombat"

#vga=771

image=/boot/vmlinuz26
    vga=771
    label="Arch_0.7_Wombat"
    root=/dev/hda8
    append="devfs=nomount acpi=on apm=off splash=verbose"
    read-only
    initrd=/boot/initrd26.img

image=/mnt/vector/boot/vmlinuz
    label="Vector_Linux"
    root=/dev/hda6
    append="acpi=on apm=off splash=verbose"
    read-only

image=/mnt/hoary/boot/vmlinuz-2.6.10-5-386
    label="Ubuntu_Hoary"
    root=/dev/hda7
    initrd=/mnt/hoary/boot/initrd.img-2.6.10-5-386
    append="devfs=nomount acpi=on apm=off splash=verbose"
    read-only
 
image=/mnt/breezy/boot/vmlinuz-2.6.12-9-386
    label="Ubuntu_Breezy"
    root=/dev/hda10
    initrd=/mnt/breezy/boot/initrd.img-2.6.12-9-386
    append="devfs=nomount splash=verbose"
    read-only

image=/mnt/knoppmyth/boot/vmlinuz-2.6.11.9-chw-2
    label="Knoppmyth"
    initrd=/mnt/knoppmyth/boot/initrd.gz
    append="splash=verbose apm=power-off nomce"
    read-only

other=/dev/hda2
    label="Windows_98SE"
    table=/dev/hda

# End of file

iphitus wrote:

With lilo you need to re-run it if you change the initrd.

I didn't see anything about that in the initrd wiki but I just tried it and got:

hhorton@msi:~$ sudo chroot /mnt/arch
[root@msi /]# /sbin/lilo
Fatal: raid_setup: stat("/dev/hda")

While I'm waiting for further wisdom I'll try editing mkinitrd.conf again etc.

Offline

#5 2005-12-26 12:06:31

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Kernel panic after running mkinitrd

You need to mount /dev /sys and /proc inside the chroot for lilo to work.

mount --bind /dev /mnt/arch/dev
mount --bind /sys /mnt/arch/sys
mount --bind /proc /mnt/arch/proc

then run lilo to attatch your new initrd.

Offline

#6 2005-12-26 12:44:07

fatbird
Member
From: Springboro, PA
Registered: 2005-12-20
Posts: 17

Re: Kernel panic after running mkinitrd

iphitus wrote:

You need to mount /dev /sys and /proc inside the chroot for lilo to work.

mount --bind /dev /mnt/arch/dev
mount --bind /sys /mnt/arch/sys
mount --bind /proc /mnt/arch/proc

then run lilo to attatch your new initrd.

I tried something similar to this from a post that I googled but they didn't have the bind option and it didn't work.  I then tried what another googled post suggested, which was to copy /dev from my current location to the chroot'ed one.  This didn't work either.  I then installed lilo on Ubuntu, edited the lilo.conf and ran lilo.  Bingo!  Just before I got your last post I reran lilo in arch and everything works fine now.

Somehow my initial problem with gnome-splash hanging is gone also.  I still have 150 modules but now I can pursue that problem without, hopefully, breaking things.

One of the many reasons I am addicted to arch is the quality of it's support community.  In other forums I see a lot of 'trouble with Gnome - use KDE, trouble with lilo - use grub, trouble with distro X - switch to distro Y.'  Here I didn't get proselytizing, I just got help. 

Thanks so much.

Offline

#7 2005-12-26 12:47:07

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: Kernel panic after running mkinitrd

or instead of chroot boot off arch install cd at 1st prompt

vmlinuz root=/dev/look/on/screenfor naming scheme hdaX or /discs/discX/partY 

get in there  to fix the problem

Offline

Board footer

Powered by FluxBB