You are not logged in.

#1 2013-08-17 22:41:05

MajorMonodon
Member
Registered: 2013-08-17
Posts: 4

[Solved] Trouble with Gnome 3, pulseaudio, music and skype

Dear Arch forums,

I just made an account because I have been breaking my head over a problem I have with my sound system.

I'm often using my pc for skype and music in the background. Running Gnome 3 and Rhythmbox at the moment, but I jsut switched form banshee, to see if my problem still persisted.

The problem is this: Whenever a notification sound, skype, general notification, mail, comes on my music player mutes itself. Now, when I go into sound settings to "Applications" the player is muted but when I drag the volume slider, it shoots right back to muted. I can use the toggle behind the slider and it goes back on, but when I use the slider again it jumps back to mute.

I made a screen recording in a WebM of this but I don't see where I could upload this to show you, maybe to youtube.

Any suggestions or information would be welcome!

Thanks in advance.

Edit: I have uploaded a video of the problem

http://www.youtube.com/watch?v=XfK7BPZArLY

There is no sound, but this is the video's fault, normally when unmuted the music is audible.

Edit: Solved: Oh dear, might as well shoot me, guys. I found the solution on the wiki though I would swear I ran through the whole skype, pulseaudio and gnome 3 pages ten times! Pulse loads a cork module or something that mutes all but skype when a call is in progress. My apologies for this unnecessary topic.

Last edited by MajorMonodon (2013-08-18 09:49:53)

Offline

#2 2013-08-17 23:02:51

MajorMonodon
Member
Registered: 2013-08-17
Posts: 4

Re: [Solved] Trouble with Gnome 3, pulseaudio, music and skype

I have investigated further and the problem only occurs/persists when I am skyping.

When I have my headphone and mic plugged in (at the front of my case via a usb dongle) this doesn't happen when listening via the headphones and then having notifications, but it does when skype is active.

Is something wrong with my skype or my pulseaudio or is my setup just so confusing my system is having trouble keeping up?

Offline

#3 2013-12-02 17:19:31

balticer
Member
From: Rostock
Registered: 2013-11-17
Posts: 6
Website

Re: [Solved] Trouble with Gnome 3, pulseaudio, music and skype

Hi,

same Problem here. Banshee got muted on "system bell" or if evolution receive an email and notify about that. Any solutions?

/edit
My solution:
Comment "load-module module-role-cork"  in "/etc/pulse/default.pa".

regards
balticer

Last edited by balticer (2013-12-02 18:16:40)

Offline

Board footer

Powered by FluxBB