You are not logged in.

#1 2013-08-18 08:52:08

Oralphabet
Member
Registered: 2012-11-06
Posts: 7

Package emergent-svn from AUR does not work

Hey folks,

I can't get emergent running on my arch. There seems to be some kind of dependency-problem with coin/coin-hg and quarter/quarter-hg. Also it is reported in the AUR that gcc-4.6 is needed instead of the new one as well as older packages of gsl and ode, but I'm not sure for which emergent version this recommendations are up to date.
Please let me know if anyone else has faced issue and has any idea how to fix it.

By the way: I tried older and newer versions of Emergent. Both did not work, but newer versions did compile with a bunch of warnings. When I then started it and wanted to create a standard network, the programm crashed with warnings like "Unknown type: layerwizellist" after initializing the 3d view.

Thanks and regards
Oralphabet

Offline

#2 2013-08-18 11:38:32

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,838
Website

Re: Package emergent-svn from AUR does not work

You're going to need to be much more specific.  What does "some kind of dependency problem" mean?  What were the "bunch of warnings"?


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2013-08-18 14:31:41

Oralphabet
Member
Registered: 2012-11-06
Posts: 7

Re: Package emergent-svn from AUR does not work

With the PKGBUILD in the AUR, just the dependency qt replaced by qt4 i get the following make config:

==> Starting make...
-- The C compiler identification is GNU 4.8.1
-- The CXX compiler identification is GNU 4.8.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Performing Test HAS_RETURN_TYPE_ERROR_FLAG
-- Performing Test HAS_RETURN_TYPE_ERROR_FLAG - Failed
Compiler does not support -Werror=return-type, will use -Wreturn-type instead.
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
-- Found Qt4: /usr/bin/qmake (found version "4.8.5") 
-- Found Coin: /usr/lib/libCoin.so  
-- Found Quarter: /usr/lib/libQuarter.so  
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Found OpenGL: /usr/lib/libGL.so  
-- Found subversion include: /usr/include/subversion-1
-- Found apr include: /usr/include/apr-1
-- Found apu include: /usr/include/apr-1
-- Found subversion client lib: /lib/libsvn_client-1.so
-- Found subversion repository lib: /lib/libsvn_repos-1.so
-- Found subversion fs lib: /lib/libsvn_fs-1.so
-- Found subversion subr lib: /lib/libsvn_subr-1.so
-- Found subversion wc lib: /lib/libsvn_wc-1.so
-- Found subversion ra lib: /lib/libsvn_ra-1.so
-- Found apr lib: /usr/lib/libapr-1.so
-- Found apu lib: /usr/lib/libaprutil-1.so
-- Found Readline: /usr/lib/libreadline.so  
-- Found Termcap: /usr/lib/libtermcap.so  
-- Found ODE: /usr/lib/libode.so  
-- Found GSL: /usr/lib/libgsl.so;/usr/lib/libgslcblas.so  
-- Found ZLIB: /usr/lib/libz.so (found version "1.2.8") 
-- 
-- -------------------------------------------------------------------------------
-- ********************* Summary of Key Build Parameters *************************
-- -------------------------------------------------------------------------------
-- CMAKE_INSTALL_PREFIX = /usr
-- CMAKE_BUILD_TYPE = RelWithDebInfo
--       (Options are: Debug | Release | RelWithDebInfo | MinSizeRel)
-- MPI_BUILD = FALSE   (true or false)
-- 
-- Change a value with: cmake -D<Variable>=<Value>
-- -------------------------------------------------------------------------------
-- ********************* Summary of Prerequisities  ******************************
-- -------------------------------------------------------------------------------
-- QT_LIBRARIES = /usr/lib/libQtOpenGL.so;/usr/lib/libQtWebKit.so;/usr/lib/libQtXmlPatterns.so;/usr/lib/libQtGui.so;/usr/lib/libQtXml.so;/usr/lib/libQtNetwork.so;/usr/lib/libQtCore.so
-- COIN_LIBRARY = /usr/lib/libCoin.so
-- QUARTER_LIBRARY = /usr/lib/libQuarter.so
-- GSL_LIBRARIES = /usr/lib/libgsl.so;/usr/lib/libgslcblas.so
-- ODE_LIBRARY = /usr/lib/libode.so
-- READLINE_LIBRARY = /usr/lib/libreadline.so

The first warning I get is

Running maketa on: /tmp/…/aur-emergent-svn/src/emergent-svn-4968/src/temt/ta/NameVar_PArray.h
I!!: Warning: in file: /tmp/…/aur-emergent-svn/src/emergent-svn-4968/src/temt/ta/NameVar_PArray.h method: SafeEl don't know how to handle return type: NameVar_ref so it will be ignored!

My ode-version is 0.12
gsl is 1.15 however I couldn't find older sources
Coin is 4.0.0a
quarter is quarter-hg as I couldn't get the old quarter to run.

Is there something else that could help?

Last edited by Oralphabet (2013-08-18 14:35:01)

Offline

#4 2013-08-18 14:34:19

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: Package emergent-svn from AUR does not work

When pasting configs, code or command output, please use [ code ] tags, not [ quote ] tags https://bbs.archlinux.org/help.php#bbcode

like this

It makes the code more readable and - in case of longer listings - more convenient to scroll through.

Offline

#5 2013-08-18 14:37:10

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,838
Website

Re: Package emergent-svn from AUR does not work

I'm trying to build this now - it takes a hell of a long time to compile (almost two hours so far on my machine, and only at 60%).  But I did find the dependencies in the PKGBUILD are odd.  There is no qt (though it is an irrelevant package group).  qt in the dependencies should be changed to qt4 and qtwebkit.  Also svn should be added as a dependency.

Aside from that it seems good so far.

Also there is no "old quarter".  Quarter-hg is marked out of date, likely due to it's not being revised for the makepkg 4.x changes.  Meanwhile quarter was revised to be an -hg package anyways.  So they both draw from the exact same sources.

As for the warning you showed - that was only a warning.  Compiling didn't stop there, right?


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#6 2013-08-18 14:42:46

Oralphabet
Member
Registered: 2012-11-06
Posts: 7

Re: Package emergent-svn from AUR does not work

No, it didn't stop there but when I open a model, it complains about something similar ("Unknown type: layerwizellist") and crashes. Perhaps you can try to enable multicore compiling, however it cost me a lot of nerve to enable it by -j4 and similar commands for cmake... and I've erased the PKGBUILD I created on my own, sadly... it used gcc-4.6 instead, but I observed no real difference.
I'm trying it again now, for the good old times (tried this already for a whole week compiling on a slow netbook '~').
I wish you good luck.

Last edited by Oralphabet (2013-08-18 14:46:34)

Offline

#7 2013-08-18 16:01:31

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,838
Website

Re: Package emergent-svn from AUR does not work

Over 4 hours (just for the last attempt) compiling.  It built and installed a package, but upon running I didn't get nearly as far as you did: I got an immediate "malloc(): memory corruption" and stall.  I'd report these issues upstream.   There are some quirks about the PKGBUILD dependencies being off, but the real problems here are in the upstream source.

EDIT: Geesh, while you're at it you may want to mention documentation.  This takes 4 hours to build on my machine, and eats over 2.8GB of a build dir to install 3 binaries none of which have a man page or any -h/--help switch output.

Last edited by Trilby (2013-08-18 16:04:45)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#8 2013-08-18 16:04:35

Oralphabet
Member
Registered: 2012-11-06
Posts: 7

Re: Package emergent-svn from AUR does not work

Yeah, this was one of the error messages I also got. Did you build the newest one? 6.3.0? I tried 6.2.0 instead and/or 5.3.10/similar and if I correctly remember, had success with 6.2.0 instead of 6.3.0 at least insofar that I did not get this error anymore...

Offline

#9 2013-08-18 16:05:38

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,838
Website

Re: Package emergent-svn from AUR does not work

I just used the pkgbuild.  I have no interest in this tool (whatever it is), I was just giving a shot at fixing the aur package - but as above, that's not where the real problems are.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB