You are not logged in.

#1 2013-08-15 05:16:53

hexadecagram
Member
Registered: 2011-05-20
Posts: 22

PulseAudio + Bluetooth not working

I've been fumbling with the solution prescribed in this thread with a Logitech h800 Wireless Headset for several hours now.

I go through the steps vlsd describe there verbatim, and it works until I reboot. Once that happens, I am able to connect to the Headset Service, but when I attempt to connect to the Audio Sink, I see the message "Connection Failed: Stream setup failed" in blueman-manager.

I've rebooted several times, experimenting each time with setting Enable=Socket or Disable=Socket in /etc/bluetooth/audio.conf after (and during) the third and final restart of bluetooth.service that vlsd mentions. None of these configurations (which I intended to stay long-term) fix the issue.

Relevant packages installed:
pulseaudio 4.0-2
pulseaudio-alsa 2-2
bluez-libs 5.7-1
bluez-utils 5.7-1
bluez4 4.101-3
alsa-firmware 1.0.27-2
alsa-lib 1.0.27.2-1
alsa-oss 1.0.25-1
alsa-plugins 1.0.27-2
alsa-utils 1.0.27.2-1

Here's my config files for those packages. If it's not here, then AFAIK, the default config file from the package is being used. Also, unless documented, I don't recall why any changes I've made to the PulseAudio config files were made (and they're old), and could probably be removed if necessary. Feel free to point any unnecessary configs out.

/etc/asound.conf:

defaults.pcm.rate_converter "samplerate_best"

# Use PulseAudio by default
pcm.!default {
  type pulse
  fallback "sysdefault"
  hint {
    show on
    description "Default ALSA Output (currently PulseAudio Sound Server)"
  }
}

ctl.!default {
  type pulse
  fallback "sysdefault"
}

### # Explicit PulseAudio device
### pcm.pulse {
###   type pulse
### }

### ctl.pulse {
###   type pulse
### }

# vim:set ft=alsaconf:

/etc/bluetooth/audio.conf (my comments more than likely aren't accurate):

# Configuration file for the audio service

# This section contains options which are not specific to any
# particular interface
[General]

# Switch to master role for incoming connections (defaults to true)
#Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
#Disable=Gateway,Source,Socket
# N.B.: Disable Socket in order for A2DP to function until further notice.
# <http://forums.gentoo.org/viewtopic-t-916968-start-0.html>
# <https://bbs.archlinux.org/viewtopic.php?id=157326>
### Enable=Source,Sink,Headset,Gateway,Control,Media
Disable=Socket
# Disable=Socket still needs to be configured long-term, but Enable=Socket must
# be used to "prime" PulseAudio into working. Also, the following thread doesn't
# *explicitly* mention, but Disable=Socket must be configured during the third
# and final restart of bluetooth.service and left to stand.
# <https://bbs.archlinux.org/viewtopic.php?id=165741>
### Enable=Source,Sink,Headset,Gateway,Control,Socket,Media
### Enable=Socket

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
#AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incoming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0

/etc/pulse/client.conf:

# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =
; default-dbus-server =

autospawn=no
; autospawn = yes
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; auto-connect-localhost = no
; auto-connect-display = no

/etc/pulse/daemon.conf:

# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.

## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

exit-idle-time=0
; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

resample-method=speex-float-0
; resample-method = speex-float-3
; enable-remixing = yes
; enable-lfe-remixing = no

; flat-volumes = yes

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 1000000

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
;;; http://www.mail-archive.com/pulseaudio-tickets@mail.0pointer.de/msg03640.html
default-sample-channels = 2
; default-channel-map = front-left,front-right

; default-fragments = 4
; default-fragment-size-msec = 25

; enable-deferred-volume = yes
; deferred-volume-safety-margin-usec = 8000
; deferred-volume-extra-delay-usec = 0

/etc/pulse/default.pa:

#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.nofail

### Load something into the sample cache
#load-sample-lazy x11-bell /usr/share/sounds/gtk-events/activate.wav
#load-sample-lazy pulse-hotplug /usr/share/sounds/startup3.wav
#load-sample-lazy pulse-coldplug /usr/share/sounds/startup3.wav
#load-sample-lazy pulse-access /usr/share/sounds/generic.wav

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
### load-module module-udev-detect
# BUG: tsched=0 is necessary for kernel 2.6.32-lts.
# <https://bbs.archlinux.org/viewtopic.php?pid=921029>
load-module module-udev-detect tsched=0
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
.nofail
load-module module-console-kit
.fail
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Load DBus protocol
.ifexists module-dbus-protocol.so
load-module module-dbus-protocol
.endif

# X11 modules should not be started from default.pa so that one daemon
# can be shared by multiple sessions.

### Load X11 bell module
#load-module module-x11-bell sample=bell-windowing-system

### Register ourselves in the X11 session manager
#load-module module-x11-xsmp

### Publish connection data in the X11 root window
#.ifexists module-x11-publish.so
#.nofail
#load-module module-x11-publish
#.fail
#.endif

### Make some devices default
#set-default-sink output
#set-default-source input

Finally, here's my bluetoothd logs, filtered from /var/log/messages.log:

Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Bluetooth daemon 4
.101
Aug 14 22:39:17 localhost bluetoothd[2546]: Bluetooth daemon 4.101
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Starting SDP serve
r
Aug 14 22:39:17 localhost bluetoothd[2546]: Starting SDP server
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: DIS cannot start: 
GATT is disabled
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Failed to init dev
iceinfo plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: DIS cannot start: GATT is disabled
Aug 14 22:39:17 localhost bluetoothd[2546]: Failed to init deviceinfo plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: Failed to init proximity plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: Failed to init time plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: Failed to init alert plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: Failed to init thermometer plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Failed to init proximity plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Failed to init time plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Failed to init alert plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Failed to init thermometer plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Failed to init gatt_example plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: Failed to init gatt_example plugin
Aug 14 22:39:17 localhost bluetoothd[2546]: Bluetooth Management interface initialized
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Bluetooth Management interface initialized
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Unknown command complete for opcode 19
Aug 14 22:39:17 localhost bluetoothd[2546]: Unknown command complete for opcode 19
Aug 14 22:39:17 localhost bluetoothd[2546]: hci0: Set Discoverable (0x0006) failed: Not Powered (0x0f)
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: hci0: Set Discoverable (0x0006) failed: Not Powered (0x0f)
Aug 14 22:39:17 localhost bluetoothd[2546]: bluetoothd[2546]: Adapter /org/bluez/2546/hci0 has been enabled
Aug 14 22:39:17 localhost bluetoothd[2546]: Adapter /org/bluez/2546/hci0 has been enabled
Aug 14 22:39:25 localhost bluetoothd[2546]: bluetoothd[2546]: Endpoint registered: sender=:1.20 path=/MediaEndpoint/HFPAG
Aug 14 22:39:25 localhost bluetoothd[2546]: Endpoint registered: sender=:1.20 path=/MediaEndpoint/HFPAG
Aug 14 22:39:25 localhost bluetoothd[2546]: Endpoint registered: sender=:1.20 path=/MediaEndpoint/HFPHS
Aug 14 22:39:25 localhost bluetoothd[2546]: Endpoint registered: sender=:1.20 path=/MediaEndpoint/A2DPSource
Aug 14 22:39:25 localhost bluetoothd[2546]: bluetoothd[2546]: Endpoint registered: sender=:1.20 path=/MediaEndpoint/HFPHS
Aug 14 22:39:25 localhost bluetoothd[2546]: bluetoothd[2546]: Endpoint registered: sender=:1.20 path=/MediaEndpoint/A2DPSource
Aug 14 22:39:25 localhost pulseaudio[2846]: [pulseaudio] bluetooth-util.c: org.bluez.AudioSource.GetProperties() failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" with signature "" on interface "org.bluez.AudioSource" doesn't exist
Aug 14 22:39:25 localhost pulseaudio[2846]: [pulseaudio] bluetooth-util.c: org.bluez.HandsfreeGateway.GetProperties() failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" with signature "" on interface "org.bluez.HandsfreeGateway" doesn't exist
Aug 14 22:39:25 localhost pulseaudio[2846]: [pulseaudio] bluetooth-util.c: org.bluez.HandsfreeGateway.GetProperties() failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" with signature "" on interface "org.bluez.HandsfreeGateway" doesn't exist
Aug 14 22:39:46 localhost bluetoothd[2546]: bluetoothd[2546]: Endpoint unregistered: sender=:1.20 path=/MediaEndpoint/HFPAG
Aug 14 22:39:46 localhost bluetoothd[2546]: bluetoothd[2546]: Endpoint unregistered: sender=:1.20 path=/MediaEndpoint/HFPHS
Aug 14 22:39:46 localhost bluetoothd[2546]: Endpoint unregistered: sender=:1.20 path=/MediaEndpoint/HFPAG
Aug 14 22:39:46 localhost bluetoothd[2546]: Endpoint unregistered: sender=:1.20 path=/MediaEndpoint/HFPHS
Aug 14 22:39:46 localhost bluetoothd[2546]: bluetoothd[2546]: Endpoint unregistered: sender=:1.20 path=/MediaEndpoint/A2DPSource
Aug 14 22:39:46 localhost bluetoothd[2546]: Endpoint unregistered: sender=:1.20 path=/MediaEndpoint/A2DPSource
Aug 14 22:40:31 localhost pulseaudio[2846]: [pulseaudio] module-bluetooth-device.c: 00:0D:44:AD:F2:9F is not known.
Aug 14 22:40:31 localhost pulseaudio[2846]: [pulseaudio] module.c: Failed to load module "module-bluetooth-device" (argument: "address=00:0D:44:AD:F2:9F profile=hsp"): initialization failed.
Aug 14 22:40:32 localhost bluetoothd[2546]: bluetoothd[2546]: Unable to select SEP
Aug 14 22:40:32 localhost bluetoothd[2546]: Unable to select SEP
Aug 14 22:40:49 localhost bluetoothd[2546]: bluetoothd[2546]: Unable to select SEP
Aug 14 22:40:49 localhost bluetoothd[2546]: Unable to select SEP

Last edited by hexadecagram (2013-08-15 05:21:42)

Offline

#2 2013-08-15 20:45:53

progandy
Member
Registered: 2012-05-17
Posts: 2,146

Re: PulseAudio + Bluetooth not working

I guess this is still true: https://bbs.archlinux.org/viewtopic.php … 0#p1302270

You have bluez4, but i dont know how well that works with bluez-libs v5 which is installed, too

Last edited by progandy (2013-08-15 20:47:59)

Offline

#3 2013-08-16 01:02:01

hexadecagram
Member
Registered: 2011-05-20
Posts: 22

Re: PulseAudio + Bluetooth not working

Thanks for the response. When I try to address this, I get the following.

I don't have any real preference for using bluez4 or bluez, but I'm not sure which direction I should go.

% sudo pacman -S bluez                 
resolving dependencies...
looking for inter-conflicts...
:: bluez and obexd-client are in conflict. Remove obexd-client? [y/N] y
:: bluez and bluez4 are in conflict. Remove bluez4? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: blueman: requires bluez4
:: gnome-bluetooth: requires bluez4
:: gvfs-obexftp: requires bluez4
% sudo pacman -R blueman gnome-bluetooth gvfs-obexftp
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: gnome-control-center: requires gnome-bluetooth
:: gnome-shell: requires gnome-bluetooth
:: gnome-user-share: requires gnome-bluetooth
% sudo pacman -R bluez-libs bluez-utils
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: blueman: requires bluez-libs
:: bluez4: requires bluez-utils
:: gpsd: requires bluez-libs
:: obexd-client: requires bluez-libs
:: openobex: requires bluez-libs
:: qemu: requires bluez-libs
:: xbmc: requires bluez-libs
% yaourt -S pulseaudio-git
...
==> Install or build missing dependencies for pulseaudio-git:
resolving dependencies...
looking for inter-conflicts...
:: bluez and obexd-client are in conflict. Remove obexd-client? [y/N] ^C
Interrupt signal received

Last edited by hexadecagram (2013-08-16 01:03:08)

Offline

#4 2013-08-22 13:30:31

ssouffri
Member
Registered: 2013-08-22
Posts: 1

Re: PulseAudio + Bluetooth not working

Hi,

I had a similar or possibly the same issue. I couldn't get the A2DP profile to work for my Philips SHB9100 headphone with bluez4 and when I tried bluez (v5) I also saw: "bluetoothd[275]: Unable to select SEP" in the logs of bluetooth.service.

I read an email which suggested the problem was caused by pulseaudio 4.0 not being compatible with bluez (v5). The email also suggested trying a patched version of pulseaudio at https://github.com/mastiz/pulseaudio-bluez5. I tried the latest version on the bluez5-head branch and it worked!

I cloned the repo, checked out version 13236335433bf95fbc34c80f0d0ee9d44ce5d88d and followed the build/run instructions in the README file. (don't forget to kill the running instance of pulseaudio first with: "pulsaudio -k"). I then used bluetoothctl to pair/connect with my headphones and pavucontrol to send the audio output to the headphones and it sounded great.

Note that I had to punch in some more commands in bluetoothctl than are listed on the wiki. Commands like: power on; scan on; agent on.

If this also works for you I suppose you could build a new pulseaudio package out of these sources and install that or you could just wait for the patches to make it into an arch packaged version of pulseaudio. These patches don't appear to be in the mainline of pulseaudio yet at the moment, so it might be a while until all of this works out of the box.

Note that the problem of the A2DP profile not working in bluez4 for the SHB9100 headphone appears to be a common issue: https://wiki.archlinux.org/index.php/Bl … d_Headsets, although I suspect this issue affects more headphones than just this one.

Hope this helps!

Last edited by ssouffri (2013-08-22 13:32:23)

Offline

#5 2013-10-10 10:18:11

darkshines
Member
From: Bremen, Germany
Registered: 2012-05-04
Posts: 11

Re: PulseAudio + Bluetooth not working

I just tried the approach suggested by ssouffri. Building from the branch pulseaudio-bluez5 went without a hitch. After restarting gnome, connecting the headset went well. Gnome's sound settings do not play well with the connected headset, it seems to have problems with the profile selection. Anyways, starting pavucontrol to select High fidelty Playback (A2DP) did the trick. After doing Alt+F2, r, to reload the shell everything works.

In conclusion, I guess we have to wait until pulseaudio and gnome settgins are properly updated.


Unity for Arch! Check it out https://wiki.archlinux.org/index.php/unity

Offline

#6 2013-10-10 14:50:02

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: PulseAudio + Bluetooth not working

I believe the pulseaudio package that was recently pushed to [testing] by heftig is supposed to address the bluetooth issues.  I don't actually use bluetooth for anything myself, so I cannot go into any more detail than that.  But I saw mention of this on the thread about heftig's user repo.  That little snippet of info starts here, though it doesn't go into any real detail as to why this was happening.

Offline

#7 2013-10-10 22:37:06

Pse
Member
Registered: 2008-03-15
Posts: 383

Re: PulseAudio + Bluetooth not working

For one specific bluetooth headset I had to set the following options, it would not work otherwise (it would connect, but no audio would come out):

[A2DP]
SBCSources=1
MPEG12Sources=0

Offline

#8 2013-10-13 13:30:08

empthollow
Member
Registered: 2009-09-26
Posts: 168

Re: PulseAudio + Bluetooth not working

For me the problem was that I had to load the module-bluetooth-discover in pulse.  That module appears to not work anymore.


--empthollow
Check out my Arch based live distro http://fluxcapacity.99k.org

Offline

#9 2013-10-14 12:48:37

empthollow
Member
Registered: 2009-09-26
Posts: 168

Re: PulseAudio + Bluetooth not working

So if i install bluez4 and blueman i can get it to connect but the sink isn't created in pulse audio.  With bluez5 it won't connect.  The only thing i can think is to install the old version of pulse and bluez4.  I haven't tried it yet but i know the new settings manager in gnome won't work with bluez4.

Got it working...
I installed pulseaudio from testing as the 4.0-2 version doesn't support bluez5.  So, use bluez5 (default config) and pulseaudio 4.0-4.  Works in gnome settings.

Last edited by empthollow (2013-10-15 12:02:54)


--empthollow
Check out my Arch based live distro http://fluxcapacity.99k.org

Offline

Board footer

Powered by FluxBB