You are not logged in.

#76 2013-08-15 22:01:32

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: root device not read-write warning

markg85 wrote:

I tried every single solution provided in this thread. The message is gone but that's due to the mkinitcpio stuff. I have no "ro" anywhere anymore yet grup itself (at boot) shows me a ro..

What do you mean? The warning discussed in this thread comes from the initramfs - not grub. I'm not sure where grub would show you "ro". Do you mean that if you edit the kernel command line, it includes "ro"?

Please confirm that you do not have a separate /boot partition.

Last edited by cfr (2013-08-15 22:02:42)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#77 2013-08-15 22:13:13

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,686
Website

Re: root device not read-write warning

markg85 wrote:

I have no "ro" anywhere anymore yet ...

As has been said at least four times in this thread alone, not having "ro" is not sufficient, as that is the default if nothing is specified.  You must include "rw" on the kernel line.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#78 2013-08-15 22:22:21

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: root device not read-write warning

BTW wasn't the grub package recently updated to fix this? Afaik you can just upgrade to the new version and regenerate your config, right?

Offline

#79 2013-08-15 23:16:43

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: root device not read-write warning

Trilby wrote:
markg85 wrote:

I have no "ro" anywhere anymore yet ...

As has been said at least four times in this thread alone, not having "ro" is not sufficient, as that is the default if nothing is specified.  You must include "rw" on the kernel line.

The grub.cfg posted shows that 'rw' is on the kernel command lines. And anonymous_user is right, I think: merely removing any 'ro' from /etc/default/grub and regenerating grub.cfg is now sufficient to ensure 'rw' on the kernel command line in grub entries.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#80 2013-08-15 23:31:58

markg85
Member
Registered: 2009-06-27
Posts: 129

Re: root device not read-write warning

cfr wrote:
markg85 wrote:

I tried every single solution provided in this thread. The message is gone but that's due to the mkinitcpio stuff. I have no "ro" anywhere anymore yet grup itself (at boot) shows me a ro..

What do you mean? The warning discussed in this thread comes from the initramfs - not grub. I'm not sure where grub would show you "ro". Do you mean that if you edit the kernel command line, it includes "ro"?

Please confirm that you do not have a separate /boot partition.

What i mean is exactly what i wrote. Grub - at boot - shows me "ro" and no "rw" on the kernel line. Also, lets please not repeat this thread. It was said that initramfs is causing this message but grub (or the kernel lines put in there) are the fix for it. ro -> rw. I know what i'm talking about since i've actually read this thread.

And yes, boot sits nice and cozy with the root partition. It does not have a partition of it's own.

Trilby wrote:
markg85 wrote:

I have no "ro" anywhere anymore yet ...

As has been said at least four times in this thread alone, not having "ro" is not sufficient, as that is the default if nothing is specified.  You must include "rw" on the kernel line.

Oh wow, you can act less annoyed. Being friendly wouldn't harm anyone.
You apparently haven't read what i said. If you would have looked in my grub.cfg paste then you would have seen that it includes "rw". And that very fact is what puzzles me because grub - while booting and looking at the kernel line shows "ro" instead of "rw".

Note: can we please drop the "pissed of behaviour" in this thread? It feels a bit hostile in here. I would like it if the replies could be a little more friendly.

Offline

#81 2013-08-15 23:35:53

markg85
Member
Registered: 2009-06-27
Posts: 129

Re: root device not read-write warning

cfr wrote:
Trilby wrote:
markg85 wrote:

I have no "ro" anywhere anymore yet ...

As has been said at least four times in this thread alone, not having "ro" is not sufficient, as that is the default if nothing is specified.  You must include "rw" on the kernel line.

The grub.cfg posted shows that 'rw' is on the kernel command lines. And anonymous_user is right, I think: merely removing any 'ro' from /etc/default/grub and regenerating grub.cfg is now sufficient to ensure 'rw' on the kernel command line in grub entries.

I doubt that. When i wrote my message i fully updated my system (with [testing] enabled to be sure that i have the latest grub available) and updated my grub.cfg with grub-mkconfig. After that it didn't work and posted my initial reply to this thread.

Also, /etc/default/grub never had a "ro" to begin with. All i added ever since i have that file is "quiet" smile

Offline

#82 2013-08-16 00:20:13

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: root device not read-write warning

markg85 wrote:
cfr wrote:
Trilby wrote:

As has been said at least four times in this thread alone, not having "ro" is not sufficient, as that is the default if nothing is specified.  You must include "rw" on the kernel line.

The grub.cfg posted shows that 'rw' is on the kernel command lines. And anonymous_user is right, I think: merely removing any 'ro' from /etc/default/grub and regenerating grub.cfg is now sufficient to ensure 'rw' on the kernel command line in grub entries.

I doubt that. When i wrote my message i fully updated my system (with [testing] enabled to be sure that i have the latest grub available) and updated my grub.cfg with grub-mkconfig. After that it didn't work and posted my initial reply to this thread.

I think you misunderstood me. Your grub.cfg has 'rw' on the kernel command lines. Your /etc/default/grub does not specify 'rw' but I think this does not, as anonymous_user pointed out, matter with the current version of grub because grub-mkconfig now uses 'rw' in any case. Your grub.cfg apparently confirms that.

Also, /etc/default/grub never had a "ro" to begin with. All i added ever since i have that file is "quiet" smile

Sure but this does not necessarily matter. As Trilby said, not having 'ro' is insufficient as that's default if nothing is specified. Moreover, with previous versions of grub, even having 'rw' in /etc/default/grub was insufficient because grub-mkconfig added 'ro' regardless. However, as anonymous_user said, that's no longer the case. (Regardless of whether you are using testing or not.)

My response to Trilby was just trying to highlight that the grub.cfg you posted does in fact have 'rw' and not 'ro'.

So the question is where and why 'ro'? If I understand correctly, when at the grub menu, if you edit the kernel command line, you find that 'ro' is there by default rather than 'rw'. Is that correct? That is, that's where you are seeing it?

Have you double-checked grub is using the correct UUID? Although it is hard to see how that could not be the case unless you have multiple installations of Arch.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#83 2013-08-16 00:22:30

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,686
Website

Re: root device not read-write warning

Sorry I don't use grub - I didn't look in the hard-to-read generated config, just in the /etc/default/grub where the kernel command line entry was left blank.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#84 2013-08-16 00:39:04

markg85
Member
Registered: 2009-06-27
Posts: 129

Re: root device not read-write warning

cfr wrote:

So the question is where and why 'ro'? If I understand correctly, when at the grub menu, if you edit the kernel command line, you find that 'ro' is there by default rather than 'rw'. Is that correct? That is, that's where you are seeing it?

Exactly!

cfr wrote:

Have you double-checked grub is using the correct UUID? Although it is hard to see how that could not be the case unless you have multiple installations of Arch.

I actually did check that and the UUID i see at boot matches the one i see in grub.cfg so that seems to be fine.


So the question remains, how can this be possible? What is "changing" my "rw" to "ro"? Since i would expect grub.cfg to be final and used as is. Apparently that isn't the case otherwise i would've seen "rw" and not "ro" in the kernel line at boot.

Offline

#85 2013-08-16 00:46:24

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: root device not read-write warning

Why don't you try changing something arbitrary in grub.cfg just to see if that change shows up when you boot? For example, try removing the "quiet" or adding e.g. rd.log (which will just enable logging in early user space). You can do this in /etc/default/grub and regenerate grub.cfg. Just make a backup copy of /etc/default/grub so you can revert the change afterwards.

That will tell you whether your grub.cfg is being ignored (i.e. grub is using a different config file) or whether the problem is specific to 'ro', which seems unlikely.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#86 2013-08-16 03:37:01

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,893

Re: root device not read-write warning

markg85, what version of grub? If it's less than 2.00.5043-3, update your system and try again.

Offline

#87 2013-08-16 10:33:33

markg85
Member
Registered: 2009-06-27
Posts: 129

Re: root device not read-write warning

Scimmia wrote:

markg85, what version of grub? If it's less than 2.00.5043-3, update your system and try again.

└─> pacman -Qi grub
Name           : grub
Version        : 2.00.5086-1
Description    : GNU GRand Unified Bootloader (2)
Architecture   : x86_64
URL            : https://www.gnu.org/software/grub/
Licenses       : GPL3
Groups         : None
Provides       : grub-common  grub-bios  grub-efi-x86_64
Depends On     : sh  xz  gettext  device-mapper
Optional Deps  : freetype2: For grub-mkfont usage
                 fuse: For grub-mount usage [installed]
                 dosfstools: For grub-mkrescue FAT FS and EFI support [installed]
                 efibootmgr: For grub-install EFI support [installed]
                 libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue
                 os-prober: To detect other OSes when generating grub.cfg in BIOS systems
                 mtools: For grub-mkrescue FAT FS support
Required By    : None
Optional For   : None
Conflicts With : grub-common  grub-bios  grub-efi-x86_64  grub-legacy
Replaces       : grub-common  grub-bios  grub-efi-x86_64
Installed Size : 19380.00 KiB
Packager       : Tobias Powalowski <tpowa@archlinux.org>
Build Date     : Mon 05 Aug 2013 05:57:13 PM CEST
Install Date   : Tue 13 Aug 2013 07:35:27 PM CEST
Install Reason : Explicitly installed
Install Script : Yes
Validated By   : Signature

Offline

#88 2013-08-16 10:43:02

markg85
Member
Registered: 2009-06-27
Posts: 129

Re: root device not read-write warning

cfr wrote:

Why don't you try changing something arbitrary in grub.cfg just to see if that change shows up when you boot? For example, try removing the "quiet" or adding e.g. rd.log (which will just enable logging in early user space). You can do this in /etc/default/grub and regenerate grub.cfg. Just make a backup copy of /etc/default/grub so you can revert the change afterwards.

That will tell you whether your grub.cfg is being ignored (i.e. grub is using a different config file) or whether the problem is specific to 'ro', which seems unlikely.

Interesting! I tried that and even entering bogus data in /boot/grub/grub.cfg - ie breaking it on purpose - gives me a working grub as if nothing changed. As if that file is not even used by grub. How can i see where grub tries to load it's config from?

Note: EFI motherboard here (in case it matters?)

Offline

#89 2013-08-16 11:38:51

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,721

Re: root device not read-write warning

anonymous_user wrote:

BTW wasn't the grub package recently updated to fix this? Afaik you can just upgrade to the new version and regenerate your config, right?

Only works for new installs because no one ever bothers to take care of their .pacnew files.

Last edited by Mr.Elendig (2013-08-16 11:39:30)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#90 2013-08-16 14:51:13

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: root device not read-write warning

markg85, your motherboard is UEFI?  Are you using UEFI?  The location of the grub.cfg in the case of UEFI is different from the legacy bios.  I am not a grub user, but I seem to recall that it either reads a config from the same directory from which it was launched... or you can specify where it is located.  I know you can at least specify where the grub.efi will live.

There is also the posibility that you created a stand-alone grub as well, which I *think* means that the config is integrated into the grub.efi itself.  I ahve never tried this though, so that iis only what I assumed was meant by stand-alone.

Of course, I am not a grub user, so take my advice iwith a handful of salt.  But I do know that the grub-efi is much more flexable in terms of file locations than the grub-bios.  Hopefully a real UEFI grub user can step in here... cfr?

Offline

#91 2013-08-16 21:11:18

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: root device not read-write warning

grub.cfg can go in different places but if you follow current recommendations, it goes in the same place as for a bios install.

Can you post the output of efibootmgr -v after modprobing efivars? But it is the command you used to install grub to disk that is crucial in determining which grub.cfg it uses. By default /boot/grub/grub.cfg but you can specify somewhere else for almost all of the defaults. Can you post that command, too?

Apart from that, the output of ls -R /boot would be useful with the EFI partition mounted wherever you usually mount it.

Mr.Elendig wrote:
anonymous_user wrote:

BTW wasn't the grub package recently updated to fix this? Afaik you can just upgrade to the new version and regenerate your config, right?

Only works for new installs because no one ever bothers to take care of their .pacnew files.

This is false. Regenerating grub.cfg is enough unless you explicitly added 'ro' to /etc/default/grub in which case you also need to remove it. The update affects a file under /etc/grub.d which is not protected by pacman's backup function so updating grub and regenerating grub.cfg should be sufficient subject to the ro-in-/etc/default/grub caveat.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#92 2013-08-17 00:38:20

60lpsdf250
Member
Registered: 2012-09-23
Posts: 11

Re: root device not read-write warning

falconindy wrote:

Before this thread gets littered with misinformation and "workarounds"...

This is the change in mkinitcpio which generates the warning. It's necessary in response to this systemd commit.

Restated: Previously, if you included the 'fsck' hook in mkinitcpio.conf, early init would write to /run/initramfs/root-fsck after fsck'ing root. This flag file would tell systemd that root has already been checked, and there's no need to check it again. Support for reading this flag file has been removed and now the only indication that systemd should not fsck the root device is that it's mounted read-write. So, if you now include the 'fsck' hook in /etc/mkinitcpio.conf and specify neither 'ro' or 'rw' on your kernel commandline, or explicitly specify 'ro', systemd will fsck your root device again. This is why the warning exists.

Yes, using the 'systemd' hook is an option. An option and not a requirement. Just fix your kernel commandline to specify 'rw' instead of 'ro' (or nothing) so that your root device is mounted rw after fsck'ing.

Thank you, this solved my problem.  I appreciate your insight.

Offline

#93 2013-08-17 03:16:43

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 331

Re: root device not read-write warning

markg85 wrote:

I tried every single solution provided in this thread. The message is gone but that's due to the mkinitcpio stuff. I have no "ro" anywhere anymore yet grup itself (at boot) shows me a ro..

This can happen if this Grub is not controlling the boot, but is just some entry in another bootloader which is not updated to add rw to the kernel line.

Offline

#94 2013-08-18 13:11:58

DogMatix
Member
From: UK
Registered: 2012-11-03
Posts: 12

Re: root device not read-write warning

falconindy wrote:

Before this thread gets littered with misinformation and "workarounds"...

This is the change in mkinitcpio which generates the warning. It's necessary in response to this systemd commit.

Restated: Previously, if you included the 'fsck' hook in mkinitcpio.conf, early init would write to /run/initramfs/root-fsck after fsck'ing root. This flag file would tell systemd that root has already been checked, and there's no need to check it again. Support for reading this flag file has been removed and now the only indication that systemd should not fsck the root device is that it's mounted read-write. So, if you now include the 'fsck' hook in /etc/mkinitcpio.conf and specify neither 'ro' or 'rw' on your kernel commandline, or explicitly specify 'ro', systemd will fsck your root device again. This is why the warning exists.

Yes, using the 'systemd' hook is an option. An option and not a requirement. Just fix your kernel commandline to specify 'rw' instead of 'ro' (or nothing) so that your root device is mounted rw after fsck'ing.

Thanks. Read carefully. Understood. Fixed.

Offline

#95 2013-08-25 12:45:57

GloW_on_dub
Member
Registered: 2013-03-13
Posts: 327

Re: root device not read-write warning

For grub user who, like me,  does not know how to add "rw" in the kernel command line ( from https://wiki.archlinux.org/index.php/Kernel_parameters:
edit /etc/default/grub and add rw at the GRUB_CMDLINE_LINUX_DEFAULT

GRUB_CMDLINE_LINUX_DEFAULT="quiet rw"

Then regenerate your grub.cfg :

 grub-mkconfig -o /boot/grub/grub.cfg

Thanks falconindy for your explanation.

Offline

#96 2013-08-25 13:18:21

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: root device not read-write warning

@GloW_on_dub, the grub package has been fixed to handle this properly now.  There is no need to have rw, as it will be placed in the kernel command line automagically on regeneration.

Offline

Board footer

Powered by FluxBB