You are not logged in.

#1 2005-12-29 10:01:09

starthis
Member
Registered: 2004-12-25
Posts: 45

snd_pcm_oss

I notice that with the latest kernel upgrade to 2.6.14.5, the module snd_pcm_oss errors on modprobing. So I don't have any oss emulation anymore. Anybody else experiencing this?

I noticed this in modprobe.conf.pacnew :

# OSS Compatibility
install snd-pcm modprobe -i snd-pcm ; modprobe snd-pcm-oss ; true
install snd-seq modprobe -i snd-seq ; modprobe snd-seq-oss ; true

if I put that in my modprobe.conf, the system hangs on boot while trying to load those modules.

2.6.14.4 worked fine.
Any ideas?

Offline

#2 2005-12-30 00:50:34

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: snd_pcm_oss

don't have the problem here. try reinstalling alsa-packages.


sorry for my bad english smile

Offline

#3 2005-12-30 08:33:41

starthis
Member
Registered: 2004-12-25
Posts: 45

Re: snd_pcm_oss

thanks for the hint, but that was the first thing I tried.

I have build alsa 1.0.11 RC1, and it works fine  8)


I still don't have a clue why I would need the 2 lines in modprobe.conf though. The modules load fine when its not there.

Offline

#4 2005-12-30 16:20:20

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: snd_pcm_oss

starthis wrote:

I still don't have a clue why I would need the 2 lines in modprobe.conf though. The modules load fine when its not there.

Those lines are there just in case someone loads "snd-pcm" it *also* loads snd-pcm-oss.  Basically, "if we have PCM, let's load OSS compat too"

Offline

Board footer

Powered by FluxBB