You are not logged in.

#1 2005-05-09 06:46:00

Registered: 2003-12-05
Posts: 18

Saitek P880 USB Gamepad

Has anyone gotten one of these to run on an arch system? I've tried googling for a how-to and all I come up with is a little bit of troubleshooting which I was unable to reverse engineer what they did to get mine to work.

I can plug it in, and dmesg sees it

usb 2-2: new low speed USB device using ohci_hcd and address 3
input: USB HID v1.00 Joystick [SAITEK P880] on usb-0000:00:02.0-2

All the lights come on, but I can't use it at all...

Thanks in advance


#2 2005-12-30 21:22:56

Registered: 2005-06-03
Posts: 44

Re: Saitek P880 USB Gamepad

I have this joypad also...


#3 2005-12-30 22:24:09

Registered: 2005-12-30
Posts: 75

Re: Saitek P880 USB Gamepad

I would check to see if there are module specific options in the kernel for this, second I think you need a program that will use this, third you need this setup in xorg.conf? not sure about the last one.


#4 2006-01-01 15:41:48

From: Quebec, Canada
Registered: 2004-02-11
Posts: 13

Re: Saitek P880 USB Gamepad

I tried my PlayStation->USB adapter yesterday and as I understand, you need to load the "joydev" driver like this, in root mode off course:

modprobe joydev

Afterward, you can test the buttons with

cat /dev/input/js0

or another /dev/input/js?
I'm currently there. I guess you need to associate these buttons to a game later on...

Good luck!

"No limits. No fears. No substitutes."


Board footer

Powered by FluxBB