You are not logged in.

#1 2013-08-30 20:47:39

cro
Member
From: Germany
Registered: 2006-01-02
Posts: 101

Flash Plugin constantly crashing on youtube

i686
extra/flashplugin 11.2.202.297-1

crashes with Opera, Chromium and Firefox almost every time on Youtube since an update in the last two days.


EnableLinuxHWVideoDecode=0 already set in /etc/adobe/mms.cfg
also tried re-installing flashplugin and libvdpau

found no interesting error messages when starting firefox from console

Last edited by cro (2013-08-30 23:01:56)

Offline

#2 2013-08-30 21:22:49

headkase
Member
Registered: 2011-12-06
Posts: 1,877

Re: Flash Plugin constantly crashing on youtube

I had the same thing happen to me.  It happened, but not might be related to, when a package named along the lines of "llvm amd gpu" or similar dropped to AUR.  I removed it and then I noticed that flash would crash any time a video was involved.  Removing the AUR package (which isn't available in AUR - it dropped to manually tracked packages) may or may not have had anything to do with it.

Unfortunately I don't have a solution for you.  What I did, since Chromium is my primary browser, is uninstall flashplugin and installed Chromium Pepper Flash Stable.  That package has the advantage of being the most current version of Flash and the disadvantage that it only works in Chromium/Chrome.

Offline

#3 2013-08-31 11:59:49

Usul
Member
Registered: 2007-05-17
Posts: 31

Re: Flash Plugin constantly crashing on youtube

I run into the same problem, using the Nouveau driver for my stone-age nvidia GeForce 6200. After downgrading some packages and a reboot, flash works like before. Here is my pacman line, the package names should by slightly different on a i686 system:

 pacman -U nouveau-dri-9.1.6-1-x86_64.pkg.tar.xz mesa-libgl-9.1.6-1-x86_64.pkg.tar.xz 
   mesa-9.1.6-1-x86_64.pkg.tar.xz llvm-amdgpu-lib-snapshot-20130403-3-x86_64.pkg.tar.xz 

Normally this old versions  should be found in /var/cache/pacman/pkg/ . Of course, this is not a solution, just a temporary workaround.

Last edited by Usul (2013-08-31 12:01:45)

Offline

#4 2013-08-31 14:42:54

MONVMENTVM
Member
Registered: 2007-10-06
Posts: 50

Re: Flash Plugin constantly crashing on youtube

I upgraded my system today after a looong long time of being too lazy for maintenance and surprisingly everything works fine except the flashplugin crashing. Strangely enough I also just removed that llvm-amdgpu-lib-snapshot package but after reading some threads here it seems to be actually caused by libvdpau. A downgrade to libvdpau-0.6-1 also helped in my case (just tested it 5 minutes ago).

As I also just found out that A.R.M. is down I had to look for a while to find that package again, so in case you need it too and don't have it in your cache anymore:
http://shadow.ind.ntou.edu.tw/archlinux … pkg.tar.xz
http://shadow.ind.ntou.edu.tw/archlinux … tar.xz.sig
http://shadow.ind.ntou.edu.tw/archlinux … pkg.tar.xz
http://shadow.ind.ntou.edu.tw/archlinux … tar.xz.sig

Last edited by MONVMENTVM (2013-08-31 14:43:32)

Offline

#5 2013-08-31 21:39:12

Usul
Member
Registered: 2007-05-17
Posts: 31

Re: Flash Plugin constantly crashing on youtube

For me, flash works fine with libvdpau 0.7-1.

Offline

#6 2013-09-01 14:50:54

gsg
Member
Registered: 2008-02-08
Posts: 14

Re: Flash Plugin constantly crashing on youtube

Same problem here - browser crashes when trying to play Youtube videos, but videos from other sites play normally. I am with GeForce 6100 (Integrated) video card and the Nouveau driver. I solved the problem by using smtube to browse Youtube videosand and playing them in smplayer.

Offline

#7 2013-09-01 15:52:24

adam777
Member
Registered: 2012-05-28
Posts: 161

Re: Flash Plugin constantly crashing on youtube

Another workaround for chromium - use the following extension:
https://chrome.google.com/webstore/deta … bmndjpblei
It replaces the YouTube player with Chrome built-in HTML5 player, which plays much better, if you're just interested in watching (no annotations etc.)
It stops working correctly from time to time due to YouTube making changes, but author is very responsive and usually fixes within a day or so.

Offline

#8 2013-09-01 17:58:45

hopimet
Member
Registered: 2013-09-01
Posts: 5

Re: Flash Plugin constantly crashing on youtube

A solution is to go on a website, other than youtube, with an embedded flash video. Then, right click on the video, choose parameter and remove hardware acceleration.
This worked for me. Hope it will help.

Offline

#9 2013-09-01 21:27:15

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,286

Re: Flash Plugin constantly crashing on youtube

I think if you use a HTML5 browser, you don't need flash on youtube.  You can however, use one of the youtube knock-offs from the repos/AUR (e.g. minitube).


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#10 2013-09-02 06:10:01

hopimet
Member
Registered: 2013-09-01
Posts: 5

Re: Flash Plugin constantly crashing on youtube

I'm using html5 in firefox but youtube needs flashplugin although I have selected the html5 option. I also tried this addon without success. Maybe I missed something.

Offline

#11 2013-09-02 06:22:28

gsg
Member
Registered: 2008-02-08
Posts: 14

Re: Flash Plugin constantly crashing on youtube

hopimet wrote:

A solution is to go on a website, other than youtube, with an embedded flash video. Then, right click on the video, choose parameter and remove hardware acceleration.
This worked for me. Hope it will help.

Thanks, this works for me too.

Offline

#12 2013-09-02 11:07:43

cro
Member
From: Germany
Registered: 2006-01-02
Posts: 101

Re: Flash Plugin constantly crashing on youtube

Thx for answers.

So far nothing worked for me.
I have nouveau with an old GeForce 7900 GT.

@Usul: on i686 package dependencies also want me to downgrade ati-dri, at the moment I'm not sure if I want that workaround.

pacman -U nouveau-dri-9.1.6-1-i686.pkg.tar.xz mesa-9.1.6-1-i686.pkg.tar.xz mesa-libgl-9.1.6-1-i686.pkg.tar.xz ati-dri-9.1.6-1-i686.pkg.tar.xz

@MONVMENTVM: have no libvdpau-0,6 and your link doesn't seem to work.

@hopimet: clicking right on flash videos on other websites gives me no helping option. Hardware acceleration should already be disabled in /etc/adobe/mms.cfg if it ever worked on my system anyway.

Last edited by cro (2013-09-02 11:09:05)

Offline

#13 2013-09-05 12:14:55

cro
Member
From: Germany
Registered: 2006-01-02
Posts: 101

Re: Flash Plugin constantly crashing on youtube

Well, downgrading to 9.1.6 works. I tested it on i686 and x86_64.
@Usul: normally llvm-amdgpu-lib-snapshot is not needed, seems to be a special installation of yours

Tested again on x86_64 with firefox 23.0.1:
- no error message on console when flash crashes with nouveau and mesa 9.2.0
- funny: got error message about libvdpau_nouveau not found when flash doesn't crash with nouveau and mesa 9.1.6 -> could that be a hint that that problem lies within libvdpau-nouveau of 9.2.0?? wink


VGA compatible controller: NVIDIA Corporation G71 [GeForce 7900 GT/GTO] (rev a1)

Last edited by cro (2013-09-05 12:18:28)

Offline

#14 2013-09-05 12:38:05

cro
Member
From: Germany
Registered: 2006-01-02
Posts: 101

Re: Flash Plugin constantly crashing on youtube

ok, when testing on i686 I got with 9.2.0:

###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv                                                                                                                                                                                                             
                                                                                                                                                                                                                                                                               
                                                                                                                                                                                                                                                                               
###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

and again with 9.1.6 it works with error message:

Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory

Last edited by cro (2013-09-05 12:54:46)

Offline

#15 2013-09-05 12:38:41

progandy
Member
Registered: 2012-05-17
Posts: 4,133

Re: Flash Plugin constantly crashing on youtube

hopimet wrote:

I'm using html5 in firefox but youtube needs flashplugin although I have selected the html5 option. I also tried this addon without success. Maybe I missed something.

Not all videos are available in a format supported by firefox. We'll have to wait until FF uses gstreamer for html5 videos, then proprietary formats like mp4 will be available and most youtube videos will be in html5 I think.


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Online

#16 2013-09-05 20:46:17

hopimet
Member
Registered: 2013-09-01
Posts: 5

Re: Flash Plugin constantly crashing on youtube

@progandy
Thx, I'll be patient.

Offline

#17 2013-09-06 02:09:03

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,286

Re: Flash Plugin constantly crashing on youtube

cro wrote:

and again with 9.1.6 it works with error message:

Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory

This message is normal for people without nvidia.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#18 2013-09-06 08:38:50

semeion
Member
From: Brazil
Registered: 2008-10-20
Posts: 62

Re: Flash Plugin constantly crashing on youtube

I was with similar problem (i have a FX5200 / NV34), and all time than mesa get update stop my flash and my mplayer like i have reported here:

https://bugs.archlinux.org/task/36004
https://bbs.archlinux.org/viewtopic.php?id=166269
https://bugs.archlinux.org/task/36712
https://bugs.freedesktop.org/show_bug.cgi?id=64582

The problem is, mesa and/or nouveau-dri don´t detect my videocard correctly and/or not consider NV34 can´t handle vdpau driver, and try force use vdpau on it. It is a bug in mesa or nouveau-dri i think.

This problem occur only using xf86-video-nouveau, because nvidia proprietary detect videocard vdpau correctly (mesa/nouveau don´t).

So, my solution was modify mesa PKGBUILD removing vdpau from the package and recompiling it.

In my modification, using abs i compile with makepkg -sr, then i install mesa-9.2.0-1-i686.pkg.tar.xz and nouveau-dri-9.2.0-1-i686.pkg.tar.xz.

Optionally you can install mesa-libgl-9.2.0-1-i686.pkg.tar.xz too. I am. Because all is compiled in same place.

Actually i don´t have more problems. My problem is solved! smile

Sorry for my bad english, i don´t speak english very well.

# $Id: PKGBUILD 193703 2013-08-28 15:19:08Z andyrtr $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Maintainer: Andreas Radke <andyrtr@archlinux.org>

pkgbase=mesa
pkgname=('ati-dri' 'intel-dri' 'nouveau-dri' 'svga-dri' 'mesa' 'mesa-libgl')
pkgver=9.2.0
pkgrel=1
arch=('i686' 'x86_64')
makedepends=('python2' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'libxxf86vm' 'libxdamage'
             'libvdpau' 'wayland' 'elfutils' 'llvm' 'systemd')
url="http://mesa3d.sourceforge.net"
license=('custom')
options=('!libtool')
source=(ftp://ftp.freedesktop.org/pub/mesa/9.2/MesaLib-${pkgver}.tar.bz2
        LICENSE)
md5sums=('4185b6aae890bc62a964f4b24cc1aca8'
         '5c65a0fe315dd347e09b1f2826a1df5a')

build() {
    cd ${srcdir}/?esa-*

    autoreconf -vfi # our automake is far too new for their build system :)

    ./configure --prefix=/usr \
    --sysconfdir=/etc \
    --with-dri-driverdir=/usr/lib/xorg/modules/dri \
    --with-gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast \
    --with-dri-drivers=i915,i965,r200,radeon,nouveau,swrast \
    --with-egl-platforms=x11,drm,wayland \
    --with-llvm-shared-libs \
    --enable-gallium-llvm \
    --enable-egl \
    --enable-gallium-egl \
    --enable-shared-glapi \
    --enable-gbm \
    --enable-glx-tls \
    --enable-dri \
    --enable-glx \
    --enable-osmesa \
    --enable-gles1 \
    --enable-gles2 \
    --enable-texture-float \
    --enable-xa \
    --disable-vdpau \
    # --help

    make

    # fake installation
    mkdir $srcdir/fakeinstall
    make DESTDIR=${srcdir}/fakeinstall install
}

package_ati-dri() {
  pkgdesc="Mesa drivers for AMD/ATI Radeon"
  depends=("mesa-libgl=${pkgver}")
  optdepends=('libtxc_dxtn: S3 Texture Compressed support')
  conflicts=('xf86-video-ati<6.9.0-6')

#  install -m755 -d ${pkgdir}/usr/lib/vdpau/
#  mv -v ${srcdir}/fakeinstall/usr/lib/vdpau/libvdpau_{r300,r600,radeonsi}.* ${pkgdir}/usr/lib/vdpau/

  install -m755 -d ${pkgdir}/usr/lib/xorg/modules/dri
  mv -v ${srcdir}/fakeinstall/usr/lib/xorg/modules/dri/{r200,r300,r600,radeon,radeonsi}_dri.so ${pkgdir}/usr/lib/xorg/modules/dri/
  
  install -m755 -d ${pkgdir}/usr/lib/gallium-pipe
  mv -v ${srcdir}/fakeinstall/usr/lib/gallium-pipe/pipe_{r300,r600,radeonsi}* ${pkgdir}/usr/lib/gallium-pipe/
  
  install -m755 -d "${pkgdir}/usr/share/licenses/ati-dri"
  install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/ati-dri/"
}

package_intel-dri() {
  pkgdesc="Mesa drivers for Intel"
  optdepends=('libtxc_dxtn: S3 Texture Compressed support')
  depends=("mesa-libgl=${pkgver}")

  install -m755 -d ${pkgdir}/usr/lib/xorg/modules/dri
  mv -v ${srcdir}/fakeinstall/usr/lib/xorg/modules/dri/{i915,i965}_dri.so ${pkgdir}/usr/lib/xorg/modules/dri/

  install -m755 -d "${pkgdir}/usr/share/licenses/intel-dri"
  install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/intel-dri/"
}

package_nouveau-dri() {
  pkgdesc="Mesa drivers for Nouveau"
  optdepends=('libtxc_dxtn: S3 Texture Compressed support')
  depends=("mesa-libgl=${pkgver}")

#  install -m755 -d ${pkgdir}/usr/lib/vdpau/
#  mv -v ${srcdir}/fakeinstall/usr/lib/vdpau/libvdpau_nouveau.* ${pkgdir}/usr/lib/vdpau/

  install -m755 -d ${pkgdir}/usr/lib/xorg/modules/dri
  mv -v ${srcdir}/fakeinstall/usr/lib/xorg/modules/dri/nouveau_{dri,vieux_dri}.so ${pkgdir}/usr/lib/xorg/modules/dri/
  
  install -m755 -d ${pkgdir}/usr/lib/gallium-pipe
  mv -v ${srcdir}/fakeinstall/usr/lib/gallium-pipe/pipe_nouveau* ${pkgdir}/usr/lib/gallium-pipe/
  
  install -m755 -d "${pkgdir}/usr/share/licenses/nouveau-dri"
  install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/nouveau-dri/"
}

package_svga-dri() {
  pkgdesc="Gallium3D VMware guest GL driver"
  depends=('libdrm' 'expat' 'llvm-libs')

  install -m755 -d ${pkgdir}/usr/lib/xorg/modules/dri
  mv -v ${srcdir}/fakeinstall/usr/lib/xorg/modules/dri/vmwgfx_dri.so ${pkgdir}/usr/lib/xorg/modules/dri/

  install -m755 -d ${pkgdir}/usr/lib/gallium-pipe
  mv -v ${srcdir}/fakeinstall/usr/lib/gallium-pipe/pipe_vmwgfx* ${pkgdir}/usr/lib/gallium-pipe/
  
  install -m755 -d "${pkgdir}/usr/share/licenses/svga-dri"
  install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/svga-dri/"
}

package_mesa() {
  pkgdesc="an open-source implementation of the OpenGL specification"
  depends=('libdrm' 'libvdpau' 'wayland' 'libxxf86vm' 'libxdamage' 'systemd' 'elfutils' 'llvm-libs')
  optdepends=('opengl-man-pages: for the OpenGL API man pages')
  provides=('libglapi' 'osmesa' 'libgbm' 'libgles' 'libegl' 'khrplatform-devel')
  conflicts=('libglapi' 'osmesa' 'libgbm' 'libgles' 'libegl' 'khrplatform-devel')
  replaces=('libglapi' 'osmesa' 'libgbm' 'libgles' 'libegl' 'khrplatform-devel')

  mv -v ${srcdir}/fakeinstall/* ${pkgdir}
  # rename libgl.so to not conflict with blobs - may break gl.pc ?
  mv ${pkgdir}/usr/lib/libGL.so.1.2.0 	${pkgdir}/usr/lib/mesa-libGL.so.1.2.0
  rm ${pkgdir}/usr/lib/libGL.so{,.1}

  install -m755 -d "${pkgdir}/usr/share/licenses/mesa"
  install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa/"
}

package_mesa-libgl() {
  pkgdesc="Mesa 3-D graphics library"
  depends=("mesa=${pkgver}")
  provides=("libgl=${pkgver}")
  replaces=('libgl')
 
  # See FS#26284
  install -m755 -d "${pkgdir}/usr/lib/xorg/modules/extensions"
  ln -s libglx.xorg "${pkgdir}/usr/lib/xorg/modules/extensions/libglx.so"

  ln -s mesa-libGL.so.1.2.0      ${pkgdir}/usr/lib/libGL.so
  ln -s mesa-libGL.so.1.2.0      ${pkgdir}/usr/lib/libGL.so.1
  ln -s mesa-libGL.so.1.2.0      ${pkgdir}/usr/lib/libGL.so.1.2.0

  install -m755 -d "${pkgdir}/usr/share/licenses/mesa-libgl"
  install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa-libgl/"
}

Last edited by semeion (2013-09-06 08:44:11)

Offline

#19 2013-09-08 11:47:17

cro
Member
From: Germany
Registered: 2006-01-02
Posts: 101

Re: Flash Plugin constantly crashing on youtube

@semeion:
Thank you for your input. Recompiling seems to be a worse workround for me than just sticking with old version 9.1.6.
Is there something I can do? Should I post a bug report somewhere?

--
The funny thing seems to me that 9.1.6. probably just works because libvdpau-nouveau is missing in the nouveau-dri package in comparison to the 9.2.0 version of the package:

# pacman -Ql nouveau-dri
nouveau-dri /usr/
nouveau-dri /usr/lib/
nouveau-dri /usr/lib/gallium-pipe/
nouveau-dri /usr/lib/gallium-pipe/pipe_nouveau.so
nouveau-dri /usr/lib/xorg/
nouveau-dri /usr/lib/xorg/modules/
nouveau-dri /usr/lib/xorg/modules/dri/
nouveau-dri /usr/lib/xorg/modules/dri/nouveau_dri.so
nouveau-dri /usr/lib/xorg/modules/dri/nouveau_vieux_dri.so
nouveau-dri /usr/share/
nouveau-dri /usr/share/licenses/
nouveau-dri /usr/share/licenses/nouveau-dri/
nouveau-dri /usr/share/licenses/nouveau-dri/LICENSE
# tar --xz -tf /lib/cache/pacman/pkg/nouveau-dri-9.2.0-1-i686.pkg.tar.xz
.PKGINFO
.MTREE
usr/
usr/lib/
usr/share/
usr/share/licenses/
usr/share/licenses/nouveau-dri/
usr/share/licenses/nouveau-dri/LICENSE
usr/lib/vdpau/
usr/lib/xorg/
usr/lib/gallium-pipe/
usr/lib/gallium-pipe/pipe_nouveau.so
usr/lib/xorg/modules/
usr/lib/xorg/modules/dri/
usr/lib/xorg/modules/dri/nouveau_dri.so
usr/lib/xorg/modules/dri/nouveau_vieux_dri.so
usr/lib/vdpau/libvdpau_nouveau.so
usr/lib/vdpau/libvdpau_nouveau.so.1
usr/lib/vdpau/libvdpau_nouveau.so.1.0.0

Maybe I could use 9.2.0 and just get rid of libvdpau_nouveau. big_smile
EDIT: EDIT: flash on youtube works, but then mplayer stops working ... so back to 9.1.6 Whoops, deleted the wrong files.

Last edited by cro (2013-09-08 20:33:19)

Offline

#20 2013-09-09 14:14:26

semeion
Member
From: Brazil
Registered: 2008-10-20
Posts: 62

Re: Flash Plugin constantly crashing on youtube

cro wrote:

Maybe I could use 9.2.0 and just get rid of libvdpau_nouveau. big_smile

Try it.

Offline

#21 2013-09-09 18:58:06

flateric
Member
Registered: 2007-08-28
Posts: 49

Re: Flash Plugin constantly crashing on youtube

Hello,

I have ATI x1400 with opensource driver radeon. Inserting "export VDPAU_DRIVER=va_gl" in to .bashrc (and relogin) and flash works well for me.

Offline

#22 2013-09-11 08:01:50

finalizer
Member
From: Israel
Registered: 2013-09-11
Posts: 21

Re: Flash Plugin constantly crashing on youtube

flateric wrote:

Inserting "export VDPAU_DRIVER=va_gl" in to .bashrc (and relogin) and flash works well for me.

To me too. Thanks for sharing this workaround.
I've NVidia FX-5500 and nouveau driver.

Waiting for the real fix in Mesa.

Offline

#23 2013-09-13 13:05:29

cro
Member
From: Germany
Registered: 2006-01-02
Posts: 101

Re: Flash Plugin constantly crashing on youtube

semeion wrote:
cro wrote:

Maybe I could use 9.2.0 and just get rid of libvdpau_nouveau. big_smile

Try it.

Of course I tried it! wink And it worked well (after I noticed that I deleted the wrong files at first).

It seem the new package version nouveau-dri-2.0-2 does the same fix now, thanks. big_smile

Last edited by cro (2013-09-13 13:06:20)

Offline

#24 2013-09-17 03:34:29

mapintar
Member
Registered: 2010-04-17
Posts: 50

Re: Flash Plugin constantly crashing on youtube

progandy wrote:
hopimet wrote:

I'm using html5 in firefox but youtube needs flashplugin although I have selected the html5 option. I also tried this addon without success. Maybe I missed something.

Not all videos are available in a format supported by firefox. We'll have to wait until FF uses gstreamer for html5 videos, then proprietary formats like mp4 will be available and most youtube videos will be in html5 I think.

Try this firefox extension: https://addons.mozilla.org/pt-BR/firefo … 5/?src=api

I'm using and enjoying it.

After install extension, visit this site for youtube html5: http://www.youtube.com/html5

Offline

#25 2013-09-21 16:18:13

scjet
Banned
Registered: 2011-07-23
Posts: 172

Re: Flash Plugin constantly crashing on youtube

gawd I hate adobe for yet the 1000'th flashback crashing yet again.

-3.11.1-1-ARCH (x86_64 with multilib, ...)
-flashplugin 11.2.202.310-1
-nvidia 325.15-7

Judgeing by the so many diferent hard/soft systems here, it's hard to tell what's goin' on with flash again? -it is for me anyway.

I guess untill we truly go to a more "standardized" HTML5,.. and convert everything past and present to it, we're gonna be stuck with this caca, over and over again, ...
Certain things (like this) just need to be open standard, ..., but then I woke up in another puddle.

Anyway, I solved my particular flashplugin crashing by simply re-Commenting that silly /etc/adobe/mms.conf file (aka do NOT un-comment it), and all woked ok, so far, for me, with my setup.

Last edited by scjet (2013-09-21 16:22:46)


The "BSD" things in life are "Free", and "Open", and so is "Arch"

Offline

Board footer

Powered by FluxBB