You are not logged in.

#1 2013-08-27 04:28:45

Shim
Member
Registered: 2013-08-23
Posts: 16

Problems after installation/upgrade of graphical and multimedia packag

I was trying to install screencasting and video editing software, ran into few problems (missing dependencies, file already exists on the filesystem). I ended up upgrading libpng package, now I have libpng16. Most (probably all) of my graphical and multimedia packages require libpng15 that I don't have on the system anymore: when I tried to start them from command-line I got the message

error while loading shared libraries: libpng15.so.15: cannot open shared object file: No such file or directory

I tried to upgrade packages (GIMP, GWENVIEW, SMPlayer) and I got error message

gtk-update-icon-cache: error while loading shared libraries: libpng15.so.15: cannot open shared object file: No such file or directory

How can I fix this?

Edit: Apparently none of the KDE-based programs work, same problem with libpng15

Last edited by Shim (2013-08-27 04:47:41)

Offline

#2 2013-08-27 05:12:43

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,105
Website

Re: Problems after installation/upgrade of graphical and multimedia packag


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2013-08-27 15:35:52

Shim
Member
Registered: 2013-08-23
Posts: 16

Re: Problems after installation/upgrade of graphical and multimedia packag

I understand that but how do I fix it?

Offline

#4 2013-08-27 15:39:21

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: Problems after installation/upgrade of graphical and multimedia packag

Fully update your system.


gtk-update-icon-cache error should be harmless: https://bbs.archlinux.org/viewtopic.php?id=162661

Last edited by karol (2013-08-27 15:40:39)

Offline

#5 2013-08-28 04:47:51

Shim
Member
Registered: 2013-08-23
Posts: 16

Re: Problems after installation/upgrade of graphical and multimedia packag

karol wrote:

Fully update your system.


gtk-update-icon-cache error should be harmless: https://bbs.archlinux.org/viewtopic.php?id=162661

Thank you.

I ran pacman -Syu and the first package I had to upgrade was pacman itself. I ran into the following problem:

error: failed to commit transaction (conflicting files)
filesystem: /bin exists in filesystem
filesystem: /sbin exists in filesystem
filesystem: /usr/sbin exists in filesystem
Errors occurred, no packages were upgraded.

Wiki explains this situation with file, those are directories and I am not sure if I can follow the advice on Wiki.

Offline

#6 2013-08-28 04:51:58

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,316

Re: Problems after installation/upgrade of graphical and multimedia packag

https://www.archlinux.org/news/binaries … ervention/
And search the forum for the uber threads covering this

Offline

#7 2013-08-29 05:32:19

Shim
Member
Registered: 2013-08-23
Posts: 16

Re: Problems after installation/upgrade of graphical and multimedia packag

skunktrader wrote:

https://www.archlinux.org/news/binaries … ervention/
And search the forum for the uber threads covering this

Thank you!
I ran into a problem with the very first command. Here is the list of files I got:

[root@::1       vikaArch localhost vika]# pacman -Qqo /bin /sbin /usr/sbin/ | pacman -Qm -error: cannot determine ownership of directory '/bin'
error: cannot determine ownership of directory '/sbin'
error: cannot determine ownership of directory '/usr/sbin/'
consolekit 0.4.6-4
dbus-core 1.6.4-1
eject 2.1.5-7
grub-bios 2.00-1
grub-common 2.00-1
hpoj 0.91-17
hsqldb-java 1:1.8.0.10-2
icedtea-web 1.3-1
initscripts 2012.08.3-2
kdeadmin-system-config-printer-kde 4.9.1-1
kdeartwork-aurorae 4.9.1-1
kdegames-kbattleship 4.9.1-1
kdegames-ktron 4.9.1-1
kdegames-libkdegames 4.9.1-1
kdegames-libkmahjongg 4.9.1-1
kdeplasma-addons-applets-kdeobservatory 4.9.1-1
kdesdk-kioslave 4.9.1-1
kdesdk-kmtrace 4.9.1-1
kdesdk-kpartloader 4.9.1-1
kdesdk-kprofilemethod 4.9.1-1
kdesdk-kstartperf 4.9.1-1
kdesdk-kuiviewer 4.9.1-1
kdesdk-scripts 4.9.1-1
kdesdk-strigi-analyzer 4.9.1-1
kdeutils-printer-applet 4.9.1-1
khrplatform-devel 8.0.4-3
lib32-dbus-core 1.6.4-1
lib32-libgl 8.0.4-4
lib32-libglapi 8.0.4-4
lib32-qt 4.8.2-2
libegl 8.0.4-3
libgbm 8.0.4-3
libgl 8.0.4-3
libglapi 8.0.4-3
libgles 8.0.4-3
libmysqlclient 5.5.27-4
libwebkit 1.8.3-1
lilo 23.2-3
mysql 5.5.27-4
mysql-clients 5.5.27-4
netcfg 2.8.10-1
openjdk6 6.b24_1.11.4-1
pacman-contrib 4.0.3-1
poppler-qt 0.20.3-1
pyqt-common 4.9.4-2
python-imaging 1.1.7-4
python-mechanize 0.2.5-2
python-pycurl 7.19.0-6
python2-pyqt 4.9.4-2
qt 4.8.2-3
system-config-printer-common 1.3.10-1
sysvinit 2.88-7

It didn't seem right to me but I still tried to remove them. As result I was getting messages about different programs using those packages. For example,

root@::1       vikaArch localhost vika]# pacman -R qt
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: attica: requires qt
:: fbreader: requires qt
:: grantlee: requires qt
:: kde-agent: requires qt
:: kdesdk-poxml: requires qt
:: lib32-qt: requires qt
:: libdbusmenu-qt: requires qt
:: liblastfm: requires qt
:: libqzeitgeist: requires qt
:: phonon: requires qt
:: polkit-qt: requires qt
:: poppler-qt: requires qt
:: prison: requires qt
:: qca: requires qt
:: qimageblitz: requires qt
:: qjson: requires qt
:: qscintilla: requires qt
:: qtwebkit: requires qt
:: qwt: requires qt
:: smplayer: requires qt
:: soprano: requires qt
:: telepathy-qt: requires qt

What should I do now?

Offline

#8 2013-08-29 05:41:52

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: Problems after installation/upgrade of graphical and multimedia packag

When pasting configs, code or command output, please use [ code ] tags, not [ quote ] tags https://bbs.archlinux.org/help.php#bbcode

like this


qt has been renamed to qt4. https://www.archlinux.org/news/qt4-replaces-qt/



Have you considered reinstalling your system? Since you haven't updated in quite a while, it might be faster and safer.

Offline

#9 2013-08-29 13:37:46

Shim
Member
Registered: 2013-08-23
Posts: 16

Re: Problems after installation/upgrade of graphical and multimedia packag

karol wrote:

When pasting configs, code or command output, please use [ code ] tags, not [ quote ] tags https://bbs.archlinux.org/help.php#bbcode

like this


qt has been renamed to qt4. https://www.archlinux.org/news/qt4-replaces-qt/



Have you considered reinstalling your system? Since you haven't updated in quite a while, it might be faster and safer.

I am considering it but haven't decided yet. I still want to make this work.

Offline

#10 2013-08-29 15:02:36

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,702

Re: Problems after installation/upgrade of graphical and multimedia packag

dbus-core was merged into dbus last Dec. This puts your last full update before /lib symlink moved from the glibc package to the filesystem package. If your glibc and filesystem are from before Jan 2013, the update is going to be much, much more difficult. You're better off reinstalling.

Edit: I had to look it up, but eject was merged into util-linux in Sept 2012. We're getting dangerously close to the last major user intervention. Is /lib even a symlink?

Last edited by Scimmia (2013-08-29 15:10:27)

Offline

#11 2013-09-13 05:50:18

Shim
Member
Registered: 2013-08-23
Posts: 16

Re: Problems after installation/upgrade of graphical and multimedia packag

Thank you everyone for help. I ended up reinstalling the system.
After reinstalling it I ran into a couple of problems that I don't know how to resolve. My main issue is with latex. I tried installing texlive-most package and I'm getting error

error: texlive-core: signature from "Rémy Oudompheng <remy@archlinux.org>" is invalid
:: File /var/cache/pacman/pkg/texlive-core-2013.30962-2-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
...
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

I am not sure how to get around this problem. Everything I read that was posted about the bug and *pacnew files solves the problem if latex is installed on the system, which I don't have.

Offline

#12 2013-09-13 05:52:28

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,105
Website

Re: Problems after installation/upgrade of graphical and multimedia packag

pacman's prompt is telling you what to do...


Not a pacman issue, moving to NC.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#13 2013-09-13 05:54:15

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Problems after installation/upgrade of graphical and multimedia packag

Either the download got f*cked up somehow (like actual corruption), or it is reporting that there is corruption because it can't verify the GnuPG signature (in this case Rémy Oudompheng <remy@archlinux.org>).

There is a wiki page on pacman-key.  Go check that out and it will tell you how to update your trusted keys to make sure you are up to date.

Offline

#14 2013-09-13 17:45:22

Shim
Member
Registered: 2013-08-23
Posts: 16

Re: Problems after installation/upgrade of graphical and multimedia packag

jasonwryan wrote:

pacman's prompt is telling you what to do...

Not really. It suggests to delete the "corrupted" file. I tried both ways (saying yes and no to the deletion) but it ends with the same result: nothing is installed. Same problem with skype installation, complains about lib32 file corruption.

WonderWoofy wrote:

Either the download got f*cked up somehow (like actual corruption), or it is reporting that there is corruption because it can't verify the GnuPG signature (in this case Rémy Oudompheng <remy@archlinux.org>).

There is a wiki page on pacman-key.  Go check that out and it will tell you how to update your trusted keys to make sure you are up to date.

There is a problem with LaTeX package in the latest upgrade but everything I found reffers to the fixing corrupted upgrade which is not my case.
I tried to update the trusted keys but this doesn't help either, I'm getting the same message.

Offline

#15 2013-09-13 18:55:06

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Problems after installation/upgrade of graphical and multimedia packag

Shim wrote:

I tried to update the trusted keys but this doesn't help either…

…and what does this mean?  For all anyone on these forums knows, you might have dug for boogers in your left nostril in an attempt to fix your pacman keys.

I just tested the installation of texlive-core on my machine, and things work perfectly fine (as expected). 

BTW, jasonwryan is right, the pacman prompt is indeed telling you what is going wrong here.  It may not be giving you explicit commands that will fix it, but it is certainly telling you where to look.

Offline

#16 2013-09-13 20:04:18

Shim
Member
Registered: 2013-08-23
Posts: 16

Re: Problems after installation/upgrade of graphical and multimedia packag

WonderWoofy wrote:

…and what does this mean?  For all anyone on these forums knows, you might have dug for boogers in your left nostril in an attempt to fix your pacman keys.

It means that I followed the wiki page, had no problem updating the pacman-keys, some of them were updated, some were kept without change. I tried to install texlive and skype after that and I was getting the same error messages as before.

WonderWoofy wrote:

I just tested the installation of texlive-core on my machine, and things work perfectly fine (as expected). 

BTW, jasonwryan is right, the pacman prompt is indeed telling you what is going wrong here.  It may not be giving you explicit commands that will fix it, but it is certainly telling you wheerre to look.

I solved my problem after updating mirrorlist again. I did that once after installing the system (few days ago), not sure what went wrong the first time or why it stopped working but after I updated mirrorlist + pacman -Syy + pacman -S --force pacman-mirrorlist bothe texlive and skype got installed.

I am new to Arch and I am trying to learn, I appreciate helpful comments.

Last edited by Shim (2013-09-13 21:24:15)

Offline

#17 2013-09-14 02:21:02

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Problems after installation/upgrade of graphical and multimedia packag

Sometimes the mirrors get old stale and crusty… potentially like those boogers.  So when in doubt, there is a page where you can check the status of all the Arch mirrors.  If you feel like there is potentially a better mirror out there, and don't feel like opening a browser, you can generate a new mirrorlist with the same tool that generates the list in the pacman-mirrorlist.  It is called reflector, and it pretty straight forward it its use, but there is also a wiki page for it

What I do is I actually generate a list with reflector with about 15 mirrors from the USA (my home country, which has many many mirrors).  Then I use rankmirrors to sort them by how fast they respond from my particular location.  Typically if there are mirrors I don't recognize on the top of the list generated by rankmirrors, I check them against the mirrorlist to ensure that there aren't any crappy mirrors on the bottom of my reflector list.

Typically, I end up with mirrors.kernel.org on the top of my list.  This is by far the fastest, but it also randomly gets out of sync from time to time.  Since I never know when this is going to happen, I keep it on the top and use it as normal, but if things go awry, I just comment it out, and try again (making sure I issue an -Syy to forse redownloading of the databases).

Helpful?

Offline

#18 2013-09-14 04:25:31

Shim
Member
Registered: 2013-08-23
Posts: 16

Re: Problems after installation/upgrade of graphical and multimedia packag

Yes, helpful, thank you.
I didn't even think that the problem might be with the mirrorlist since the system is freshly installed couple of days ago and I updated mirrorlist after that. I am not sure what went wrong with that. I came across the solution by accident by trying something else (don't remember what already), getting an error message and then searching that message on internet

Offline

Board footer

Powered by FluxBB