You are not logged in.

#1 2013-09-14 03:07:26

darkreaper476
Member
Registered: 2010-05-17
Posts: 98

KDE 4.11 vsync issues

Hello all, Since the update to 4.11 we have gained a few new options in the advance tab of the Desktop Effects settings. Some in which have to do with vsync. When I choose either Automatic or Re-use screen content the screen becomes blurry unless recently updated with a hover over or high light. With either of these options the screens do NOT tear, which is great. While with the other options I still get a significant amount of tearing. I was wondering if anyone had anything to say about this that might help the issue.

I am using openGL 3.1 option/raster. latest Nvidia proprietary drivers on a GTX 680M.

Thanks. I can upload a video or screen shots to help understand what is happening if I must.

Thanks


I am opposed to millionaires, but it would be dangerous to offer me the position. -Mark Twain

Offline

#2 2013-09-14 05:14:05

Beelzebud
Member
From: Illinois, U.S.
Registered: 2010-07-16
Posts: 154

Re: KDE 4.11 vsync issues

I can't seem to get vsync to work with videos in VLC.   I'm using KDE 4.11.1, a GTX 650 Ti Boost with the latest drivers.   I've tried the open gl 1.3, and 1.2 settings.   I've messed with different options in vlc, nvidia-settings, and kwin but nothing seems to truly enable it.

Offline

#3 2013-09-14 05:58:14

awbs
Member
Registered: 2013-01-18
Posts: 25

Re: KDE 4.11 vsync issues

I noticed I had awful tearing issues today across the whole desktop. (KDE 4.11.5, Nvidia GeForce 675M)  I went to Desktop Effects and changed:
Compositing Type to OpenGL 3.1 (from 2.0).
QT graphics system: Raster.
Scale Method: Accurate
Suspend Desktop effects for fullscreen windows checked
Tearing Prevention: Re-use screen content, although full-screen repaints seems to work just as well.

I don't know if this had any effect but I disabled and reenabled desktop effects with the Alt+F12 keyboard shortcut.

In VLC > Tools > Preferences > Check "All" radiobox.
Go to Videos > Output module. Select "X11 video output (XCB)"
Expand "Output modules", click XVideo, make sure both boxes have a 0 value.

This fixed all tearing issues, including outside of VLC.

Oh, and I also have Hardware Decoding disabled in VLC.

Edit: after rebooting the tearing comes back until I do a ALT+F12 disable/reenable, then is disappears until the next session.

Edit2: Sometimes I have to reselect the same settings in the Advanced tab in Desktop Effects, like changing it from OpenGL 3 to OpenGL 2 to OpenGL3 then click apply. Then disable and reenable desktop effects and it works fine.

I'm glad I found a way to make vsync work but it's aggravating going through hoops to get it enabled every reboot.

Last edited by awbs (2013-09-14 08:07:39)

Offline

#4 2013-09-14 11:48:19

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: KDE 4.11 vsync issues

It's a known bug. I submitted it a couple of days ago and it was marked as duplicate of this:
https://bugs.kde.org/show_bug.cgi?id=322060

You can get VSync working again by switching from OpenGL X to OpenGL Y one time in the KWin settings. On NVIDIA hardware vsync is lost about 4 seconds after the desktop starts. You can observe this by enableing the "show fps" effect for Kwin and boot your PC. It will be capped at 60 FPS initially but rise above your monitors refreshrate after 3-4 seconds at this points you'll also see tearing when dragging windows.

Last edited by blackout23 (2013-09-14 11:48:44)

Offline

#5 2013-09-14 16:20:33

Beelzebud
Member
From: Illinois, U.S.
Registered: 2010-07-16
Posts: 154

Re: KDE 4.11 vsync issues

Thanks for the tips guys.   Switching from one OpenGL version to the other one time, does seem to correct this for the session.  Hopefully the fix will be pulled in soon.   I guess I picked the wrong day to switch from AMD to nvidia on that machine.  smile

Offline

#6 2013-09-15 03:32:50

lam
Member
Registered: 2012-01-30
Posts: 14

Re: KDE 4.11 vsync issues

I also know this bug so i switch from NVIDIA to AMD

I have solved the tearing by enable Triplebuffering in nvidia

https://wiki.archlinux.org/index.php/NV … _buffering

Then creat a file called Tearing.sh in /etc/profile.d/

# /etc/profile.d/Tearing.sh
export KWIN_TRIPLE_BUFFER=1

make it exeutable

# chmod +x /etc/profile.d/Tearing.sh

Reboot ,  Be Happy wink

Last edited by lam (2013-09-15 03:38:40)

Offline

#7 2013-09-15 07:23:44

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,432

Re: KDE 4.11 vsync issues

triple buffering can cause vsync issues too depending on the gpu.
In that cases this environment:
export __GL_YIELD="USLEEP"
can be used in place of export KWIN_TRIPLE_BUFFER=1
to make kwin happy.

Offline

#8 2013-09-16 02:42:42

darkreaper476
Member
Registered: 2010-05-17
Posts: 98

Re: KDE 4.11 vsync issues

kokoko3k wrote:

triple buffering can cause vsync issues too depending on the gpu.
In that cases this environment:
export __GL_YIELD="USLEEP"
can be used in place of export KWIN_TRIPLE_BUFFER=1
to make kwin happy.


Where is this file?


Restarting the compositor does not help me. Any one else getting the blurry screen?

And is anyone else experiencing extremely unstable X environment with KDE lately? I cant even disconnect my second monitor with out everything breaking. Playing a game or trying to run another environment in another session even breaks everything... I had to kill X when trying to play Cave Story and now Steam wont start... WTF...


I am opposed to millionaires, but it would be dangerous to offer me the position. -Mark Twain

Offline

#9 2013-09-16 08:36:01

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,432

Re: KDE 4.11 vsync issues

Lam told you where to create and put that file, i said that you can use another content for it.

Offline

#10 2013-09-18 07:04:58

darkreaper476
Member
Registered: 2010-05-17
Posts: 98

Re: KDE 4.11 vsync issues

kokoko3k wrote:

Lam told you where to create and put that file, i said that you can use another content for it.

Oh I see now, I'll give it a shot when I can. Or if I don't change environments again... KDE is becoming EXTREMELY unstable for me... I have to kill X way too often now... I can't even give a reason... Sometimes because I'm trying to run a game, sometimes because I minimize a window hmm

Thanks though!


I am opposed to millionaires, but it would be dangerous to offer me the position. -Mark Twain

Offline

#11 2013-09-18 07:23:54

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,432

Re: KDE 4.11 vsync issues

What do you mean with unstable?
Latest kde with latest nvidia drivers could lead sometimes to the frozen desktop with a working mouse pointer.
But that's just a matter of the compositor, and ALT+Shift+F12 twice fixes it.

Offline

#12 2013-09-19 09:39:32

Beelzebud
Member
From: Illinois, U.S.
Registered: 2010-07-16
Posts: 154

Re: KDE 4.11 vsync issues

I've tried every suggestion in this thread but I can't get vsync to function correctly at all.   Sometimes reloading the OpenGL renderer in Kwin fixes it, but it's not consistent, and doesn't work a lot of the time.  It makes watching video very annoying.  When I log over to Gnome, vsync works just fine.

Last edited by Beelzebud (2013-09-19 18:33:40)

Offline

#13 2013-09-20 06:26:16

darkreaper476
Member
Registered: 2010-05-17
Posts: 98

Re: KDE 4.11 vsync issues

kokoko3k wrote:

What do you mean with unstable?
Latest kde with latest nvidia drivers could lead sometimes to the frozen desktop with a working mouse pointer.
But that's just a matter of the compositor, and ALT+Shift+F12 twice fixes it.

I'll try and get a pic of it when it happens, but when KDE crashes on me it looks like my screen SHATTERED, it fragments the screen into multiple sharps shapes then eventually goes black... The cursor is still there but nothing works... I have to ctrl+shft+f2 login and kill X every time...


I am opposed to millionaires, but it would be dangerous to offer me the position. -Mark Twain

Offline

#14 2013-09-20 12:00:41

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: KDE 4.11 vsync issues

kokoko3k wrote:

What do you mean with unstable?
Latest kde with latest nvidia drivers could lead sometimes to the frozen desktop with a working mouse pointer.
But that's just a matter of the compositor, and ALT+Shift+F12 twice fixes it.

Don't have any problems with KDE 4.11.1 on both my NVIDIA systems. Apart from having to change OGL backend twice at the beginning to get vsync.

Offline

#15 2013-10-01 17:07:03

Beelzebud
Member
From: Illinois, U.S.
Registered: 2010-07-16
Posts: 154

Re: KDE 4.11 vsync issues

blackout23 wrote:
kokoko3k wrote:

What do you mean with unstable?
Latest kde with latest nvidia drivers could lead sometimes to the frozen desktop with a working mouse pointer.
But that's just a matter of the compositor, and ALT+Shift+F12 twice fixes it.

Don't have any problems with KDE 4.11.1 on both my NVIDIA systems. Apart from having to change OGL backend twice at the beginning to get vsync.

I consider that a problem.   You shouldn't have to mess with the render engine every time you start your DE.   No combination of fixes has resolved this issue for me.  Under KDE 4.11 I simply can not view full screen video without screen tearing.   I've tried using fresh xorg configs, fresh KDE user accounts, etc.   Nothing works.

Offline

#16 2013-10-02 02:42:53

Beelzebud
Member
From: Illinois, U.S.
Registered: 2010-07-16
Posts: 154

Re: KDE 4.11 vsync issues

Still issues with vsync in 4.11.2, although now if I disable "Suspend desktop effects for fullscreen windows", vsync begins working fine.

Last edited by Beelzebud (2013-10-02 02:50:19)

Offline

#17 2013-12-07 18:17:22

firekage
Member
From: Eastern Europe, Poland
Registered: 2013-06-30
Posts: 470

Re: KDE 4.11 vsync issues

lam wrote:

I also know this bug so i switch from NVIDIA to AMD

I have solved the tearing by enable Triplebuffering in nvidia

https://wiki.archlinux.org/index.php/NV … _buffering

Then creat a file called Tearing.sh in /etc/profile.d/

# /etc/profile.d/Tearing.sh
export KWIN_TRIPLE_BUFFER=1

make it exeutable

# chmod +x /etc/profile.d/Tearing.sh

Reboot ,  Be Happy wink

Doesen't work for my GTX260. I exported KWIN_TRIPLE_BUFFER=1  and __GL_YIELD="USLEEP", i created tearing.sh but it just doesen't work for my. If i have 20-nvidia.conf in my system, i can't start kde (gui), because of error "parse error on line 1 of section InputClass" of 20-nvidia.conf (base file from archwiki). If i put triplebuffer to xorg.conf...no luck at all, but at least kde starts. Enabling vsync in nvidia-settings or kde settings doesen't change a thing.

Offline

#18 2013-12-09 23:06:00

Heema
Member
From: Egypt
Registered: 2008-08-12
Posts: 60

Re: KDE 4.11 vsync issues

awbs wrote:

I noticed I had awful tearing issues today across the whole desktop. (KDE 4.11.5, Nvidia GeForce 675M)  I went to Desktop Effects and changed:
Compositing Type to OpenGL 3.1 (from 2.0).
QT graphics system: Raster.
Scale Method: Accurate
Suspend Desktop effects for fullscreen windows checked
Tearing Prevention: Re-use screen content, although full-screen repaints seems to work just as well.

I don't know if this had any effect but I disabled and reenabled desktop effects with the Alt+F12 keyboard shortcut.

In VLC > Tools > Preferences > Check "All" radiobox.
Go to Videos > Output module. Select "X11 video output (XCB)"
Expand "Output modules", click XVideo, make sure both boxes have a 0 value.

This fixed all tearing issues, including outside of VLC.

Oh, and I also have Hardware Decoding disabled in VLC.

Edit: after rebooting the tearing comes back until I do a ALT+F12 disable/reenable, then is disappears until the next session.

Edit2: Sometimes I have to reselect the same settings in the Advanced tab in Desktop Effects, like changing it from OpenGL 3 to OpenGL 2 to OpenGL3 then click apply. Then disable and reenable desktop effects and it works fine.

I'm glad I found a way to make vsync work but it's aggravating going through hoops to get it enabled every reboot.


THANKS it finally worked   big_smile

that vsync issue was driving me mad as i had every option right.  I changed the kde setting like these my FPS was still 90+ then disabled and renabled desktop effects then it immediatly went down to 60

Now vsync is gone and i can watch vlc without tearing, and also browsing is better now as it was choppy when scrolling


also thanks for this tip

blackout23 wrote:

You can observe this by enableing the "show fps" effect for Kwin and boot your PC.

Last edited by Heema (2013-12-10 10:33:35)

Offline

#19 2014-02-25 09:22:20

Cloudane
Member
Registered: 2009-05-04
Posts: 8

Re: KDE 4.11 vsync issues

Thanks!  This suddenly became in issue with the latest system updates (one of which was newer NVidia drivers) on my system.

Adding

export __GL_YIELD="USLEEP"

to /etc/profile underneath the PATH variable did the trick for me.  (Not another one with "dot dee disease" smile  I didn't bother messing around with .d files but I imagine that's the "proper" way to do it)

Well, it manifested itself for me with some really ugly scrolling in Firefox (there was a sort of "ripple" effect in the middle that was really distracting) and now that is gone, so the issue that I was seeing is fixed.

Offline

#20 2014-02-25 10:35:18

Awebb
Member
Registered: 2010-05-06
Posts: 4,125

Re: KDE 4.11 vsync issues

Also have a look at this: https://bbs.archlinux.org/viewtopic.php?id=175820

EDIT: I meant this link: https://bbs.archlinux.org/viewtopic.php?id=176651

Last edited by Awebb (2014-03-29 10:19:47)

Offline

#21 2014-03-22 16:21:03

bhrgunatha
Member
Registered: 2009-12-16
Posts: 69

Re: KDE 4.11 vsync issues

I had the problem with tearing but only with vlc.
I added both to my profile:

export __GL_YIELD="USLEEP"
export KWIN_TRIPLE_BUFFER=1

Things were good for a while, but with recent updates to the nvidia drivers the problem has come back - and it's worse now than before.
Now scrolling web pages in firefox as well as videos in vlc have a rippling effect in the middle of the screen.

The thread Awebb linked to above seems to indicate its a problem with the xorg-server.
I tried downgrading the xorg-server (along nvidia drivers and the kernel) but then X fails to start.

I've NEVER had issues with tearing until January this year, and now it seems to be a persistent problem which is causing me a lot of frustration.

Any ideas? Or solutions?

Offline

#22 2014-03-29 09:32:11

bhrgunatha
Member
Registered: 2009-12-16
Posts: 69

Re: KDE 4.11 vsync issues

Does anyone have any idea what is causing the tearnig?

Is it KDE? Kwin? Xorg-server? nvidia drivers?
Any way I can track it down?

Is anyone else still suffering? Has everyone's problems cleared up?

This is driving me mad. I'm not able to stop it and I can't find any reliable information about the cause.

Offline

#23 2014-03-29 10:19:22

Awebb
Member
Registered: 2010-05-06
Posts: 4,125

Re: KDE 4.11 vsync issues

Sorry, I have posted the wrong link. It's most likely an SDL problem, which has to be patched at the moment but will be fixed in SDL 2.0
https://bbs.archlinux.org/viewtopic.php?id=176651

Offline

#24 2014-03-29 19:10:35

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,432

Re: KDE 4.11 vsync issues

Mmh, rippling in firefox is likely NOT to be caused by sdl...

Offline

#25 2014-03-31 04:14:11

bhrgunatha
Member
Registered: 2009-12-16
Posts: 69

Re: KDE 4.11 vsync issues

I also thought it was unlikely, but I tried anyway. More out of desperation. Still no luck.

Offline

Board footer

Powered by FluxBB