You are not logged in.

#26 2013-08-10 00:29:29

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: Settings in /etc/sysctl.conf overwritten [SOLVED]

graysky wrote:

Well, the simple test is to just move /etc/tmpfiles.d to /etc/foo which I did.  Following a reboot, nothing changed.

Not sure what you expected to accomplish with this given that you had already hand reviewed the contents of the directory.

Leonid.I wrote:

Good, so it's not your tmpfiles that causes the problem.

Uhh, what? What about /run/tmpfiles.d? What about /usr/lib/tmpfiles.d? He removed /etc from the equation, but that doesn't stop $process or $administrator from putting things elsewhere. Had he masked the tmpfiles setup service I think only then would it be fair to draw this conclusion.

Leonid.I wrote:

Try rebooting (add systemd.unit=rescue.target to your bootloader) into rescue.target and see if the /proc/sys/vm/* settings are correct...

Right.... bisect the bootup, as I mentioned before.

Offline

#27 2013-08-10 00:51:43

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,343
Website

Re: Settings in /etc/sysctl.conf overwritten [SOLVED]

Leonid.I wrote:

Try rebooting (add systemd.unit=rescue.target to your bootloader) into rescue.target and see if the /proc/sys/vm/* settings are correct...

When I boot to the rescue.target sysctl.conf this problem is not present.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#28 2013-08-10 01:32:31

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Settings in /etc/sysctl.conf overwritten [SOLVED]

So I think the idea is to go on to the next step, and the next step, and so on.  Once the problem pops up, you will at least have an idea of what target this is being set at.  So then you can use that info to further dissect that target.

Offline

#29 2013-08-10 08:49:18

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,343
Website

Re: Settings in /etc/sysctl.conf overwritten [SOLVED]

Seems to be something in xfce4... If I disable lxdm, reboot, login into the console and check my settings, they are as defined in /etc/sysctl.conf.  If I `start x` they are overwritten.  This is true for any user even one I just created as a test.

What is _really_ odd is that, I can manually run `sudo sysctl -p` and logout, log back in and the settings are NOT overwritten.  I would think that whatever it is that's changing these settings upon either logging in via lxdm or via the console then via an `xinit`would be consistently doing this, no?

The only things I have run via "autostart" are:
PolicyKit Authentication Agent
Power Manager
PulseAudio Sound System
Screensaver
Xfsettingsd

EDIT: After spinning up a fresh Arch VM, and installing xfce4 on it, the very same behavior is exhibited.  Anyone else reading this thread using xfce4 out there?  Can you reproduce?

1) Add this line for example to /etc/sysctl.conf

vm.dirty_ratio = 3

2) Reboot
3) Start an X session (either by your graphical greeter or `xinit`).
4) Check that the setting has not been overwritten `cat /proc/sys/vm/dirty_ratio` should return 3 not 10.

Last edited by graysky (2013-08-10 09:03:32)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#30 2013-08-10 09:26:39

chp
Member
Registered: 2013-08-09
Posts: 2

Re: Settings in /etc/sysctl.conf overwritten [SOLVED]

Did you see my earlier message about pm-utils? Please check the file /usr/lib/pm-utils/power.d/laptop-mode. This script is probably executed when a xfce session is started.

Last edited by chp (2013-08-10 09:31:32)

Offline

#31 2013-08-10 09:32:23

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,343
Website

Re: Settings in /etc/sysctl.conf overwritten [SOLVED]

chp wrote:

Did you see my earlier message about pm-utils? Check the file /usr/lib/pm-utils/power.d/laptop-mode. This script is probably executed when a xfce session is started.

Dunno how I missed that.  You are right: this is the culprit... and thank you for the suggestion smile

% sudo chmod -x /usr/lib/pm-utils/power.d/laptop-mode

Now upon rebooting, everything is as it should be.

chp wrote:

Do you have pm-utils installed?  It has a laptop-mode script that sets vm.dirty_ratio.  You can disable it by adding an empty file laptop-mode in /etc/pm/power.d/

I don't think users should have to do this empty file solution... since pm-utils is a dep of upower>xfce4-session that means both laptop and non-laptop users alike will be using it.  Bug against pm-utils?  Enabled by default seems to be wrong.

EDIT: https://bugs.archlinux.org/task/28115

This behavior really needs to be changed in our package IMO.

EDIT2: Ahhhhhhhhh.... Looks like we did finally shed this PoS: https://projects.archlinux.org/svntogit … dbea9e5856

Related for reference: https://bugs.archlinux.org/task/31349

Last edited by graysky (2013-08-10 10:21:57)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#32 2013-08-10 19:27:50

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Settings in /etc/sysctl.conf overwritten [SOLVED]

Yeah, I installed xfce4-power-manager recently and was very pleasantly surprised to see that the dependency of pm-utils is now gone from upower!  Really that was one of the primary reasons I refused to use xfce4-power-manager...

Offline

#33 2013-09-19 15:37:14

Perfect Gentleman
Member
Registered: 2012-10-25
Posts: 216

Re: Settings in /etc/sysctl.conf overwritten [SOLVED]

graysky, thanx that helped me too

Offline

#34 2013-09-19 21:49:34

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: Settings in /etc/sysctl.conf overwritten [SOLVED]

Just to note that the update to upower is not yet in the stable repo.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#35 2013-09-20 02:44:34

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: Settings in /etc/sysctl.conf overwritten [SOLVED]

graysky wrote:
chp wrote:

Did you see my earlier message about pm-utils? Check the file /usr/lib/pm-utils/power.d/laptop-mode. This script is probably executed when a xfce session is started.

Dunno how I missed that.  You are right: this is the culprit... and thank you for the suggestion smile

% sudo chmod -x /usr/lib/pm-utils/power.d/laptop-mode

Now upon rebooting, everything is as it should be.

chp wrote:

Do you have pm-utils installed?  It has a laptop-mode script that sets vm.dirty_ratio.  You can disable it by adding an empty file laptop-mode in /etc/pm/power.d/

I don't think users should have to do this empty file solution... since pm-utils is a dep of upower>xfce4-session that means both laptop and non-laptop users alike will be using it.  Bug against pm-utils?  Enabled by default seems to be wrong.

EDIT: https://bugs.archlinux.org/task/28115

This behavior really needs to be changed in our package IMO.

EDIT2: Ahhhhhhhhh.... Looks like we did finally shed this PoS: https://projects.archlinux.org/svntogit … dbea9e5856

Related for reference: https://bugs.archlinux.org/task/31349

Nice, I look forward to finally being able to un-install pm-utils. It amazes me how that totally unmaintained POS is still in every distro hmm

Offline

Board footer

Powered by FluxBB