You are not logged in.

#1 2004-01-31 06:56:05

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,442

how to allow group "nero" to burn rom

Hello, again.

I can't work out how to tweak user rights in arch to allow a group cdrom burning.

Here is what I tried, following common wikis and readmes.

· Created group

$groupadd nero

· Added user 'pink' to group

$gpasswd -a pink nero

· Change group on cdrecord

$chmod -o-x /usr/bin/cdrecord
$chgrp nero /usr/bin/cdrecord
$ls -l /usr/bin/cdrecord
--wS------    1 bin      nero      290364 2003-05-30 19:53 /usr/bin/cdrecord

· Scan for devices

$ whoami
pink
$ cdrecord -scanbus
/usr/bin/cdrecord: no permission 

in fact the result is "Keine Berechtigung",  as I use german environmet, what means "no permission"

OMG. Idea. Logout / Login?
Wait a minute...
No. Nothing works. Run cdrecord as root won't work, therefore I add root to nero. Humh, root has no more permission to run cdrecord. This turns out to be a desaster.
Help, please.
sad


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#2 2004-01-31 07:44:15

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: how to allow group "nero" to burn rom

chggrp /dev/cdroms/cdrom? /dev/sg*

chmod g+w /dev/sg* i have never used this in Arch as i always use superuser or sudo to burn, but i used it with great success in libranet.


AKA uknowme

I am not your friend

Offline

#3 2004-01-31 10:05:11

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: how to allow group "nero" to burn rom

Sarah's at the meat of the problem.  You didn't have group writing set, only owner.

The other option is to add a line similar to mine to your devfsd.conf:

REGISTER ^scsi/host.*/bus.*/target.*/lun.*/cd PERMISSIONS root.cdrom 660


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#4 2004-01-31 11:54:26

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,442

Re: how to allow group "nero" to burn rom

Allmighty devfsd.conf. I am not yet warm with it, but I like it mo' an' mo'.
Thanks AGAIN for helping me out, I hope once I can pay it back.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#5 2004-02-01 10:42:31

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,442

Re: how to allow group "nero" to burn rom

hey, both tweaks will not work, this could'nt be it all.
sad
I would be glad if someone descends to let me know the "arch" way of doing it. Meanwhile, I mix up the whole permissions setting, but won't allow more than necessary.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#6 2004-02-01 12:26:30

andy
Member
From: Germany
Registered: 2002-10-11
Posts: 374

Re: how to allow group "nero" to burn rom

Well maybe Xentac's response wasn't clear (no offense Xentac ;-) ), I think what he meant was to change the group permissions of the file /usr/bin/cdrecord as well. As you showed it, they were definetly wrong. Frankly, I would not have changed anything with /usr/bin/cdrecord at all.

Then changing the permissions on the device entry like Sarah and Xentac described should do it.

What you will have then is the following : the kernel checks if you can execute cdrecord (now : nope - then : yes); the kernel checks if you have permissions to write to the cd-writer device (now : should be yes - then : yes); the kernel lets you proceed.

What you tried first was to elevate you permissions by making you a member of the nero group with the help of the sticky flag of /usr/bin/cdrecord. That is not necessary when you are already a member of the nero group.

Offline

#7 2004-02-14 16:58:37

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,442

Re: how to allow group "nero" to burn rom

:?
I am confused. So you say changing any permissions of /usr/bin/cdrecord is not necessary?
But I can't see the solution. Could one clear my mind?


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#8 2004-02-14 17:27:09

andy
Member
From: Germany
Registered: 2002-10-11
Posts: 374

Re: how to allow group "nero" to burn rom

What I would suggest is to make cdrecord world-readable-executable, and not worry about the ownership of cdrecord - and that's how cdrecord is shipped by default ! Therefore, I suggested to not mess around, since the default is already ok. In your first attempt you seemed to have messed with cdrecord, which you should not.

Don't confuse permissions  with owndership !

What you do need to change is the permissions of your cd-writer DEVICE. You can either make it world-writable, then you still need NOT to worry about OWNERSHIP.

Or you can make it only group writable - then you do need to worry about ownership - specifically group ownership of the DEVICE (not cdrecord !). And you have to be part of that group.

So, I guess my post wasn't clear either :-)

Offline

#9 2004-02-16 00:58:45

drivingmsjuki
Member
From: Massachusetts
Registered: 2003-08-10
Posts: 21

Re: how to allow group "nero" to burn rom

Hmm, here's what mine looks like (and it works just fine with no need to define a cd-writing group):

$ ls -l /usr/bin/cdrecord
-rwsr-sr-x  1 root  users  2904064

/dev/cdroms/cdrom0 is a symlink to:

$ ls -l /dev/scsi/host0/bus0/target0/lun0/cd
brwxrwxrwx  1  root   root    11

In lilo.conf the kernel 2.4 entry has "append=hdc=ide-scsi"

rc.conf loads the modules sg then ide-scsi

Hope this helps  ~
  s

Offline

#10 2004-02-16 02:32:43

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: how to allow group "nero" to burn rom

$ls -l /usr/bin/cdrecord
--wS------    1 bin      nero      290364 2003-05-30 19:53 /usr/bin/cdrecord 

The binary isn't executable, so make sure it has the same permissions as drivingmsjuki's cdrecord has.

Offline

Board footer

Powered by FluxBB