You are not logged in.

#1 2013-01-18 20:30:27

mokasin
Member
Registered: 2009-07-30
Posts: 35

Mouse input lag

My USB mouse and also other USB input devices like my wacom graphics tablet suffer from consistently reoccuring lags, during which they are unresponsive for about half a second.

Somebody an idea, what could cause that?

Offline

#2 2013-01-18 21:58:21

brebs
Member
Registered: 2007-04-03
Posts: 3,413

Re: Mouse input lag

Offline

#3 2013-01-19 12:53:16

mokasin
Member
Registered: 2009-07-30
Posts: 35

Re: Mouse input lag

I fear not:

# for d in /sys/bus/usb/devices/[0-9]* ; do if [[ -e $d/product ]] ; then echo -e "`basename $d`\t`cat $d/power/control`\t`cat $d/speed`\t`cat $d/product`" ; fi ; done
1-1.1	on	1.5	USB-PS/2 Optical Mouse
{...}

Offline

#4 2013-05-09 21:23:29

stimut
Member
Registered: 2011-03-03
Posts: 4

Re: Mouse input lag

I had (have) a similar problem on my laptop. I looked at USB auto-suspend etc, but couldn't really come to a solution.

What I have found though, is that the problem only occurs if I boot with power attached. So a workaround (for me) is to either boot up without power attached, or to just disconnect the power for a few seconds before plugging it in again. After that, I don't have the lag.

Offline

#5 2013-09-23 22:55:59

invsblduck
Member
Registered: 2012-07-12
Posts: 4

Re: Mouse input lag

In my case laptop-mode was configured to enable the autosuspend, so the udev rule wasn't fixing the problem.

I added

AUTOSUSPEND_USBTYPE_BLACKLIST="usbhid"

to

/etc/laptop-mode/conf.d/usb-autosuspend.conf

and now my USB mouse doesn't power save when I unplug the AC adapter.

HTH,
-duck

Offline

Board footer

Powered by FluxBB