You are not logged in.

#1 2013-09-22 14:06:52

aldeano
Member
Registered: 2009-09-04
Posts: 20

USB Ntfs Not detecting

Got an external dd western digital my passport 1 tb usb 3.0 and i can't see the device when i plug it. Using archlinux x64 and kernel 3.11.1, udev, ntfs-3g, udisks2 and udevil installed

Dmesg says

[ 5405.991949] usb 1-2: new high-speed USB device number 7 using xhci_hcd
[ 5406.044083] usb-storage 1-2:1.0: USB Mass Storage device detected
[ 5406.044230] scsi4 : usb-storage 1-2:1.0
[ 5406.044429] usbcore: registered new interface driver usb-storage
[ 5428.549688] usb 1-2: reset high-speed USB device number 7 using xhci_hcd
[ 5428.589722] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e180
[ 5428.589732] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e1c0
[ 5428.752910] usb 1-2: reset high-speed USB device number 7 using xhci_hcd
[ 5428.792906] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e180
[ 5428.792917] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e1c0
[ 5434.952793] usb 1-2: reset high-speed USB device number 7 using xhci_hcd
[ 5434.992796] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e180
[ 5434.992806] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e1c0
[ 5435.152680] usb 1-2: reset high-speed USB device number 7 using xhci_hcd
[ 5435.192674] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e180
[ 5435.192684] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e1c0
[ 5435.355903] usb 1-2: reset high-speed USB device number 7 using xhci_hcd
[ 5435.395872] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e180
[ 5435.395882] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e1c0
[ 5435.396284] scsi 4:0:0:0: Device offlined - not ready after error recovery

Lsusb detects it

Bus 003 Device 003: ID 8087:07dc Intel Corp. 
Bus 003 Device 002: ID 8087:8000 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:5727 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 0eef:a108 D-WAV Scientific Co., Ltd 
Bus 001 Device 007: ID 1058:0740 Western Digital Technologies, Inc. My Passport
Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Fdisk only list my internal ssd drive:

Disk /dev/sda: 128.0 GB, 128035676160 bytes, 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Identificador del disco: 0x0a756ec0

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1               1  4294967295  2147483647+  ee  GPT

Also blkid

/dev/sda1: LABEL="SONYSYS" UUID="4014-89B3" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="bfe6cce6-fdde-4993-b1c9-7dc18d723201" 
/dev/sda2: UUID="8b55ea4d-d81f-489e-b085-9b6328ee6611" TYPE="ext4" PARTUUID="1cfbee95-3b50-4a2b-8a96-ce9f66e28605" 
/dev/sda3: UUID="4594-507F" TYPE="vfat" PARTLABEL="boot" PARTUUID="053728b5-805f-4869-8679-64c5893df9d4" 

Without an assignation letter i can't mount it with fstab.

Got out of ideas.

Offline

#2 2013-09-23 07:39:20

mr.MikyMaus
Member
From: +3600 UT
Registered: 2006-03-31
Posts: 270

Re: USB Ntfs Not detecting

aldeano wrote:
[ 5435.395872] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e180
[ 5435.395882] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801b518e1c0
[ 5435.396284] scsi 4:0:0:0: Device offlined - not ready after error recovery

it's right there: either the drive is buggy or the kernel xhci driver is buggy. I'd suggest running another kernel version (try LTS) and if the problem prevails, try the drive in a different OS (linux and others). If it works elsewhere then there is time to fill a bug report.

-m.


What happened to Arch's KISS? systemd sure is stupid but I must have missed the simple part ...

... and who is general Failure and why is he reading my harddisk?

Offline

#3 2013-09-24 01:32:08

aldeano
Member
Registered: 2009-09-04
Posts: 20

Re: USB Ntfs Not detecting

Mr. MikyMuas

I've installed lts and dmesg says the same when i plug in the external usb dd, exactly the same driver. In win7 it works, so i guess it's time to fill a bug report, the question is here? or in kernel.org?

Offline

#4 2013-09-24 11:23:13

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,282

Re: USB Ntfs Not detecting

Which usb3 controller does your board have (check with lspci)?


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#5 2013-09-24 14:26:06

mr.MikyMaus
Member
From: +3600 UT
Registered: 2006-03-31
Posts: 270

Re: USB Ntfs Not detecting

aldeano wrote:

I've installed lts and dmesg says the same when i plug in the external usb dd, exactly the same driver. In win7 it works, so i guess it's time to fill a bug report, the question is here? or in kernel.org?

perhaps a stupid point bud did you actually boot the lts kernel? Anyway, I would fill an Arch bug first, it may be related to kernel build configuration or it may not even be a kernel problem (udev mixup, etc.)


What happened to Arch's KISS? systemd sure is stupid but I must have missed the simple part ...

... and who is general Failure and why is he reading my harddisk?

Offline

#6 2013-09-25 01:03:19

aldeano
Member
Registered: 2009-09-04
Posts: 20

Re: USB Ntfs Not detecting

R00KIE

Lspci shows this:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Device 0a0c (rev 09)
00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation Lynx Point-LP USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
01:00.0 Network controller: Intel Corporation Wireless 7260 (rev 6b)

mr.MikyMaus

Yes, i've cheked with uname -r and shows 3.10.12-lts.

Offline

#7 2013-09-26 08:48:21

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,282

Re: USB Ntfs Not detecting

The usb3 controller is from intel so it should work. I suppose the lts kernel also doesn't have the uas driver which was causing problems before, but just in case do check with lsmod if uas is loaded (modinfo uas should also return 'modinfo: ERROR: Module uas not found.').

Check your bios for any usb related options and try toggling them, maybe some legacy support option is creating problems, no other ideas here.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#8 2013-09-26 22:49:41

aldeano
Member
Registered: 2009-09-04
Posts: 20

Re: USB Ntfs Not detecting

R00KIE wrote:

The usb3 controller is from intel so it should work. I suppose the lts kernel also doesn't have the uas driver which was causing problems before, but just in case do check with lsmod if uas is loaded (modinfo uas should also return 'modinfo: ERROR: Module uas not found.').

Check your bios for any usb related options and try toggling them, maybe some legacy support option is creating problems, no other ideas here.

Modinfo gave me exactly what you said, no uas module. Also i've tried to play with the few usb options in the bios which are related, but got no luck, i'm using uefi a boot. Anyway now i'm trying with kernel 3.11.1-2 because of wifi driver only available in that kernel.

Offline

#9 2013-09-29 00:33:41

aldeano
Member
Registered: 2009-09-04
Posts: 20

Re: USB Ntfs Not detecting

Offline

Board footer

Powered by FluxBB