You are not logged in.

#1 2013-09-26 02:21:14

vox23
Member
Registered: 2013-09-25
Posts: 9

Does systemctl --user (as per wiki) still works?

I'm following wiki to the letter:

$ .config/systemd/user
.config/systemd/user
├── bspwm.service
├── default.target -> .config/systemd/user/mystuff.target
├── mystuff.target
├── wm.target
└── wm.target.wants
    └── bspwm.service -> /home/me/.config/systemd/user/bspwm.service
$ cat /etc/systemd/system/getty@tty1.service.d/autologin.conf
[Service]
ExecStart=
ExecStart=-/usr/bin/agetty --autologin boojum --noclear %I 38400 linux
$ cat /etc/systemd/system/user@.service.d/environment.conf
[Service]
Environment=DISPLAY=:0
Environment=XDG_RUNTIME_DIR=/run/user/%I
Environment=SHELL=%s
$ yaourt -S systemd-xorg-launch-helper-git
$ cat .config/systemd/user/wm.target
[Unit]
Description=Window manager target
Wants=xorg.target
Wants=mystuff.target
Requires=dbus.socket
AllowIsolate=true

[Install]
Alias=default.target
$ cat .config/systemd/user/mystuff.target
[Unit]
Description=Xinitrc Stuff
Wants=wm.target

[Install]
Alias=default.target
ln -sf .config/systemd/user/mystuff.target .config/systemd/user/default.target
$ cat .config/systemd/user/bspwm.service
[Unit]
Description=bspwm
Before=mystuff.target
After=xorg.target
Requires=xorg.target

[Service]
#Environment=PATH=uncomment:to:override:your:PATH
ExecStart=/usr/bin/bspwm
Restart=always
RestartSec=10

[Install]
WantedBy=wm.target
$ systemctl --user enable bspwm.service
ln -s '/home/me/.config/systemd/user/bspwm.service' '/home/me/.config/systemd/user/wm.target.wants/bspwm.service'

Reboot and nothing happens:

$ systemctl --user status bspwm.service
bspwm.service - bspwm
   Loaded: loaded (/home/me/.config/systemd/user/bspwm.service; enabled)
   Active: inactive (dead)

So my question is - are those instructions in the wiki still relevant? What I'm doing wrong? And for the completness sake:

$ tree -l /etc/systemd/system
/etc/systemd/system
├── default.target -> /usr/lib/systemd/system/graphical.target
├── getty.target.wants
│   └── getty@tty1.service -> /usr/lib/systemd/system/getty@.service
├── getty@tty1.service.d
│   └── autologin.conf
├── multi-user.target.wants
│   ├── netctl-auto@wlan0.service -> /usr/lib/systemd/system/netctl-auto@.service
│   ├── ntpd.service -> /usr/lib/systemd/system/ntpd.service
│   └── remote-fs.target -> /usr/lib/systemd/system/remote-fs.target
└── user@.service.d
    └── environment.conf
$ tree -l /etc/systemd/user
/etc/systemd/user
└── xorg.service

Help?

Offline

#2 2013-09-26 02:40:44

HalosGhost
Member
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,486
Website

Re: Does systemctl --user (as per wiki) still works?

I'm actually unsure of the status of systemd --user. My old --user setup works famously even after the 207 update. However, in trying to setup a new install to use systemd --user, I've been having some serious trouble. I'm still troubleshooting it, but I'm in a similar place as you. I actually have X starting up a user session when I login, but I have yet to get my window manager to correctly load. I shall let you know when I get it working.

Having said all the above, this may do well to just be merged with the current "systemd --user & systemd 207" thread.

All the best,

-HG


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Online

#3 2013-09-26 07:51:49

msthev
Member
Registered: 2012-04-05
Posts: 177

Re: Does systemctl --user (as per wiki) still works?

vox23 wrote:

I'm following wiki to the letter:

Not exactly:

ln -sf .config/systemd/user/mystuff.target .config/systemd/user/default.target

This will create a symlink in $HOME/.config/systemd/user/default.target (absolute path) pointing to .config/systemd/user/mystuff.target (relative path).
Fix:

ln -sf mystuff.target "$HOME/.config/systemd/user/default.target"

If you want absolute path, you can use systemctl --user enable mystuff.target (or add "$HOME/" to the first argument of your command).

Last edited by msthev (2013-09-26 07:53:14)

Offline

#4 2013-09-26 21:51:50

vox23
Member
Registered: 2013-09-25
Posts: 9

Re: Does systemctl --user (as per wiki) still works?

msthev wrote:

Fix:

ln -sf mystuff.target "$HOME/.config/systemd/user/default.target"

If you want absolute path, you can use systemctl --user enable mystuff.target (or add "$HOME/" to the first argument of your command).

I stand corrected, however bspwm is not starting even after systemctl --user enable.

HalosGhost wrote:

Having said all the above, this may do well to just be merged with the current "systemd --user & systemd 207" thread.

Thanks! I'll give it a carefule read tomorrow, Hopefully we can figure it out.

Offline

Board footer

Powered by FluxBB