You are not logged in.

#1 2013-09-28 20:59:07

Doctor Drive
Member
From: Ukraine
Registered: 2010-08-11
Posts: 167
Website

[Solvd]hd0,gpt1error: file /EFI/Microsoft/Boot/bootmgfw.efi' not found

I'm trying to configure GRUB2 to load Windows 8 on UEFI system.
os-prober does not detect it.
grub-mkconfig creates only for Linux (tried both with mounted and unmounted Windows partition).

So I went for manual entry.
I executed the following

$ mount /dev/sde1 /boot/efi/
$ grub-probe --target=fs_uuid /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
69DB-D2EB
# grub-probe --target=hints_string /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
--hint-bios=hd4,gpt1 --hint-efi=hd4,gpt1 --hint-baremetal=ahci4,gpt1

Created menuentry for /boot/grub/grub.cfg

menuentry "Microsoft Windows 8" {
    insmod part_gpt
    insmod fat
    insmod search_fs_uuid
    insmod chain
    search --fs-uuid --hint-bios=hd4,gpt1 --hint-efi=hd4,gpt1 --hint-baremetal=ahci4,gpt1 69DB-D2EB
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}

And when I choose it it says

hd0,gpt1error: file /EFI/Microsoft/Boot/bootmgfw.efi' not found

Note that EFI partition is not mounted is fstab (does it make a difference for GRUB?).
Also, specifying

chainloader /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi

Gives the same not found.
P.S. Windows "fast start" is disabled

Last edited by Doctor Drive (2013-09-29 09:57:25)

Offline

#2 2013-09-28 21:23:49

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,663

Re: [Solvd]hd0,gpt1error: file /EFI/Microsoft/Boot/bootmgfw.efi' not found

I don't use Windows but I would try setting the root explicitly in the entry since it is apparently looking in the wrong place.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#3 2013-09-29 09:35:47

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [Solvd]hd0,gpt1error: file /EFI/Microsoft/Boot/bootmgfw.efi' not found

Doctor Drive wrote:
menuentry "Microsoft Windows 8" {
    insmod part_gpt
    insmod fat
    insmod search_fs_uuid
    insmod chain
    search --fs-uuid --hint-bios=hd4,gpt1 --hint-efi=hd4,gpt1 --hint-baremetal=ahci4,gpt1 69DB-D2EB
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}

You need to explicitely mention "--set=root" in the search line for this to work. This is not assumed by GRUB.

search --fs-uuid --set=root --hint-bios=hd4,gpt1 --hint-efi=hd4,gpt1 --hint-baremetal=ahci4,gpt1 69DB-D2EB

Offline

#4 2013-09-29 09:56:45

Doctor Drive
Member
From: Ukraine
Registered: 2010-08-11
Posts: 167
Website

Re: [Solvd]hd0,gpt1error: file /EFI/Microsoft/Boot/bootmgfw.efi' not found

Thank you, the.ridikulus.rat.
I just booted back from windows to tell the same.
I just found the solution here

http://unix.stackexchange.com/questions … th-windows

I was configuring according to the ArchWiki.
The ArchWiki was missing that point.
https://wiki.archlinux.org/index.php/GR … I-GPT_Mode

it said

menuentry "Microsoft Windows Vista/7/8 x86_64 UEFI-GPT" {
   insmod part_gpt
   insmod fat
   insmod search_fs_uuid
   insmod chain
   search --fs-uuid $hints_string $uuid
   chainloader /EFI/Microsoft/Boot/bootmgfw.efi
 }

Just edited the wiki. Thanks!

Offline

#5 2013-09-29 09:59:24

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [Solvd]hd0,gpt1error: file /EFI/Microsoft/Boot/bootmgfw.efi' not found

Doctor Drive wrote:

Thank you, the.ridikulus.rat.
I just booted back from windows to tell the same.
I just found the solution here

http://unix.stackexchange.com/questions … th-windows

I was configuring according to the ArchWiki.
The ArchWiki was missing that point.
https://wiki.archlinux.org/index.php/GR … I-GPT_Mode

it said

menuentry "Microsoft Windows Vista/7/8 x86_64 UEFI-GPT" {
   insmod part_gpt
   insmod fat
   insmod search_fs_uuid
   insmod chain
   search --fs-uuid $hints_string $uuid
   chainloader /EFI/Microsoft/Boot/bootmgfw.efi
 }

Just edited the wiki. Thanks!

I initially wrote that section of the wiki (with "--set=root" included), but someone had changed it recently ( https://wiki.archlinux.org/index.php?ti … did=276742 ).

Last edited by the.ridikulus.rat (2013-09-29 10:02:48)

Offline

Board footer

Powered by FluxBB