You are not logged in.

#1 2013-09-23 22:47:24

Registered: 2013-01-07
Posts: 348

[SOLVED]problems with git aur packages

So i'm trying to install mupdf, but am having trouble cloning the git-repo. When I type makepkg, this is what I get

==> Making package: mupdf-git 1.3.14.gdf42421-1 (Mon Sep 23 16:21:24 MDT 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Cloning mupdf git repo...
Cloning into bare repository '/home/christian/.aur/mupdf-git/mupdf'...

And then it just waits forever. I've also tried the powedown-git package and I get the same thing. I noticed that there is a source url in the PKGBUILD's that start with git://<url>. I thought that this was normal, but just in case I changed it to start with https://. Now the clone succeeds, but the build fails with something like this:

==> Starting pkgver()...
/home/christian/.aur/powerdown-git/PKGBUILD: line 20: cd: /home/christian/.aur/powerdown-git/src/powerdown: No such file or directory
==> Entering fakeroot environment...
==> Starting package()...
/home/christian/.aur/powerdown-git/PKGBUILD: line 25: cd: /home/christian/.aur/powerdown-git/src/powerdown: No such file or directory
==> ERROR: A failure occurred in package().

After that makepkg fails I'm left with the following files

[christian@archbox] 4:45 PM ~/.aur/mupdf-git % ls -R
mupdf.git  mupdf-git.install  PKGBUILD  src


where mupdf.git is just an html file. Anyone have any ideas?

Last edited by cris9288 (2013-10-02 01:20:34)


#2 2013-09-23 22:54:11

From: .nz
Registered: 2009-05-09
Posts: 25,071

Re: [SOLVED]problems with git aur packages

Builds fine here. Are you using an AUR helper?

Moving to AUR Issues...

Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438


#3 2013-09-23 23:31:38

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 7,980

Re: [SOLVED]problems with git aur packages

What does the mupdf.git html file say? Is it a "helpful" message from your ISP?

Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.


#4 2013-09-24 02:41:06

Registered: 2013-01-07
Posts: 348

Re: [SOLVED]problems with git aur packages

Sorry for the late reply guys. I was at school when I was trying to build these packages. I didn't really think about the possibility of the git:// port being blocked by the school, but I think that must've been it because I came home and built mupdf and powerdown without a problem.


#5 2013-09-30 23:39:33

Trusted User (TU)
From: Long Island NY
Registered: 2007-07-05
Posts: 1,358

Re: [SOLVED]problems with git aur packages

Remember to mark this as solved!

6EA3 F3F3 B908 2632 A9CB E931 D53A 0445 B47A 0DAB
Great things come in tar.xz packages.


Board footer

Powered by FluxBB