You are not logged in.

#1 2013-10-01 06:56:11

gaelic
Member
Registered: 2010-08-01
Posts: 64

Gnome3 Locales

I've got a problem how Gnome3 behaves when setting the locales:

1) it ignores the settings made in /etc/locale.conf
2) In the 'Region & Language' settings there are two settings:

- language
- formats

I thought thats perfect: I wan't English as language and Austrian Formats (Metric/A4). But what happens: the date is now displayed in German ... why?

Any thoughts on that behavior?

Offline

#2 2013-10-01 07:11:36

ijanos
Member
From: Budapest, Hungary
Registered: 2008-03-30
Posts: 440

Re: Gnome3 Locales

Because the format of the date string (and the name of the days) is part of the date local.

Offline

#3 2013-10-01 07:19:00

gaelic
Member
Registered: 2010-08-01
Posts: 64

Re: Gnome3 Locales

Thx. You confirm what I suspected.

Anyways? Is there a solution to this? For example in KDE4 it is not a problem to have an English output.

Offline

#4 2013-10-01 07:30:43

ijanos
Member
From: Budapest, Hungary
Registered: 2008-03-30
Posts: 440

Re: Gnome3 Locales

Well, you can always use the UK locales, they use metric and the dates are in english.

Other option would be manually override LC_TIME enviroment variable, but that is a hack and I don't know how Gnome will try to switch it back.

Offline

#5 2013-10-01 07:57:26

jrussell
Member
From: Cape Town, South Africa
Registered: 2012-08-16
Posts: 510

Re: Gnome3 Locales

Im not sure of the exact problem here, but Ill just share that I had an issue where my locales where a bit wonky, and /etc/locale.conf was being ignored by gnome/gdm only, turned out AccountService was changing my locales.

Here is my original thread and solution https://bbs.archlinux.org/viewtopic.php … 8#p1292808


bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U

Offline

Board footer

Powered by FluxBB