You are not logged in.

#1 2006-01-04 06:48:17

tdphys
Member
From: Lower Mainland
Registered: 2005-06-14
Posts: 42

new kernel updates help!!

I'm stuck back at the 2.6.13  kernels because the newer ones don't work.  I've got the intrd stuff in my bootloader,  but when I boot up, the hwd daemon runs way too fast, and the only modules I can see from modprobe  is the nvidia one sitting in the old 2.6.13 modules directory.

lsmod doesn't list anything either. 

Any ideas?

Thanks

Offline

#2 2006-01-04 07:28:19

dojo
Member
Registered: 2005-11-02
Posts: 96

Re: new kernel updates help!!

Hi,

i followed the howto in the wiki [1] and i run kernel.2.6.14 without any problems.

Maybe there is something wrong in you /etc/rc.conf.  With
MOD_AUTOLOAD="yes" hwd will modprobe your modules, except the modules listed in MOD_BLACKLIST.
For modules you specified in MODULE modprobe will always be executed whatever MODULES_AUTOLOAD is set to.

I set MODULES_AUTOLOAD="no", put all needed module in the MODULES-array and removed hwd from the DAEMONS-array. And it works great. Before i did this modifications the kernel 2.6.14 worked fine too and all modules were loaded automatically.

Greets

Sunnemer

[1] http://wiki.archlinux.org/index.php/Initrd

edit: corrected MOD_AUTOLOAD

Offline

#3 2006-01-04 07:54:51

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: new kernel updates help!!

MOD_AUTOLOAD="yes" in rc.conf
solves your problem

Offline

#4 2006-01-04 23:29:45

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: new kernel updates help!!

tdphys wrote:

the hwd daemon runs way too fast

Just a note: hwd is NOT the same as hwdetect.  Everyone seems to confuse this and I have no idea why.  hwd is a daemon in the DAEMONs array in rc.conf, whereas hwdetect is controlled by MOD_AUTOLOAD - they are two different tools.  If you are using MOD_AUTOLOAD, you are using hwdetect not hwd.

tdphys wrote:

the only modules I can see from modprobe  is the nvidia one sitting in the old 2.6.13 modules directory.

If your kernel is booting and still loading modules from 2.6.13, then the upgrade did not work.  Odds are your boot partition is not auto-mounted (it has the 'noauto' option in /etc/fstab) and pacman installed the kernel to the /boot folder on you root partition instead of the /boot partition.

Either that, or you didn't rerun lilo.

When you boot, check:
a) If /boot has 'noauto' in /etc/fstab
b) The output of 'uname -r'

Offline

#5 2006-01-05 16:05:44

tdphys
Member
From: Lower Mainland
Registered: 2005-06-14
Posts: 42

Re: new kernel updates help!!

Actually,  Phrakture had it right, thanks Phrakture.   I wasn't mounting the boot partition. 

After some hassle, my initrd works okay, but now my root partition gets mounted read only, and nothing can write to /var or /tmp  which really screws up alot of the boot options.  I know this is probably a stupid error, but I can't find really where the problem would be,  my fstab line for the drive is the same as before:

/dev/hda7              /home ext3 defaults 0 1
/dev/hda1              /media ext3 defaults 0 1
/dev/hda2              /reiserfs defaults 0 1
/dev/hda6               /boot ext3 defaults 0 1
/dev/hda5               swap swap defaults 0 1

And  my kernel options in menu.lst

title  Arch Linux  [/boot/vmlinuz]
root   (hd0,5)
kernel /vmlinuz26 root=/dev/hda2 ro 
initrd /initrd26.img

Offline

#6 2006-01-05 16:22:12

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: new kernel updates help!!

yuo have no space between /reiserfs change it to / reiserfs

Offline

#7 2006-01-05 17:02:56

tdphys
Member
From: Lower Mainland
Registered: 2005-06-14
Posts: 42

Re: new kernel updates help!!

Ahemm... yes,  thankyou  :oops:

Offline

#8 2006-01-05 17:20:27

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: new kernel updates help!!

you should change your pass to 1 for / and 2 for everything else otherwise the filesystems are checked in order according to fstab.  / should always be checked first.

Offline

Board footer

Powered by FluxBB