You are not logged in.

#1 2013-09-13 18:40:00

Thermi
Member
Registered: 2013-05-11
Posts: 5

lightdm ignores /etc/lightdm/users.conf

Hello,

After upgrading the lightdm package to the newest version, lightm blatantly ignores the settings in /etc/lightdm/users.conf and shows me useless users like "folding", "git", "lightdm account service" and others besides actual users.
The settings int users.conf worked before, so what changed? How can I fix this? I tried to look for a solution, but neither the wiki, nor the rest of the  internet seem to know anything about this.
I don't have "accountservice" installed.
lightdm package version is  1:1.6.1-4
I also have liblightdm-qt4-devel and liblight-qt5-devel with version 1.7.15-1 installed (both).
I use lightdm-webkit-greeter 0.1.2-6 as greeter.

Offline

#2 2013-09-18 01:56:13

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: lightdm ignores /etc/lightdm/users.conf

Can you post the users.conf and lightdm.conf you're using?
Did you deal with all the pacnew files after the update?

Last edited by karol (2013-09-18 01:58:07)

Offline

#3 2013-09-18 02:05:03

Thermi
Member
Registered: 2013-05-11
Posts: 5

Re: lightdm ignores /etc/lightdm/users.conf

I dealth with lightdm.conf.pacnew by showing myself a diff and taking a look at the differences. I changed some stuff like the xsession-wrapper script parameter inside my customized lightdm.conf to work with the new name (what is now called "Xsession" was called "xsession" before, but nothing more. I use the default users.conf.

users.conf
#
# User accounts configuration
#
# NOTE: If you have AccountsService installed on your system, then LightDM will
# use this instead and these settings will be ignored
#
# minimum-uid = Minimum UID required to be shown in greeter
# hidden-users = Users that are not shown to the user
# hidden-shells = Shells that indicate a user cannot login
#
[UserAccounts]
minimum-uid=1000
hidden-users=nobody nobody4 noaccess
hidden-shells=/bin/false /sbin/nologin

lightdm.conf:
#
# General configuration
#
# start-default-seat = True to always start one seat if none are defined in the configuration
# greeter-user = User to run greeter as
# minimum-display-number = Minimum display number to use for X servers
# minimum-vt = First VT to run displays on
# lock-memory = True to prevent memory from being paged to disk
# user-authority-in-system-dir = True if session authority should be in the system location
# guest-account-script = Script to be run to setup guest account
# log-directory = Directory to log information to
# run-directory = Directory to put running state in
# cache-directory = Directory to cache to
# xsessions-directory = Directory to find X sessions
# remote-sessions-directory = Directory to find remote sessions
# xgreeters-directory = Directory to find X greeters
#
[LightDM]
# was true
start-default-seat=false
greeter-user=lightdm
#minimum-display-number=0
minimum-vt=7
#lock-memory=true
#user-authority-in-system-dir=false
#guest-account-script=guest-account
#log-directory=/var/log/lightdm
run-directory=/run/lightdm
#cache-directory=/var/cache/lightdm
#xsessions-directory=/usr/share/xsessions
#remote-sessions-directory=/usr/share/lightdm/remote-sessions
#xgreeters-directory=/usr/share/lightdm/greeters:/usr/share/xgreeters

[Seat:0]
type=xlocal
xserver-allow-tcp=false
greeter-hide-users=false
greeter-show-manual-login=false
greeter-show-remote-login=false
greeter-session=lightdm-webkit-greeter
pam-service=lightdm-autologin
# was xsession
session-wrapper=/etc/lightdm/Xsession
user-session=xfce
#
# Seat defaults
# [here lots of seat defaults]
[SeatDefaults]
session-wrapper=/etc/lightdm/Xsession
pam-service=lightdm-autologin

The rest of the file consists of just commented parameters, that are in their default state.

Offline

#4 2013-09-18 02:09:52

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: lightdm ignores /etc/lightdm/users.conf

I know nothing about lightdm, but what would happen if you added e.g. 'folding' to 'hidden-users' line?


When pasting configs, code or command output, please use [ code ] tags https://bbs.archlinux.org/help.php#bbcode

like this

It makes the code more readable and - in case of longer listings - more convenient to scroll through.

Offline

#5 2013-09-18 02:16:34

Thermi
Member
Registered: 2013-05-11
Posts: 5

Re: lightdm ignores /etc/lightdm/users.conf

I don't think this is the solution. The problem is, that although "minimum-uid=1000" is set, all the other accounts with a valid shell are shown in the menu, although their UID is below 1000 or their shell is set to one of "hidden-shells".
E.g.: git is shown although: git:x:619:619:git daemon user:/:/bin/bash -> UID 619 < 1000
folding:x:1001:1001::/home/folding:/sbin/nologin -> /sbin/nologin is set in "hidden-shells"

Offline

#6 2013-09-21 07:17:41

dvw10984
Member
Registered: 2013-02-16
Posts: 23

Re: lightdm ignores /etc/lightdm/users.conf

same problem here, /etc/lightdm/users.conf is ignored

$ cat /etc/lightdm/users.conf
#
# User accounts configuration
#
# NOTE: If you have AccountsService installed on your system, then LightDM will
# use this instead and these settings will be ignored
#
# minimum-uid = Minimum UID required to be shown in greeter
# hidden-users = Users that are not shown to the user
# hidden-shells = Shells that indicate a user cannot login
#
[UserAccounts]
minimum-uid=1000
hidden-users=nobody nobody4 noaccess
hidden-shells=/bin/false /sbin/nologin

Offline

#7 2013-10-01 17:39:42

Götz
Member
Registered: 2009-02-16
Posts: 23

Re: lightdm ignores /etc/lightdm/users.conf

I have the same problem, but installing accountsservice makes those users with UID < 1000 not appear on the LightDM login screen.


What I hear, I forget. What I say, I remember. What I do, I understand.  –Tao Te Ching/Laozi

Offline

Board footer

Powered by FluxBB