You are not logged in.

#1 2005-12-22 00:15:55

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

[arch64] mkinitrd fails with kernel 2.6.15

based on the current 2.6.14.4-2 pkgbuild from arch32 I use this pkgbuild:

# $Id: PKGBUILD,v 1.60 2005/10/09 18:20:12 tpowa Exp $
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=kernel26
basekernel=2.6.15
pkgver=2.6.15
_rcver=rc6
_gitver=git2
pkgrel=4
pkgdesc="The Linux Kernel and modules (IDE support)"
url="http://www.kernel.org"
backup=('boot/kconfig26')
depends=('module-init-tools')
makedepends=('mkinitrd>=1.01-21')
depends=('module-init-tools' 'mkinitrd>=1.01-21')
# ieee80211 and hostap-driver26 modules are included in kernel26 now
replaces=('kernel26-scsi' 'ieee80211' 'hostap-driver26')
install=kernel26.install
source=(#ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$basekernel.tar.bz2 
  #http://www.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2 
  http://www.kernel.org/pub/linux/kernel/v2.6/testing/linux-$pkgver-$_rcver.tar.bz2 
  http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-$pkgver-$_rcver-$_gitver.bz2 
  config 
  logo_linux_clut224.ppm 
  #acpi-dsdt-initrd-v0.7d-2.6.12.patch 
  #http://ck.kolivas.org/patches/2.6/2.6.11/2.6.11-ck1/patches/nvidia_6111-6629_compat2.diff
)
md5sums=('')

build() {
  cd $startdir/src/linux-$basekernel-$_rcver
  patch -Np1 -i ../patch-$pkgver-$_rcver-$_gitver || return 1
  #patch -Np1 -i ../nvidia_6111-6629_compat2.diff || return 1
  #patch -Np1 -i ../acpi-dsdt-initrd-v0.7d-2.6.12.patch || return 1
  # remove the extraversion from Makefile
  sed -i 's|^EXTRAVERSION = .*$|EXTRAVERSION =|g' Makefile  
  # Arch logo!
  cp ../logo_linux_clut224.ppm drivers/video/logo/
  # get rid of the 'i' in i686
  carch=`echo $CARCH | sed 's|i||'`
  cat ../config | sed "s|#CARCH#|$carch|g" >./.config
  # build the full kernel version to use in pathnames
  . ./.config
  _kernver="${basekernel}${CONFIG_LOCALVERSION}"
  # load configuration
  yes "" | make config
  # build!
  make bzImage modules || return 1
  mkdir -p $startdir/pkg/{lib/modules,boot}
  make INSTALL_MOD_PATH=$startdir/pkg modules_install || return 1
  cp System.map $startdir/pkg/boot/System.map26
  cp arch/x86_64/boot/bzImage $startdir/pkg/boot/vmlinuz26
  install -D -m644 Makefile 
    $startdir/pkg/usr/src/linux-${_kernver}/Makefile
  install -D -m644 kernel/Makefile 
    $startdir/pkg/usr/src/linux-${_kernver}/kernel/Makefile
  install -D -m644 .config 
    $startdir/pkg/usr/src/linux-${_kernver}/.config
  install -D -m644 .config $startdir/pkg/boot/kconfig26
  mkdir -p $startdir/pkg/usr/src/linux-${_kernver}/include
  mkdir -p $startdir/pkg/usr/src/linux-${_kernver}/arch/x86_64/kernel
  for i in acpi asm-generic asm-i386 config linux math-emu media net pcmcia scsi sound video; do
    cp -a include/$i $startdir/pkg/usr/src/linux-${_kernver}/include/
  done
  # copy files necessary for later builds, like nvidia and vmware
  cp Module.symvers $startdir/pkg/usr/src/linux-${_kernver}
  cp -a scripts $startdir/pkg/usr/src/linux-${_kernver}
  mkdir -p $startdir/pkg/usr/src/linux-${_kernver}/.tmp_versions
  cp arch/x86_64/Makefile $startdir/pkg/usr/src/linux-${_kernver}/arch/x86_64/
  cp arch/x86_64/kernel/asm-offsets.s 
    $startdir/pkg/usr/src/linux-${_kernver}/arch/x86_64/kernel/
  # add headers for lirc package
  mkdir -p $startdir/pkg/usr/src/linux-${_kernver}/drivers/media/video
  cp drivers/media/video/*.h  $startdir/pkg/usr/src/linux-${_kernver}/drivers/media/video/
  # add inotify.h
  mkdir -p $startdir/pkg/usr/src/linux-${_kernver}/include/linux
  cp include/linux/inotify.h $startdir/pkg/usr/src/linux-${_kernver}/include/linux/
  # copy in Kconfig files
  for i in `find . -name "Kconfig*"`; do 
    mkdir -p $startdir/pkg/usr/src/linux-${_kernver}/`echo $i | sed 's|/Kconfig.*||'`
    cp $i $startdir/pkg/usr/src/linux-${_kernver}/$i
  done
  cd $startdir/pkg/usr/src/linux-${_kernver}/include && ln -s asm-x86_64 asm
  chown -R root.root $startdir/pkg/usr/src/linux-${_kernver}
  cd $startdir/pkg/lib/modules/${_kernver} && 
    (rm -f source build; ln -sf ../../../usr/src/linux-${_kernver} build)
  # Now generate a fallback init ramdisk
  # NOTE: This backup ramdisk will not work for cryptsetup/raid users, since
  #       we don't have their unique configuration at build-time!
  touch $startdir/pkg/boot/initrd26-full.img
  /sbin/mkinitrd --skip-config --root-dir=$startdir/pkg full || return 1
}

The last part seems to be broken:

  INSTALL sound/usb/snd-usb-lib.ko
  INSTALL sound/usb/usx2y/snd-usb-usx2y.ko
if [ -r System.map -a -x /sbin/depmod ]; then /sbin/depmod -ae -F System.map -b /var/abs/local/kernel/kernel26rc_64/pkg -r 2.6.15-ARCH; fi
WARNING: /var/abs/local/kernel/kernel26rc_64/pkg/lib/modules/2.6.15-ARCH/kernel/drivers/isdn/hysdn/hysdn.ko needs unknown symbol cli
WARNING: /var/abs/local/kernel/kernel26rc_64/pkg/lib/modules/2.6.15-ARCH/kernel/drivers/isdn/hysdn/hysdn.ko needs unknown symbol restore_flags
WARNING: /var/abs/local/kernel/kernel26rc_64/pkg/lib/modules/2.6.15-ARCH/kernel/drivers/isdn/hysdn/hysdn.ko needs unknown symbol save_flags
WARNING: /var/abs/local/kernel/kernel26rc_64/pkg/lib/modules/2.6.15-ARCH/kernel/drivers/isdn/hysdn/hysdn.ko needs unknown symbol sti
Checking Input...
    Building full initrd for Arch standard kernel
      (includes all possible modules)
Setting up Parameters...
    /var/abs/local/kernel/kernel26rc_64/pkg/lib/modules/2.6.15-ARCH found
ERROR: All of your loopback devices are in use!
==> ERROR: Build Failed.  Aborting...
[andyrtr@workstation64 kernel26rc_64]$

Expect from that building the initrd26full.img it works when I comment it out.

Ideas how to fix it?

Offline

#2 2005-12-24 08:56:26

notz
Member
From: Graz, Austria
Registered: 2005-04-05
Posts: 22

Re: [arch64] mkinitrd fails with kernel 2.6.15

make sure that you have a /dev/zero device.

if not create one with:

mknod dev/zero c 1 5

that workde for me.


arch64 user - www.arch64.org

Offline

#3 2005-12-25 10:15:56

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

Re: [arch64] mkinitrd fails with kernel 2.6.15

/dev/zero exists  :?

[root@workstation64 andyrtr]# ls -l /dev/zero
crw-rw-rw-  1 root root 1, 5 2005-12-25 10:47 /dev/zero

Offline

#4 2006-01-02 19:45:51

ovihc
Member
Registered: 2004-06-16
Posts: 62

Re: [arch64] mkinitrd fails with kernel 2.6.15

i'm trying to install a custom kernel taken from the stock Arch kernel (copied files from abs) and i added the patches for suspend2 and fbsplash, while disabling SMP since my wireless card driver doesn't work with SMP.

I get the exact same error:

Checking Input...
    Building full initrd for Arch standard kernel
      (includes all possible modules)
Setting up Parameters...
    /home/ovihc/kernel26-wifi/pkg/lib/modules/2.6.14-ARCH found
ERROR: All of your loopback devices are in use!
==> ERROR: Build Failed.  Aborting...

I've already tried compiling the kernel about 7 times but i get the same error.

Offline

#5 2006-01-02 20:20:18

poetofnumbers
Member
From: Kansas, United States
Registered: 2004-10-30
Posts: 106
Website

Re: [arch64] mkinitrd fails with kernel 2.6.15

The kernel in Arch64/testing build just fine for me.  With mkinitrd, my system runs with no troubles.


Sweet, now I can play with myself.

Offline

#6 2006-01-02 20:48:13

ovihc
Member
Registered: 2004-06-16
Posts: 62

Re: [arch64] mkinitrd fails with kernel 2.6.15

i forgot to mention that this is not for the 64bit kernel. i'm using a 32bit kernel for my 32bit cpu. however, i got the same error as the guy who first made this post, so i wanted to know if there was a solution that could help me.

Offline

#7 2006-01-03 03:20:46

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: [arch64] mkinitrd fails with kernel 2.6.15

I commented this section out on the bottom and it built fine

  touch $startdir/pkg/boot/initrd26-full.img
  /sbin/mkinitrd --skip-config --root-dir=$startdir/pkg full || return 1

it looks like its for full backup initrd although the .install file creates one too.
I don't use the full image so it worked fine for me...

Offline

#8 2006-01-06 01:29:04

Jacob
Member
Registered: 2005-03-19
Posts: 52

Re: [arch64] mkinitrd fails with kernel 2.6.15

I got the "ERROR: All of your loopback devices are in use!" message too when going from 2.6.14.5 to 2.6.15-2. 

My problem seemed to stem from the way I upgraded.  I first removed my kernel26 (pacman -r kernel26), then added my selfmade kernel26 (pacman -A kernel26-2.6.15-2.pkg.tar.gz)...

The way I fixed it was, I removed the new kernel, and re-added the old kernel, then it was able to make an initrd.  Then I did an upgrade with: pacman -U kernel26-2.6.15-2.pkg.tar.gz  And it was able to create the initrd file without letting me know I've run out of loopbacks.

I don't know in the future if I will be so lucky.

Jacob

Offline

#9 2006-01-06 08:39:51

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

Re: [arch64] mkinitrd fails with kernel 2.6.15

The feature that the kernel pkgbuild creates a second full initrd has been removed in official pkgbuilds. So mkinitrd will do it alone now.

Offline

Board footer

Powered by FluxBB