You are not logged in.

#1 2013-10-09 16:40:44

SilverWyrda
Member
Registered: 2013-10-09
Posts: 6

systemd & systemd-sysvinit : 207-5 > 208-1 | unable to hibernate

Hi !

After the update of systemd and systemd-sysvinit from v. 207-5 to v. 208-1, I'm experiencing an issue with xfce4-power-manager which cannot detect the ability of the computer to hibernate and so it desactivates the option (despite pm-hibernate works very well).

The only solution I've found is to downgrade these two packages, and everything runs smooth.

Is somebody experiencing the same issue and is there an obvious workaround I missed ?

SilverWyrda

Offline

#2 2013-10-09 19:45:20

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 918

Re: systemd & systemd-sysvinit : 207-5 > 208-1 | unable to hibernate

I use xfce and not have this problem, but I use lightdm

maybe, you miss a option in .xinitirc


Well, I suppose that this is somekind of signature, no?

Offline

#3 2013-10-09 20:11:34

SilverWyrda
Member
Registered: 2013-10-09
Posts: 6

Re: systemd & systemd-sysvinit : 207-5 > 208-1 | unable to hibernate

I also use lightdm. I keep searching for a workaround. Thanks for your answer smile.

Offline

#4 2013-10-11 11:08:25

venam
Member
From: Lebanon
Registered: 2012-05-23
Posts: 14
Website

Re: systemd & systemd-sysvinit : 207-5 > 208-1 | unable to hibernate

Seems like the same problem as in this thread: https://bbs.archlinux.org/viewtopic.php?pid=1334369


"For even better randomness, let your cat walk on the keyboard." -- From the "Advanced Linux Programming" book

Offline

#5 2013-10-11 13:32:50

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 918

Re: systemd & systemd-sysvinit : 207-5 > 208-1 | unable to hibernate

I noticed until now that I have the option to hivernate but aparently is wroken, even thatnk to the polkit-gnome  removition and replacenment for lxpolkit, now lxpolkit need to type my pass when I try to hibernate...

Silver: You use lxpolkit??


Well, I suppose that this is somekind of signature, no?

Offline

#6 2013-10-11 17:32:49

SilverWyrda
Member
Registered: 2013-10-09
Posts: 6

Re: systemd & systemd-sysvinit : 207-5 > 208-1 | unable to hibernate

Hi !

@venam : Yes, it seems to be a linked issue...

@Jristz : I've the option to hibernate too only in the "Buttons" menu on the XFCE panel. However, the option is grayed out under the xfce4-power-manager menu, which also control for me the hibernate shortcut... I use polkit-gnome and I've tried lxpolkit but it was a bad experiment insofar as I've not been able to mount some partitions from thunar anymore so... (and typing the password to hibernate  . . . big_smile).

Thanks to you for your answers wink.

Last edited by SilverWyrda (2013-10-11 17:33:55)

Offline

#7 2013-12-11 08:56:04

mezcal
Member
From: Czech Republic
Registered: 2006-01-31
Posts: 64
Website

Re: systemd & systemd-sysvinit : 207-5 > 208-1 | unable to hibernate

Hi,

I have the same problem. Do you use swapfile? I have desktop with swap partition. It is working. But my laptop uses swapfile. It can not hibernate as a user.

Hibernation is working. It`s possible with sudo.

sudo systemctl hibernate

Offline

#8 2013-12-11 10:24:57

SilverWyrda
Member
Registered: 2013-10-09
Posts: 6

Re: systemd & systemd-sysvinit : 207-5 > 208-1 | unable to hibernate

@mezcal : Hi ! I also use a swap file, and the command you're providing work as expected. However, whatever I change in /etc/logind.conf, I'm unable to have a working hibernation using the power button. This issue with systemd has apparently already been patched. We will see in the next release/revision...
The commit which could solves this : http://cgit.freedesktop.org/systemd/sys … ea3e464c02.

Last edited by SilverWyrda (2013-12-11 18:18:49)

Offline

#9 2013-12-13 09:25:32

mezcal
Member
From: Czech Republic
Registered: 2006-01-31
Posts: 64
Website

Re: systemd & systemd-sysvinit : 207-5 > 208-1 | unable to hibernate

@SilverWyrda : Hi, this patch solves the problem. I have written bug report. https://bugs.archlinux.org/task/38123

Offline

Board footer

Powered by FluxBB