You are not logged in.

#1 2013-08-29 10:21:51

HeaDBanGer
Member
Registered: 2013-08-29
Posts: 5

Tevii S471 does not load Firmware

Hello

Since Kernel 3.9.x the Kernel has the problems to load the "dvb-fe-ds3000.fw" firmware.

Aug 29 08:41:52 kernel: ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
Aug 29 08:41:52 kernel: ds3000_firmware_ondemand: Waiting for firmware upload(2)...

In german boards i found 2 Threads concerning similiar Problems.

https://bbs.archlinux.de/viewtopic.php?id=20011
https://bbs.archlinux.de/viewtopic.php?pid=308707

I thought the Problem would be fixed within a few version, so i stayed on version 3.8.11, but its still in the current kernel (3.10.9).

Has anybody experienced similiar Errors (I cant tune to any channel if the firmware does not load correctly) or any idea to fix it?

Last edited by HeaDBanGer (2013-08-29 10:24:57)

Offline

#2 2013-10-16 11:34:50

JohannesK
Member
From: Bonn
Registered: 2013-07-17
Posts: 3

Re: Tevii S471 does not load Firmware

Hi HeaDBanGer,

this problem still exists in the 3.11 kernel, but is fixed in the release candidates for kernel version 3.12.
You can either stay on a kernel previous to 3.9, switch to aur/linux-mainline or apply
this patch to your kernel.

Best regards
Johannes

Last edited by JohannesK (2013-10-16 11:35:27)

Offline

#3 2013-10-16 13:24:46

HeaDBanGer
Member
Registered: 2013-08-29
Posts: 5

Re: Tevii S471 does not load Firmware

Thank your for the new Details.

I stay on 3.8.11 and looking forward to 3.12. Is there a possibility to get this code to upstream LTS-Kernel-versions?

Best regards,
   HDBG

Last edited by HeaDBanGer (2013-10-16 13:26:27)

Offline

#4 2013-11-18 17:51:00

HeaDBanGer
Member
Registered: 2013-08-29
Posts: 5

Re: Tevii S471 does not load Firmware

Installed Kernel 3.12, still not working. Downgraded to 3.8 again :-(

Offline

#5 2013-11-19 09:49:25

JohannesK
Member
From: Bonn
Registered: 2013-07-17
Posts: 3

Re: Tevii S471 does not load Firmware

Strange. I used a patched 3.11 kernel for my media center until yesterday and now switched to 3.12 without any problems.

Could you verify, that the ts2020 module is loaded (# lsmod | grep ts202)?
If it is working with the 3.8 kernel I assume, that the correct firmware dvb-fe-ds3000.fw is accessible at /usr/lib/firmware/?

This is the one I'm using:

# du -b /usr/lib/firmware/dvb-fe-ds3000.fw 
8192    /usr/lib/firmware/dvb-fe-ds3000.fw

# sha1sum /usr/lib/firmware/dvb-fe-ds3000.fw 
ce3b57c6e7643b773f795b9b2f09cc53256b235f  /usr/lib/firmware/dvb-fe-ds3000.fw

# md5sum  /usr/lib/firmware/dvb-fe-ds3000.fw 
a32d17910c4f370073f9346e71d34b80  /usr/lib/firmware/dvb-fe-ds3000.fw

Are you still experiencing the same problem as before? After reboot from a working kernel to 3.12, can you still watch the channel you were on before the reboot, while after a cold restart, you can not tune to any channel?

Best regards
Johannes

Offline

#6 2013-11-21 11:27:14

HeaDBanGer
Member
Registered: 2013-08-29
Posts: 5

Re: Tevii S471 does not load Firmware

After all your test successed I tried a diffrent client (vlc) and everything is working. After analysing the configuration of TVHeadend, I recognised that the device name changed. Redoing the channel-mapping fixed all the problems.

Thank you very much for your Help,
HeaDBanGer

Offline

#7 2013-12-09 21:18:45

JohannesK
Member
From: Bonn
Registered: 2013-07-17
Posts: 3

Re: Tevii S471 does not load Firmware

HeaDBanGer wrote:

Is there a possibility to get this code to upstream LTS-Kernel-versions?

The fix is now included in the 3.10 longterm kernel.

Best regards,
Johannes

Offline

#8 2013-12-19 10:57:22

HeaDBanGer
Member
Registered: 2013-08-29
Posts: 5

Re: Tevii S471 does not load Firmware

Everything works just fine, Thread can be closed!

Thank you for you great Help Johannes

Best regards and Happy XMas
HeaDBanGer

Offline

Board footer

Powered by FluxBB