You are not logged in.

#26 2013-10-18 16:54:29

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [SOLVED] KDE not working, could not start ksmserver

The current version is https://www.archlinux.org/packages/?name=qt4 qt4 4.8.5-3.
Pick a more up to date mirror and update.

Offline

#27 2013-10-18 17:28:49

quiqueck
Member
Registered: 2013-04-15
Posts: 49

Re: [SOLVED] KDE not working, could not start ksmserver

You are funny karol :-D the latest version of qt4  is from today. As you wrote your message, it comes to the mirror and now its installed and the issue is away :-)

xpt wrote:

Yesterday  updated with pacman -Syu and poweroff, today start the issue

Please take a look at the pacman log (/var/log/pacman.log) to determine what updates are yesterday installed.

Offline

#28 2013-10-18 17:37:18

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [SOLVED] KDE not working, could not start ksmserver

quiqueck wrote:

You are funny karol :-D the latest version of qt4  is from today.

Yup, It has been released to [extra] whole 2 hrs before you posted (If I got it right) :-)

Offline

#29 2013-10-19 03:28:48

xpt
Member
Registered: 2012-10-23
Posts: 53

Re: [SOLVED] KDE not working, could not start ksmserver

I updated and still the same

/var/log/pacman.log

[2013-10-16 13:19] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-16 13:19] [PACMAN] synchronizing package lists
[2013-10-16 13:25] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-16 13:25] [PACMAN] synchronizing package lists
[2013-10-16 14:01] [PACMAN] Running '/usr/bin/pacman --color auto -Syy'
[2013-10-16 14:01] [PACMAN] synchronizing package lists
[2013-10-16 14:02] [PACMAN] Running '/usr/bin/pacman -Swu'
[2013-10-16 14:02] [PACMAN] starting full system upgrade
[2013-10-16 14:25] [PACMAN] Running '/usr/bin/pacman --color auto -U /tmp/yaourt-tmp-xpt/PKGDEST.jeG/clementine-git-1.1.1.645.ge737e74-1-x86_64.pkg.tar.xz'
[2013-10-16 14:29] [PACMAN] removed clementine (1.1.1-9)
[2013-10-16 14:29] [PACMAN] installed clementine-git (1.1.1.645.ge737e74-1)
[2013-10-16 14:35] [PACMAN] Running '/usr/bin/pacman --color auto -S community/clementine'
[2013-10-16 14:35] [PACMAN] removed clementine-git (1.1.1.645.ge737e74-1)
[2013-10-16 14:35] [PACMAN] installed clementine (1.2.0-1)
[2013-10-16 23:54] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-16 23:54] [PACMAN] synchronizing package lists
[2013-10-17 00:26] [PACMAN] Running '/usr/bin/pacman --color auto -S -u'
[2013-10-17 00:26] [PACMAN] starting full system upgrade
[2013-10-17 00:27] [PACMAN] upgraded dbus (1.6.14-1 -> 1.6.16-1)
[2013-10-17 00:27] [PACMAN] upgraded at-spi2-core (2.10.0-1 -> 2.10.1-1)
[2013-10-17 00:27] [PACMAN] upgraded gsettings-desktop-schemas (3.10.0-1 -> 3.10.1-1)
[2013-10-17 00:27] [PACMAN] upgraded baobab (3.10-1 -> 3.10.1-1)
[2013-10-17 00:27] [PACMAN] upgraded cloog (0.18.0-2 -> 0.18.1-1)
[2013-10-17 00:27] [PACMAN] upgraded eclipse (4.3-1 -> 4.3.1-1)
[2013-10-17 00:27] [PACMAN] upgraded ethtool (1:3.10-1 -> 1:3.11-1)
[2013-10-17 00:27] [PACMAN] upgraded git (1.8.4-1 -> 1.8.4.1-1)
[2013-10-17 00:27] [PACMAN] upgraded glib-networking (2.38.0-1 -> 2.38.1-1)
[2013-10-17 00:27] [PACMAN] upgraded gnome-desktop (1:3.10.0-1 -> 1:3.10.1-1)
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-icns.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-tga.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-ico.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-pnm.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-jasper.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-jpeg.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-qtif.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-xpm.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-wbmp.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: /usr/lib/libpango-1.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-bmp.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-xbm.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-ani.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-ras.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-tiff.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-gif.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-pcx.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-17 00:27] [PACMAN] upgraded librsvg (1:2.39.0-2 -> 1:2.40.0-1)
[2013-10-17 00:27] [PACMAN] upgraded gnome-icon-theme-symbolic (3.10.0-1 -> 3.10.1-1)
[2013-10-17 00:27] [PACMAN] upgraded gnome-menus (3.10.0-1 -> 3.10.1-1)
[2013-10-17 00:27] [PACMAN] upgraded upower (0.9.20-2 -> 0.9.22-1)
[2013-10-17 00:27] [PACMAN] upgraded libsoup (2.44.0-1 -> 2.44.1-1)
[2013-10-17 00:27] [PACMAN] upgraded libgweather (3.10.0-1 -> 3.10.1-1)
[2013-10-17 00:27] [PACMAN] upgraded gnome-settings-daemon (3.10.0-1 -> 3.10.1-1)
[2013-10-17 00:27] [PACMAN] upgraded graphviz (2.32.0-2 -> 2.34.0-1)
[2013-10-17 00:27] [PACMAN] upgraded libarchive (3.1.2-2 -> 3.1.2-3)
[2013-10-17 00:27] [PACMAN] upgraded libmikmod (3.2.0-1 -> 3.3.3-1)
[2013-10-17 00:27] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2013-10-17 00:27] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2013-10-17 00:27] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2013-10-17 00:27] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2013-10-17 00:27] [ALPM-SCRIPTLET] ==> Starting build: 3.11.5-1-ARCH
[2013-10-17 00:27] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2013-10-17 00:27] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [bbswitch]
[2013-10-17 00:28] [ALPM-SCRIPTLET] Building bbswitch modules for 3.11.5-1-ARCH kernel...
[2013-10-17 00:28] [ALPM-SCRIPTLET] Error! echo
[2013-10-17 00:28] [ALPM-SCRIPTLET] Your kernel headers for kernel 3.11.5-1-ARCH cannot be found at
[2013-10-17 00:28] [ALPM-SCRIPTLET] /usr/lib/modules/3.11.5-1-ARCH/build or /usr/lib/modules/3.11.5-1-ARCH/source.
[2013-10-17 00:28] [ALPM-SCRIPTLET] Ok.
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux.img
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> Starting build: 3.11.5-1-ARCH
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: smsmdtv
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2013-10-17 00:28] [ALPM-SCRIPTLET]   -> Running build hook: [bbswitch]
[2013-10-17 00:28] [ALPM-SCRIPTLET] Building bbswitch modules for 3.11.5-1-ARCH kernel...
[2013-10-17 00:28] [ALPM-SCRIPTLET] Error! echo
[2013-10-17 00:28] [ALPM-SCRIPTLET] Your kernel headers for kernel 3.11.5-1-ARCH cannot be found at
[2013-10-17 00:28] [ALPM-SCRIPTLET] /usr/lib/modules/3.11.5-1-ARCH/build or /usr/lib/modules/3.11.5-1-ARCH/source.
[2013-10-17 00:28] [ALPM-SCRIPTLET] Ok.
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
[2013-10-17 00:28] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-10-17 00:28] [PACMAN] upgraded linux (3.11.4-1 -> 3.11.5-1)
[2013-10-17 00:28] [PACMAN] upgraded linux-headers (3.11.4-1 -> 3.11.5-1)
[2013-10-17 00:28] [PACMAN] upgraded lirc-utils (1:0.9.0-63 -> 1:0.9.0-64)
[2013-10-17 00:28] [PACMAN] upgraded mpfr (3.1.2-1 -> 3.1.2.p3-1)
[2013-10-17 00:28] [PACMAN] upgraded pygobject-devel (3.10.0-1 -> 3.10.1-1)
[2013-10-17 00:28] [ALPM] warning: directory permissions differ on /usr/lib/python3.3/site-packages/gi/_gobject/__pycache__/
filesystem: 700  package: 755
[2013-10-17 00:28] [ALPM] warning: directory permissions differ on /usr/lib/python3.3/site-packages/gi/_glib/__pycache__/
filesystem: 700  package: 755
[2013-10-17 00:28] [ALPM] warning: directory permissions differ on /usr/lib/python3.3/site-packages/gi/overrides/__pycache__/
filesystem: 700  package: 755
[2013-10-17 00:28] [ALPM] warning: directory permissions differ on /usr/lib/python3.3/site-packages/gi/repository/__pycache__/
filesystem: 700  package: 755
[2013-10-17 00:28] [PACMAN] upgraded python-gobject (3.10.0-1 -> 3.10.1-1)
[2013-10-17 00:28] [PACMAN] upgraded sip (4.15.2-1 -> 4.15.3-1)
[2013-10-17 00:28] [PACMAN] upgraded python-sip (4.15.2-1 -> 4.15.3-1)
[2013-10-17 00:28] [PACMAN] upgraded python2-gobject (3.10.0-1 -> 3.10.1-1)
[2013-10-17 00:28] [PACMAN] upgraded python2-sip (4.15.2-1 -> 4.15.3-1)
[2013-10-17 00:28] [PACMAN] upgraded qtwebkit (2.3.2-1 -> 2.3.3-1)
[2013-10-17 00:28] [PACMAN] upgraded vte-common (0.34.8-1 -> 0.34.9-1)
[2013-10-17 00:28] [PACMAN] upgraded vte3 (0.34.8-1 -> 0.34.9-1)
[2013-10-17 00:28] [PACMAN] upgraded vinagre (3.10.0-2 -> 3.10.1-1)
[2013-10-17 00:28] [PACMAN] upgraded virtualbox-guest-modules (4.2.18-6 -> 4.2.18-7)
[2013-10-17 00:28] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2013-10-17 00:28] [PACMAN] upgraded virtualbox-host-modules (4.2.18-6 -> 4.2.18-7)
[2013-10-17 00:28] [PACMAN] upgraded yelp-xsl (3.10.0-1 -> 3.10.1-1)
[2013-10-17 00:40] [PACMAN] Running '/usr/bin/pacman --color auto -U /tmp/yaourt-tmp-xpt/PKGDEST.UaT/archlinux-artwork-1.6-3-any.pkg.tar.xz'
[2013-10-17 00:40] [PACMAN] upgraded archlinux-artwork (1.6-2 -> 1.6-3)
[2013-10-17 03:01] [PACMAN] Running '/usr/bin/pacman --color auto -S --asdeps --needed --ignore chromium-libpdf --ignore lightdm-ubuntu --ignore lightdm-unity-greeter --noconfirm extra/python2-lxml'
[2013-10-17 03:01] [PACMAN] installed python2-lxml (3.2.3-1)
[2013-10-17 03:05] [PACMAN] Running '/usr/bin/pacman --color auto -U --ignore chromium-libpdf --ignore lightdm-ubuntu --ignore lightdm-unity-greeter --noconfirm /tmp/yaourt-tmp-xpt/PKGDEST.3Ji/kdeplasma-applets-networkmanagement-1:0.9.0.9-4-x86_64.pkg.tar.xz'
[2013-10-17 03:05] [PACMAN] upgraded kdeplasma-applets-networkmanagement (1:0.9.0.9-3 -> 1:0.9.0.9-4)
[2013-10-17 03:32] [PACMAN] Running '/usr/bin/pacman -R bamf'
[2013-10-17 03:32] [PACMAN] Running '/usr/bin/pacman -Rcsn bamf'
[2013-10-17 14:06] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 14:06] [PACMAN] synchronizing package lists
[2013-10-17 14:07] [PACMAN] Running '/usr/bin/pacman --color auto -S -u'
[2013-10-17 14:07] [PACMAN] starting full system upgrade
[2013-10-17 14:17] [PACMAN] upgraded icu (51.2-1 -> 52.1-1)
[2013-10-17 14:17] [PACMAN] upgraded boost-libs (1.54.0-3 -> 1.54.0-4)
[2013-10-17 14:17] [PACMAN] upgraded boost (1.54.0-3 -> 1.54.0-4)
[2013-10-17 14:17] [PACMAN] upgraded harfbuzz (0.9.19-1 -> 0.9.22-1)
[2013-10-17 14:17] [PACMAN] upgraded harfbuzz-icu (0.9.19-1 -> 0.9.22-1)
[2013-10-17 14:17] [PACMAN] upgraded chromium (30.0.1599.66-1 -> 30.0.1599.101-1)
[2013-10-17 14:17] [PACMAN] upgraded gcr (3.10.0-1 -> 3.10.1-1)
[2013-10-17 14:17] [PACMAN] upgraded gnome-keyring (3.10.0-1 -> 3.10.1-1)
[2013-10-17 14:17] [PACMAN] upgraded hplip (3.13.9-3 -> 3.13.10-1)
[2013-10-17 14:18] [ALPM-SCRIPTLET] updating font cache... done.
[2013-10-17 14:18] [PACMAN] upgraded lib32-fontconfig (2.10.95-1.1 -> 2.11.0-1)
[2013-10-17 14:18] [PACMAN] upgraded lib32-libdrm (2.4.46-1 -> 2.4.47-1)
[2013-10-17 14:18] [PACMAN] upgraded libgnome-keyring (3.10.0-1 -> 3.10.1-1)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-common (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-base (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-calc (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-draw (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-gnome (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-impress (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-kde4 (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-math (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-postgresql-connector (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-sdk (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-sdk-doc (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libreoffice-writer (4.1.2-1 -> 4.1.2-2)
[2013-10-17 14:18] [PACMAN] upgraded libtracker-sparql (0.16.2-2 -> 0.16.2-3)
[2013-10-17 14:18] [PACMAN] upgraded python2-pillow (2.2.1-1 -> 2.2.1-2)
[2013-10-17 14:18] [PACMAN] upgraded qt5-base (5.1.1-1 -> 5.1.1-2)
[2013-10-17 14:18] [PACMAN] upgraded raptor (2.0.10-2 -> 2.0.10-3)
[2013-10-17 14:18] [PACMAN] upgraded seahorse (3.10.0-1 -> 3.10.1-1)
[2013-10-17 14:18] [PACMAN] upgraded webkitgtk (2.2.0-1 -> 2.2.0-2)
[2013-10-17 14:18] [PACMAN] upgraded webkitgtk2 (1.10.2-7 -> 1.10.2-8)
[2013-10-17 14:18] [PACMAN] upgraded zeromq (3.2.3-1 -> 4.0.1-1)
[2013-10-17 14:28] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 14:28] [PACMAN] synchronizing package lists
[2013-10-17 15:28] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 15:28] [PACMAN] synchronizing package lists
[2013-10-17 15:32] [PACMAN] Running '/usr/bin/pacman --color auto -S extra/libdbusmenu-qt'
[2013-10-17 15:32] [PACMAN] removed libdbusmenu-qt-patched (0.9.2-3)
[2013-10-17 15:32] [PACMAN] installed libdbusmenu-qt (0.9.2-2)
[2013-10-17 15:34] [PACMAN] Running '/usr/bin/pacman --color auto -S extra/qt-gstreamer extra/phonon-gstreamer'
[2013-10-17 15:34] [PACMAN] reinstalled qt-gstreamer (0.10.2-3)
[2013-10-17 15:34] [PACMAN] reinstalled phonon-gstreamer (4.6.3-1)
[2013-10-17 15:36] [PACMAN] Running '/usr/bin/pacman --color auto -S extra/qt5-base'
[2013-10-17 15:37] [PACMAN] reinstalled qt5-base (5.1.1-2)
[2013-10-17 15:39] [PACMAN] Running '/usr/bin/pacman --color auto -U /tmp/yaourt-tmp-xpt/PKGDEST.d2C/appmenu-qt5-0.2.7daily13.03.28-1-x86_64.pkg.tar.xz /tmp/yaourt-tmp-xpt/PKGDEST.d2C/appmenu-qt5-debug-0.2.7daily13.03.28-1-x86_64.pkg.tar.xz'
[2013-10-17 15:39] [PACMAN] reinstalled appmenu-qt5 (0.2.7daily13.03.28-1)
[2013-10-17 15:39] [PACMAN] reinstalled appmenu-qt5-debug (0.2.7daily13.03.28-1)
[2013-10-17 15:40] [PACMAN] Running '/usr/bin/pacman --color auto -U /tmp/yaourt-tmp-xpt/PKGDEST.2NG/libdbusmenu-qt5-0.9.2daily13.03.28-1-x86_64.pkg.tar.xz /tmp/yaourt-tmp-xpt/PKGDEST.2NG/libdbusmenu-qt5-debug-0.9.2daily13.03.28-1-x86_64.pkg.tar.xz'
[2013-10-17 15:40] [PACMAN] reinstalled libdbusmenu-qt5 (0.9.2daily13.03.28-1)
[2013-10-17 15:40] [PACMAN] reinstalled libdbusmenu-qt5-debug (0.9.2daily13.03.28-1)
[2013-10-17 15:44] [PACMAN] Running '/usr/bin/pacman --color auto -S multilib/lib32-icu'
[2013-10-17 15:44] [PACMAN] installed lib32-icu (51.2-1)
[2013-10-17 15:53] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 15:53] [PACMAN] synchronizing package lists
[2013-10-17 16:09] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 16:09] [PACMAN] synchronizing package lists
[2013-10-17 16:19] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 16:19] [PACMAN] synchronizing package lists
[2013-10-17 16:19] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 16:19] [PACMAN] synchronizing package lists
[2013-10-17 16:22] [PACMAN] Running '/usr/bin/pacman --color auto -S extra/icu'
[2013-10-17 16:22] [PACMAN] reinstalled icu (52.1-1)
[2013-10-17 16:23] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 16:23] [PACMAN] synchronizing package lists
[2013-10-17 16:23] [PACMAN] Running '/usr/bin/pacman --color auto -U /tmp/yaourt-tmp-xpt/PKGDEST.j4z/chromium-libpdf-32.0.1671.3-1-x86_64.pkg.tar.xz'
[2013-10-17 16:24] [PACMAN] upgraded chromium-libpdf (32.0.1664.3-1 -> 32.0.1671.3-1)
[2013-10-17 16:24] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 16:24] [PACMAN] synchronizing package lists
[2013-10-17 16:28] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 16:28] [PACMAN] synchronizing package lists
[2013-10-17 16:37] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 16:37] [PACMAN] synchronizing package lists
[2013-10-17 16:38] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 16:38] [PACMAN] synchronizing package lists
[2013-10-17 16:40] [PACMAN] Running '/usr/bin/pacman --color auto -S -u'
[2013-10-17 16:40] [PACMAN] starting full system upgrade
[2013-10-17 16:43] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2013-10-17 16:43] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-ck.preset: 'default'
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-ck -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-ck.img
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> Starting build: 3.11.5-1-ck
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [bbswitch]
[2013-10-17 16:43] [ALPM-SCRIPTLET] Building bbswitch modules for 3.11.5-1-ck kernel...
[2013-10-17 16:43] [ALPM-SCRIPTLET] Error! echo
[2013-10-17 16:43] [ALPM-SCRIPTLET] Your kernel headers for kernel 3.11.5-1-ck cannot be found at
[2013-10-17 16:43] [ALPM-SCRIPTLET] /usr/lib/modules/3.11.5-1-ck/build or /usr/lib/modules/3.11.5-1-ck/source.
[2013-10-17 16:43] [ALPM-SCRIPTLET] Ok.
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux-ck.img
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-ck.preset: 'fallback'
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-ck -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-ck-fallback.img -S autodetect
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> Starting build: 3.11.5-1-ck
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: smsmdtv
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2013-10-17 16:43] [ALPM-SCRIPTLET]   -> Running build hook: [bbswitch]
[2013-10-17 16:43] [ALPM-SCRIPTLET] Building bbswitch modules for 3.11.5-1-ck kernel...
[2013-10-17 16:43] [ALPM-SCRIPTLET] Error! echo
[2013-10-17 16:43] [ALPM-SCRIPTLET] Your kernel headers for kernel 3.11.5-1-ck cannot be found at
[2013-10-17 16:43] [ALPM-SCRIPTLET] /usr/lib/modules/3.11.5-1-ck/build or /usr/lib/modules/3.11.5-1-ck/source.
[2013-10-17 16:43] [ALPM-SCRIPTLET] Ok.
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux-ck-fallback.img
[2013-10-17 16:43] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-10-17 16:43] [ALPM-SCRIPTLET] 
[2013-10-17 16:43] [ALPM-SCRIPTLET] >>> Thank you for using http://repo-ck.com/ for your linux-ck package needs.
[2013-10-17 16:43] [ALPM-SCRIPTLET] >>> Note that the following CPU optimized packages are or could be available to you:
[2013-10-17 16:43] [ALPM-SCRIPTLET]  AMD   : barcelona, bobcat, bulldozer, kx, k10, piledriver
[2013-10-17 16:43] [ALPM-SCRIPTLET]  Intel : atom, core2, haswell, ivybridge, nehalem, p4, pentm, sandybridge
[2013-10-17 16:43] [ALPM-SCRIPTLET] 
[2013-10-17 16:43] [ALPM-SCRIPTLET] >>> Search via group name:  pacman -Sg ck-ivybridge
[2013-10-17 16:43] [ALPM-SCRIPTLET] 
[2013-10-17 16:43] [ALPM-SCRIPTLET] >>> Post in the repo support thread if package group is unavailable for your architecture:
[2013-10-17 16:43] [ALPM-SCRIPTLET] >>> https://bbs.archlinux.org/viewtopic.php?id=111715
[2013-10-17 16:43] [PACMAN] upgraded linux-ck-sandybridge (3.11.4-1 -> 3.11.5-1)
[2013-10-17 16:43] [PACMAN] upgraded broadcom-wl-ck-sandybridge (6.30.223.141-2 -> 6.30.223.141-3)
[2013-10-17 16:43] [PACMAN] upgraded linux-ck-sandybridge-headers (3.11.4-1 -> 3.11.5-1)
[2013-10-17 16:43] [PACMAN] upgraded menu-cache (0.5.0-2 -> 0.5.1-1)
[2013-10-17 16:43] [ALPM-SCRIPTLET] rmmod: ERROR: Module nvidia is not currently loaded
[2013-10-17 16:43] [ALPM-SCRIPTLET] In order to use the new nvidia module, exit Xserver and unload it manually.
[2013-10-17 16:43] [PACMAN] upgraded nvidia-ck-sandybridge (325.15-7 -> 325.15-8)
[2013-10-17 16:45] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 16:45] [PACMAN] synchronizing package lists
[2013-10-17 16:51] [PACMAN] Running '/usr/bin/pacman -Rcsn plasma-wallpaper-dreamdesktop'
[2013-10-17 16:53] [PACMAN] Running '/usr/bin/pacman --color auto -U --noconfirm /tmp/yaourt-tmp-xpt/PKGDEST.0kj/partitionmanager-svn-1367118-1-x86_64.pkg.tar.xz'
[2013-10-17 16:53] [PACMAN] upgraded partitionmanager-svn (1358183-1 -> 1367118-1)
[2013-10-17 16:53] [PACMAN] Running '/usr/bin/pacman --color auto -U --noconfirm /tmp/yaourt-tmp-xpt/PKGDEST.eKe/kdeplasma-applets-veromix-git-10.f2e9c5d-1-x86_64.pkg.tar.xz'
[2013-10-17 16:53] [PACMAN] reinstalled kdeplasma-applets-veromix-git (10.f2e9c5d-1)
[2013-10-17 16:56] [PACMAN] Running '/usr/bin/pacman -Rcsn libdbusmenu'
[2013-10-17 16:57] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 16:57] [PACMAN] synchronizing package lists
[2013-10-17 17:02] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 17:02] [PACMAN] synchronizing package lists
[2013-10-17 17:03] [PACMAN] Running '/usr/bin/pacman --color auto -S extra/libtiger'
[2013-10-17 17:03] [PACMAN] reinstalled libtiger (0.3.4-3)
[2013-10-17 17:04] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 17:04] [PACMAN] synchronizing package lists
[2013-10-17 17:08] [PACMAN] Running '/usr/bin/pacman --color auto -U --noconfirm /tmp/yaourt-tmp-xpt/PKGDEST.krO/cairo-ubuntu-1.12.16-2-x86_64.pkg.tar.xz'
[2013-10-17 17:08] [PACMAN] reinstalled cairo-ubuntu (1.12.16-2)
[2013-10-17 17:19] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 17:19] [PACMAN] synchronizing package lists
[2013-10-17 17:24] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 17:24] [PACMAN] synchronizing package lists
[2013-10-17 17:26] [PACMAN] Running '/usr/bin/pacman --color auto -U /tmp/yaourt-tmp-xpt/PKGDEST.xvg/pyload-git-2621.76e7c4b-1-any.pkg.tar.xz'
[2013-10-17 17:26] [PACMAN] upgraded pyload-git (2595.cef7ca8-1 -> 2621.76e7c4b-1)
[2013-10-17 17:26] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 17:26] [PACMAN] synchronizing package lists
[2013-10-17 17:56] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 17:56] [PACMAN] synchronizing package lists
[2013-10-17 18:02] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 18:02] [PACMAN] synchronizing package lists
[2013-10-17 18:19] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 18:19] [PACMAN] synchronizing package lists
[2013-10-17 18:29] [PACMAN] Running '/usr/bin/pacman -U Descargas/qt4-4.8.5-3-x86_64.pkg.tar.xz'
[2013-10-17 18:29] [PACMAN] upgraded qt4 (4.8.5-2 -> 4.8.5-3)
[2013-10-17 18:52] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 18:52] [PACMAN] synchronizing package lists
[2013-10-17 18:57] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 18:57] [PACMAN] synchronizing package lists
[2013-10-17 20:14] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 20:14] [PACMAN] synchronizing package lists
[2013-10-17 20:45] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 20:45] [PACMAN] synchronizing package lists
[2013-10-17 21:03] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 21:03] [PACMAN] synchronizing package lists
[2013-10-17 21:05] [PACMAN] Running '/usr/bin/pacman --color auto -S -u'
[2013-10-17 21:05] [PACMAN] starting full system upgrade
[2013-10-17 21:05] [PACMAN] upgraded youtube-dl (2013.10.07-1 -> 2013.10.17-1)
[2013-10-17 21:59] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 21:59] [PACMAN] synchronizing package lists
[2013-10-17 22:49] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 22:49] [PACMAN] synchronizing package lists
[2013-10-17 23:04] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 23:04] [PACMAN] synchronizing package lists
[2013-10-17 23:13] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 23:13] [PACMAN] synchronizing package lists
[2013-10-17 23:19] [PACMAN] Running '/usr/bin/pacman --color auto -S -u'
[2013-10-17 23:19] [PACMAN] starting full system upgrade
[2013-10-17 23:19] [PACMAN] upgraded python2-pycurl (7.19.0-2 -> 7.19.0.2-1)
[2013-10-17 23:19] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-17 23:19] [PACMAN] synchronizing package lists
[2013-10-18 01:31] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-18 01:31] [PACMAN] synchronizing package lists
[2013-10-18 02:09] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-18 02:09] [PACMAN] synchronizing package lists
[2013-10-18 12:25] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-18 12:25] [PACMAN] synchronizing package lists
[2013-10-18 12:26] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-18 12:26] [PACMAN] synchronizing package lists
[2013-10-18 12:27] [PACMAN] Running '/usr/bin/pacman --color auto -S -u'
[2013-10-18 12:27] [PACMAN] starting full system upgrade
[2013-10-18 12:28] [PACMAN] upgraded hplip (3.13.10-1 -> 3.13.10-2)
[2013-10-18 12:28] [PACMAN] upgraded sqlite (3.8.0.2-1 -> 3.8.1-1)
[2013-10-18 12:29] [PACMAN] Running '/usr/bin/pacman --color auto -S extra/qt5-base'
[2013-10-18 12:30] [PACMAN] reinstalled qt5-base (5.1.1-2)
[2013-10-18 12:30] [PACMAN] Running '/usr/bin/pacman --color auto -S extra/qt4'
[2013-10-18 23:52] [PACMAN] Running '/usr/bin/pacman --color auto -S extra/qt5-base'
[2013-10-18 23:52] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-18 23:52] [PACMAN] synchronizing package lists
[2013-10-18 23:55] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-18 23:55] [PACMAN] synchronizing package lists
[2013-10-19 00:05] [PACMAN] Running '/usr/bin/pacman --color auto -S -u'
[2013-10-19 00:05] [PACMAN] starting full system upgrade
[2013-10-19 00:20] [PACMAN] Running '/usr/bin/pacman --color auto -S community/zeromq'
[2013-10-19 00:20] [PACMAN] upgraded zeromq (4.0.1-1 -> 4.0.1-3)
[2013-10-19 00:20] [PACMAN] Running '/usr/bin/pacman --color auto -S extra/qt4'
[2013-10-19 00:23] [PACMAN] reinstalled qt4 (4.8.5-3)
[2013-10-19 00:23] [PACMAN] Running '/usr/bin/pacman --color auto -Sy'
[2013-10-19 00:23] [PACMAN] synchronizing package lists

the problem with icu longer appears, only the ksmserver

Last edited by xpt (2013-10-19 03:36:12)

Offline

#30 2013-10-19 03:39:44

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [SOLVED] KDE not working, could not start ksmserver

So what did you do about the errors?

Last edited by cfr (2013-10-19 03:42:28)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#31 2013-10-19 03:42:26

xpt
Member
Registered: 2012-10-23
Posts: 53

Re: [SOLVED] KDE not working, could not start ksmserver

I can't start KDE, and gives me the error that showed you at the beginning of the post

Offline

#32 2013-10-19 03:43:44

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [SOLVED] KDE not working, could not start ksmserver

What did you do about the errors mentioned in pacman's output?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#33 2013-10-19 03:47:33

xpt
Member
Registered: 2012-10-23
Posts: 53

Re: [SOLVED] KDE not working, could not start ksmserver

i updated the 16/10 all packages,  when I turned on the notebook on the 17th, I had the issue

Offline

#34 2013-10-19 04:15:34

Alambre
Member
Registered: 2011-11-30
Posts: 11

Re: [SOLVED] KDE not working, could not start ksmserver

some here, but on gnome

extra/icu 52.1-1 [instalado]

------------------------------------------

ls /usr/lib/libicu*                                                                            
/usr/lib/libicudata.so       /usr/lib/libicuio.so       /usr/lib/libiculx.so         /usr/lib/libicutu.so
/usr/lib/libicudata.so.52    /usr/lib/libicuio.so.52    /usr/lib/libiculx.so.52      /usr/lib/libicutu.so.52
/usr/lib/libicudata.so.52.1  /usr/lib/libicuio.so.52.1  /usr/lib/libiculx.so.52.1    /usr/lib/libicutu.so.52.1
/usr/lib/libicui18n.so       /usr/lib/libicule.so       /usr/lib/libicutest.so       /usr/lib/libicuuc.so
/usr/lib/libicui18n.so.52    /usr/lib/libicule.so.52    /usr/lib/libicutest.so.52    /usr/lib/libicuuc.so.52
/usr/lib/libicui18n.so.52.1  /usr/lib/libicule.so.52.1  /usr/lib/libicutest.so.52.1  /usr/lib/libicuuc.so.52.1

$gnome-control-center                                                                             
gnome-control-center: error while loading shared libraries: libicuuc.so.51: cannot open shared object file: No such file or directory

ls /usr/lib/libicuu* -la                                                                         
lrwxrwxrwx 1 root root      16 oct 12 05:47 /usr/lib/libicuuc.so -> libicuuc.so.52.1
lrwxrwxrwx 1 root root      16 oct 12 05:47 /usr/lib/libicuuc.so.52 -> libicuuc.so.52.1
-rwxr-xr-x 1 root root 1526432 oct 12 05:47 /usr/lib/libicuuc.so.52.1

#ln -s /usr/lib/libicuuc.so /usr/lib/libicuuc.so.51

$gnome-control-center                                                                            
gnome-control-center: error while loading shared libraries: libicudata.so.51: cannot open shared object file: No such file or directory

#ln -s /usr/lib/libicudata.so /usr/lib/libicudata.so.51

Last edited by Alambre (2013-10-19 04:20:26)

Offline

#35 2013-10-19 05:55:35

xpt
Member
Registered: 2012-10-23
Posts: 53

Re: [SOLVED] KDE not working, could not start ksmserver

cat ~.xsession-errors

startkde: Starting up...
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kbuildsycoca4 running...
KCrash: Attempting to start /usr/bin/kded4 from kdeinit
KCrash: Application 'kded4' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
kded(2899): Communication problem with  "kded" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" " 

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
drkonqi(2903) SystemInformation::tryToSetBugzillaPlatformFromExternalInfo: found lsb_release
drkonqi(2903) KCrashBackend::constructCrashedApplication: Using /proc to determine executable path
drkonqi(2903) KCrashBackend::constructCrashedApplication: Executable is: "/usr/bin/kdeinit4"
drkonqi(2903) KCrashBackend::constructCrashedApplication: Executable exists: true
kbuildsycoca4 running...
drkonqi(2903) DrKonqi::init: Enabling drkonqi crash catching
kded(2902): Communication problem with  "kded" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" " 

drkonqi(2903)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "The name org.kde.kded was not provided by any .service files" 

kdeinit4: (ksmserver /usr/bin/ksmserver) Pipe closed unexpectedlykdeinit4: Pipe closed unexpectedly: Recurso no disponible temporalmente
KInit could not launch 'ksmserver'.
startkde: Could not start ksmserver. Check your installation.
drkonqi(2903) KCrashBackend::stopAttachedProcess: Sending SIGSTOP to process
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
klauncher: Exiting on signal 1
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit. 

Offline

#36 2013-10-19 13:05:00

Al_xl
Member
Registered: 2013-10-19
Posts: 2

Re: [SOLVED] KDE not working, could not start ksmserver

hi,

i just wanted to mention that i saw the

Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)"

Error today when i wanted to setup a kdialog script.

But now after the update to qt4-4.8.5-3 the output is gone and my problem is fixed.

Hope i gave a little helpful input to this problem

Alex

Last edited by Al_xl (2013-10-19 13:05:32)

Offline

#37 2013-10-19 23:46:15

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [SOLVED] KDE not working, could not start ksmserver

cfr wrote:

What did you do about the errors mentioned in pacman's output?

That output shows errors building kernel modules. Have you addressed those? If so, how?

Last edited by cfr (2013-10-19 23:47:25)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#38 2013-10-19 23:50:33

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [SOLVED] KDE not working, could not start ksmserver

@Alambre,
That is not really the same issue. The icu problem for the OP is resolved and wasn't the main problem in the first place.

If your system is fully updated and you are still having problems, I suggest starting a new thread or joining a more relevant existing one, if applicable, to avoid side-tracking this one which is struggling somewhat as it is.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#39 2013-10-20 00:43:45

xpt
Member
Registered: 2012-10-23
Posts: 53

Re: [SOLVED] KDE not working, could not start ksmserver

cfr wrote:
cfr wrote:

What did you do about the errors mentioned in pacman's output?

That output shows errors building kernel modules. Have you addressed those? If so, how?

the problem with bbswitch solved after installing it with mkinitcpio -p linux

Offline

#40 2013-10-20 01:34:16

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [SOLVED] KDE not working, could not start ksmserver

Maybe try running kded4 with the --check option to see if it can check the database? Also any debug or verbose options it has so you get as much information as possible about it crashing.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#41 2013-10-20 06:51:36

xpt
Member
Registered: 2012-10-23
Posts: 53

Re: [SOLVED] KDE not working, could not start ksmserver

i run kded4 --check over LXDE, and  gave me nothing.

Also, i run plasma-desktop over LXDE, and work fine

 xpt@arch:~$ plasma-desktop 
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusObjectPath: invalid path ""
QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.36'
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
Could not resolve property : linearGradient5334
Could not resolve property : linearGradient5332
Could not resolve property : linearGradient5326
Could not resolve property : linearGradient5328
Could not resolve property : linearGradient5334
Could not resolve property : linearGradient5332
Could not resolve property : linearGradient5326
Could not resolve property : linearGradient5328
Could not resolve property : linearGradient5334
Could not resolve property : linearGradient5332
Could not resolve property : linearGradient5326
Could not resolve property : linearGradient5328
Object::connect: No such signal QDBusAbstractInterface::DeviceAdded(QString)
Object::connect: No such signal QDBusAbstractInterface::DeviceAdded(QString)
Object::connect: No such signal QDBusAbstractInterface::DeviceRemoved(QString)
Object::connect: No such signal QDBusAbstractInterface::DeviceRemoved(QString)
QGraphicsLinearLayout::removeAt: invalid index 0
file:///usr/lib/kde4/imports/org/kde/homerun/components/TabButton.qml:161:5: QML QDeclarativeText_QML_81: Possible anchor loop detected on fill.
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
xpt@arch:~$ Could not resolve property : linearGradient5334
Could not resolve property : linearGradient5332
Could not resolve property : linearGradient5326
Could not resolve property : linearGradient5328
Could not resolve property : linearGradient5334
Could not resolve property : linearGradient5332
Could not resolve property : linearGradient5326
Could not resolve property : linearGradient5328
Could not resolve property : linearGradient5334
Could not resolve property : linearGradient5332
Could not resolve property : linearGradient5326
Could not resolve property : linearGradient5328
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:431:9: QML Flickable: Possible anchor loop detected on fill.
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:431:9: QML Flickable: Possible anchor loop detected on fill.
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:431:9: QML Flickable: Possible anchor loop detected on fill.
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:431:9: QML Flickable: Possible anchor loop detected on fill.
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:327:9: QML ListView: Possible anchor loop detected on fill.
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:327:9: QML ListView: Possible anchor loop detected on fill.
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:327:9: QML ListView: Possible anchor loop detected on fill.
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:327:9: QML ListView: Possible anchor loop detected on fill.
"/org/freedesktop/UDisks2/drives/SAMSUNG_HM641JI_S26XJ9BB925947" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/TSSTcorp_CDDVDW_SN_208BB_R8F96GOB925020" : property "Drive" does not exist 
link XMLID_34_ hasn't been detected!
link XMLID_34_ hasn't been detected!
link XMLID_36_ hasn't been detected!
========================>  5 0
static bool QDeclarativeMetaType::isModule(const QByteArray&, int, int) Qt 4.7 import detected; please note that Qt 4.7 is directly reusable as QtQuick 1.x with no code changes. Continuing, but startup time will be slower. 
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
veromix icon installed
Object::connect: No such signal SimpleJavaScriptApplet::formFactorChanged()
Object::connect: No such signal SimpleJavaScriptApplet::locationChanged()
Object::connect: No such signal SimpleJavaScriptApplet::contextChanged()
Object::connect: No such signal Plasma::PopupApplet::popupEvent(bool)
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
trying to alter state of unknown activity!!
"/org/freedesktop/UDisks2/drives/SAMSUNG_HM641JI_S26XJ9BB925947" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/TSSTcorp_CDDVDW_SN_208BB_R8F96GOB925020" : property "Drive" does not exist 
file:///usr/lib/kde4/imports/org/kde/plasma/components/SectionScroller.qml:103: TypeError: Result of expression 'listView' [null] is not an object.
file:///usr/lib/kde4/imports/org/kde/plasma/components/SectionScroller.qml:175: ReferenceError: Can't find variable: sectionsRepeater
file:///usr/lib/kde4/imports/org/kde/plasma/components/SectionScroller.qml:103: Error: Cannot assign [undefined] to QString
file:///usr/share/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_119: Detectado posible bucle de anclaje en ëfillû.
file:///usr/share/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_119: Detectado posible bucle de anclaje en ëfillû.
file:///usr/share/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_119: Detectado posible bucle de anclaje en ëfillû.
file:///usr/share/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_119: Detectado posible bucle de anclaje en ëfillû.
file:///usr/share/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_119: Detectado posible bucle de anclaje en ëfillû.
file:///usr/share/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_119: Detectado posible bucle de anclaje en ëfillû.
file:///usr/share/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_119: Detectado posible bucle de anclaje en ëfillû.
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
xpt@arch:~$ virtual QStringList Solid::Backends::UPower::UPowerManager::allDevices()  error:  "org.freedesktop.DBus.Error.TimedOut" 
virtual QStringList Solid::Backends::UPower::UPowerManager::allDevices()  error:  "org.freedesktop.DBus.Error.NoReply" 
file:///usr/share/apps/plasma/plasmoids/battery/contents/ui/batterymonitor.qml:125: TypeError: Result of expression 'pmSource.data["PowerDevil"]' [undefined] is not an object.
file:///usr/share/apps/plasma/plasmoids/battery/contents/ui/batterymonitor.qml:124: TypeError: Result of expression 'pmSource.data["PowerDevil"]' [undefined] is not an object.
file:///usr/share/apps/plasma/plasmoids/battery/contents/ui/CompactRepresentation.qml:81:9: QML Column: Cannot specify top, bottom, verticalCenter, fill or centerIn anchors for items inside Column
link XMLID_34_ hasn't been detected!
link XMLID_34_ hasn't been detected!
link XMLID_36_ hasn't been detected!
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
plasma-desktop(7554)/libakonadi Akonadi::AgentManagerPrivate::createDBusInterface: AgentManager failed to get a valid AgentManager DBus interface. Error is: 1 "org.freedesktop.DBus.Error.NameHasNoOwner" "Could not get owner of name 'org.freedesktop.Akonadi.Control': no such name" 
plasma-desktop(7554)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Invalid name" 
plasma-desktop(7554)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Invalid name" 
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
search paths:  ("/home/xpt/.bin", "/usr/lib/lightdm/lightdm", "/usr/local/sbin", "/usr/local/bin", "/usr/sbin", "/usr/bin", "/sbin", "/bin", "/usr/games", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin", "/opt/mysql/sbin") 
plasma-desktop(7554)/libplasma Plasma::PackagePrivate::isValid: Could not find required directory images 
"/org/freedesktop/UDisks2/drives/SAMSUNG_HM641JI_S26XJ9BB925947" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/SAMSUNG_HM641JI_S26XJ9BB925947" : property "Device" does not exist 
plasma-desktop(7554)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
"/org/freedesktop/UDisks2/drives/TSSTcorp_CDDVDW_SN_208BB_R8F96GOB925020" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/TSSTcorp_CDDVDW_SN_208BB_R8F96GOB925020" : property "Device" does not exist 
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
akonadi.collectionattributetable                   OK
akonadi.collectionmimetyperelation                 OK
akonadi.collectionpimitemrelation                  OK
akonadi.collectiontable                            OK
akonadi.flagtable                                  OK
akonadi.mimetypetable                              OK
akonadi.parttable                                  OK
akonadi.pimitemflagrelation                        OK
akonadi.pimitemtable                               OK
akonadi.resourcetable                              OK
akonadi.schemaversiontable                         OK
Nepomuk Query Server not available
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
search paths:  ("/home/xpt/.bin", "/usr/lib/lightdm/lightdm", "/usr/local/sbin", "/usr/local/bin", "/usr/sbin", "/usr/bin", "/sbin", "/bin", "/usr/games") 
akonadi_gcal_resource_4(7780)/libakonadi Akonadi::AgentManagerPrivate::createDBusInterface: AgentManager failed to get a valid AgentManager DBus interface. Error is: 1 "org.freedesktop.DBus.Error.NameHasNoOwner" "Could not get owner of name 'org.freedesktop.Akonadi.Control': no such name" 
search paths:  ("/usr/lib", "/usr/lib/qt4/plugins/", "/usr/lib/kde4/", "/usr/lib/kde4/plugins/", "/usr/lib/qt4/plugins/", "/usr/lib/qt4/plugins", "/usr/bin", "/home/xpt/.kde4/lib/kde4/") 
search paths:  ("/usr/lib", "/usr/lib/qt4/plugins/", "/usr/lib/kde4/", "/usr/lib/kde4/plugins/", "/usr/lib/qt4/plugins/", "/usr/lib/qt4/plugins", "/usr/bin", "/home/xpt/.kde4/lib/kde4/") 
AkonadiAgentServer(7784)/libakonadi Akonadi::AgentManagerPrivate::createDBusInterface: AgentManager failed to get a valid AgentManager DBus interface. Error is: 1 "org.freedesktop.DBus.Error.NameHasNoOwner" "Could not get owner of name 'org.freedesktop.Akonadi.Control': no such name" 
QDBusConnection: name 'org.freedesktop.Akonadi.Control' had owner '' but we thought it was ':1.50'
QGridLayoutEngine::addItem: Cell (0, 1) already taken
QGridLayoutEngine::addItem: Cell (0, 1) already taken
QGridLayoutEngine::addItem: Cell (0, 1) already taken
QGridLayoutEngine::addItem: Cell (0, 1) already taken
QGridLayoutEngine::addItem: Cell (0, 1) already taken
akonadi_googlecalendar_resource_5(7781) GoogleResource::slotAccountManagerReady: true
plasma-desktop(7554)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
akonadi_googlecalendar_resource_5(7781)/LibKGAPI KGAPI2::Job::Private::_k_replyReceived: Unauthorized. Access token has expired or is invalid. 
akonadi_googlecalendar_resource_5(7781) GoogleResource::handleError: KGAPI2::CalendarFetchJob(0x21a6730) "Invalid authentication."
akonadi_googlecalendar_resource_7(7783)/LibKGAPI KGAPI2::Job::Private::_k_replyReceived: Unauthorized. Access token has expired or is invalid. 
akonadi_googlecalendar_resource_5(7781) GoogleResource::slotAuthJobFinished:
QGridLayoutEngine::addItem: Cell (0, 1) already taken
 list is empty 
QGridLayoutEngine::addItem: Cell (0, 1) already taken
QGridLayoutEngine::addItem: Cell (0, 1) already taken
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:431:9: QML Flickable: Possible anchor loop detected on fill.
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:431:9: QML Flickable: Possible anchor loop detected on fill.
file:///usr/share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml:431:9: QML Flickable: Possible anchor loop detected on fill.
file:///usr/lib/kde4/imports/org/kde/homerun/components/TabButton.qml:161:5: QML QDeclarativeText_QML_81: Possible anchor loop detected on fill.
file:///usr/lib/kde4/imports/org/kde/homerun/components/TabButton.qml:161:5: QML QDeclarativeText_QML_81: Possible anchor loop detected on fill.
file:///usr/lib/kde4/imports/org/kde/homerun/components/TabButton.qml:161:5: QML QDeclarativeText_QML_81: Possible anchor loop detected on fill.
"/org/freedesktop/UDisks2/drives/SAMSUNG_HM641JI_S26XJ9BB925947" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/SAMSUNG_HM641JI_S26XJ9BB925947" : property "Device" does not exist 
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x2600071 

As in the output talk about homerun, I tried to compile again (kdeplasma-applets-homerun and kdeplasma-applets-homerun-git) and I got an error as seen in ~.xsession-errors
(Not sure if it is closely related with the issue)

 Scanning dependencies of target dirmodeltest_x11
[ 20%] Building CXX object tests/auto/CMakeFiles/dirmodeltest_x11.dir/dirmodeltest_x11_automoc.o
[ 20%] Linking CXX shared module ../lib/plasma_applet_homerunlauncher.so
Building CXX object tests/auto/CMakeFiles/dirmodeltest_x11.dir/dirmodeltest.o
[ 21%] Building CXX object shell/CMakeFiles/homerunviewer.dir/main.o                                                                    
[ 21%] Built target plasma_applet_homerunlauncher
Scanning dependencies of target favoriteappsmodeltest_x11
[ 22%] Building CXX object tests/auto/CMakeFiles/favoriteappsmodeltest_x11.dir/favoriteappsmodeltest_x11_automoc.o
[ 22%] Building CXX object tests/auto/CMakeFiles/favoriteappsmodeltest_x11.dir/favoriteappsmodeltest.o                                  
[ 23%] Building CXX object lib/CMakeFiles/homerun.dir/sourceconfigurationwidget.o                                                       
[ 23%] Building CXX object shell/CMakeFiles/homerunviewer.dir/homerunvieweradaptor.o                                                    
Linking CXX shared library libhomerun.so
[ 24%] Built target homerun
Scanning dependencies of target favoriteplacesmodeltest_x11
[ 25%] Building CXX object tests/auto/CMakeFiles/dirmodeltest_x11.dir/__/__/components/sources/dir/dirconfigurationwidget.o
[ 25%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/favoriteplacesmodeltest_x11_automoc.o                  
[ 26%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/favoriteplacesmodeltest.o                              
[ 27%] Building CXX object tests/auto/CMakeFiles/favoriteappsmodeltest_x11.dir/__/__/components/sources/favorites/favoriteappsmodel.o   
Linking CXX executable homerunviewer
/usr/lib/libQtWebKit.so.4: referencia a `g_type_class_adjust_private_offset' sin definir
collect2: error: ld devolvió el estado de salida 1
make[2]: *** [shell/homerunviewer] Error 1
make[1]: *** [shell/CMakeFiles/homerunviewer.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 28%] Building CXX object tests/auto/CMakeFiles/dirmodeltest_x11.dir/__/__/components/sources/dir/dirmodel.o
[ 28%] Building CXX object tests/auto/CMakeFiles/dirmodeltest_x11.dir/__/__/components/sources/favorites/favoriteutils.o                
[ 29%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/components/sources/dir/dirconfigurationwidget.o  
[ 30%] Building CXX object tests/auto/CMakeFiles/dirmodeltest_x11.dir/__/__/lib/abstractsource.o                                        
Linking CXX executable favoriteappsmodeltest_x11
[ 31%] Built target favoriteappsmodeltest_x11
[ 31%] Building CXX object tests/auto/CMakeFiles/dirmodeltest_x11.dir/__/__/lib/actionlist.o
[ 32%] Building CXX object tests/auto/CMakeFiles/dirmodeltest_x11.dir/__/__/lib/pathmodel.o                                             
[ 32%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/components/sources/dir/dirmodel.o                
[ 32%] Building CXX object tests/auto/CMakeFiles/dirmodeltest_x11.dir/__/__/lib/sourceconfigurationwidget.o                             
[ 33%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/components/sources/favorites/favoriteplacesmodel.o                                                                                                                                       
[ 33%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/components/sources/favorites/favoriteutils.o     
Linking CXX executable dirmodeltest_x11
[ 36%] Built target dirmodeltest_x11
[ 37%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/components/sources/favorites/fileplacesmodel.o
[ 37%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/components/sources/favorites/kfileplacesitem.o
[ 38%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/components/sources/favorites/kfileplacessharedbookmarks.o
[ 38%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/lib/abstractsource.o
[ 39%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/lib/actionlist.o
[ 39%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/lib/pathmodel.o
[ 40%] Building CXX object tests/auto/CMakeFiles/favoriteplacesmodeltest_x11.dir/__/__/lib/sourceconfigurationwidget.o
Linking CXX executable favoriteplacesmodeltest_x11
[ 46%] Built target favoriteplacesmodeltest_x11
make: *** [all] Error 2
==> ERROR: Se produjo un error en build().
    Cancelando...
==> ERROR: Makepkg no ha podido compilar kdeplasma-applets-homerun.
==> Reiniciar la compilación de kdeplasma-applets-homerun? [s/N]
==> ------------------------------------------------------------
==> 

Last edited by xpt (2013-10-20 07:08:09)

Offline

#42 2013-10-20 15:48:12

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [SOLVED] KDE not working, could not start ksmserver

Try uninstalling the homerun stuff to see if that resolves the issue.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#43 2013-10-20 18:24:25

xpt
Member
Registered: 2012-10-23
Posts: 53

Re: [SOLVED] KDE not working, could not start ksmserver

I uninstall homerun and still the same
I think it has to do with:

g_type_class_adjust_private_offset

appearing in pacman.log after upgrade gnome-desktop (also uninstall it) and too appearing when try to compile other packages like homerun, bamf, libdbusmenu, etc, etc

Offline

#44 2013-10-20 18:39:44

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [SOLVED] KDE not working, could not start ksmserver

I think those errors are from the update of librsvg. I have that library installed, too, but I don't have those errors in my logs. Have you tried reinstalling it?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#45 2013-10-20 18:43:02

xpt
Member
Registered: 2012-10-23
Posts: 53

Re: [SOLVED] KDE not working, could not start ksmserver

$LC_ALL=C yaourt -S librsvg
warning: librsvg-1:2.40.0-1 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Packages (1): librsvg-1:2.40.0-1

Total Installed Size:   0.50 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                                              [#####################################################] 100%
(1/1) checking package integrity                                                            [#####################################################] 100%
(1/1) loading package files                                                                 [#####################################################] 100%
(1/1) checking for file conflicts                                                           [#####################################################] 100%
(1/1) checking available disk space                                                         [#####################################################] 100%
(1/1) reinstalling librsvg                                                                  [#####################################################] 100%
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-icns.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-tga.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-ico.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-pnm.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-jasper.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-jpeg.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-qtif.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-xpm.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-wbmp.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: /usr/lib/libpango-1.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-bmp.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-xbm.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-ani.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-ras.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-tiff.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-gif.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-pcx.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset 

Offline

#46 2013-10-20 19:21:05

xpt
Member
Registered: 2012-10-23
Posts: 53

Re: [SOLVED] KDE not working, could not start ksmserver

SOLVED smile
I had installed glib2-ubuntu, I uninstalled and solved
Last time something similar happened to me to have AUR packages
thank you all for the help!

Offline

#47 2013-10-20 20:37:53

isacdaavid
Member
From: México
Registered: 2011-11-21
Posts: 76
Website

Re: [SOLVED] KDE not working, could not start ksmserver

I have filed this bug. I am no expert when it comes to .so bumps and dynamic libraries, but looking at your pacman outputs you all seem to have libreoffice installed, which is pulling icu 52.1 without retaining 51.2.

Offline

#48 2013-10-20 22:09:29

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [SOLVED] KDE not working, could not start ksmserver

isacdaavid wrote:

I have filed this bug. I am no expert when it comes to .so bumps and dynamic libraries, but looking at your pacman outputs you all seem to have libreoffice installed, which is pulling icu 52.1 without retaining 51.2.

I'm almost certain this is not a bug. At least, not that bug.

libreoffice opens fine here. Also, your bug ignores the fact that the errors about the library disappeared once the updated version of icu was moved to Extra and users installed it. I don't know why you get that error but I'm pretty sure it is not a bug in libreoffice. Do you have anything related installed from AUR? Is your system completely up to date?

EDIT:

$ ldd /usr/lib/libreoffice/program/soffice.bin  | grep icu
        libicuuc.so.52 => /usr/lib/libicuuc.so.52 (0x00007f34c244a000)
        libharfbuzz-icu.so.0 => /usr/lib/libharfbuzz-icu.so.0 (0x00007f34be05c000)
        libicule.so.52 => /usr/lib/libicule.so.52 (0x00007f34bdbb1000)
        libicudata.so.52 => /usr/lib/libicudata.so.52 (0x00007f34bb105000)

Does this command give you different output?

Last edited by cfr (2013-10-20 22:11:38)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#49 2013-10-20 23:44:17

isacdaavid
Member
From: México
Registered: 2011-11-21
Posts: 76
Website

Re: [SOLVED] KDE not working, could not start ksmserver

cfr wrote:

I'm almost certain this is not a bug. At least, not that bug.

libreoffice opens fine here. Also, your bug ignores the fact that the errors about the library disappeared once the updated version of icu was moved to Extra and users installed it. I don't know why you get that error but I'm pretty sure it is not a bug in libreoffice. Do you have anything related installed from AUR? Is your system completely up to date?

My system is updated and I'm using the latest icu. I've made several pacman -Syyus and mirror switches in the past 2 days in case something wasn't getting upgraded. My AUR stuff is minimal, more or less, and nothing suggests correlation with icu or libreoffice whatsoever:

└──>> pacman -Qm | wc -l && pacman -Qmi | grep "icu" | wc -l
25
0
cfr wrote:

EDIT:

$ ldd /usr/lib/libreoffice/program/soffice.bin  | grep icu
        libicuuc.so.52 => /usr/lib/libicuuc.so.52 (0x00007f34c244a000)
        libharfbuzz-icu.so.0 => /usr/lib/libharfbuzz-icu.so.0 (0x00007f34be05c000)
        libicule.so.52 => /usr/lib/libicule.so.52 (0x00007f34bdbb1000)
        libicudata.so.52 => /usr/lib/libicudata.so.52 (0x00007f34bb105000)

Does this command give you different output?

yes,  mine is linked to both icu 51.2 and 52.1. Don't ask me why

libicuuc.so.52 => /usr/lib/libicuuc.so.52 (0x00007f6a01b0b000)
libharfbuzz-icu.so.0 => /usr/lib/libharfbuzz-icu.so.0 (0x00007f69fd73b000)
libicule.so.52 => /usr/lib/libicule.so.52 (0x00007f69fd290000)
libicudata.so.52 => /usr/lib/libicudata.so.52 (0x00007f69fa800000)
libicuuc.so.51 => not found
libicudata.so.51 => not found

Offline

#50 2013-10-21 00:21:15

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [SOLVED] KDE not working, could not start ksmserver

Are you using 32 or 64 bit Arch? That's the only thing I can think since we should have identical binaries otherwise.

If so, I would add that information to the bug report with the output you posted above.

EDIT: Actually, I checked and the 32 bit libreoffice-common binary is not linked against the older version of the library either. So that is not it.

Can you check which package owns the binary?

Last edited by cfr (2013-10-21 00:31:42)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB