You are not logged in.

#1 2005-12-29 15:06:15

slackhack
Member
Registered: 2004-06-30
Posts: 738

[Solved] udev: no mouse or cam

i thought i had udev implemented correctly, but when i turned off hotplug, my USB mouse no longer worked and i couldn't access my camera. actually when i turned off hotplug from the OS, i also lost my USB keyboard, but if i boot without hotplug, i *have* the keyboard, but not the mouse or USB devices. so i guess udev must be working, but somehow my mouse and cam aren't configged properly? i thought the idea of udev was that you didn't need hotplug? :?:

Offline

#2 2005-12-29 18:52:33

Komodo
Member
From: Oxford, UK
Registered: 2005-11-03
Posts: 674

Re: [Solved] udev: no mouse or cam

I'd like to know what the problem is, since I don't really know a lot about the workings of udev... when I upgraded from hotplug, all my stuff worked flawlessly, fortunately.

I expect you've already consulted the wiki for aid, but if not, here's the udev section.


.oO Komodo Dave Oo.

Offline

#3 2005-12-29 20:35:25

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: [Solved] udev: no mouse or cam

that's what i used to upgrade. there's nothing there about mice though. the mice permissions in /etc/udev/rules.d/udev.rules are 0644, is that what they should be?

my xorg:
### logitech cordless optical
    Identifier  "USB Mice"
    Driver      "mouse"
    Option      "Protocol"    "IMPS/2"
    Option      "Device"      "/dev/input/mice"
    Option       "ZAxisMapping"      "4 5"
### end logitech

i added my user to the storage group, but i still can't access the cam anymore.  :x

fstab:

none                   /proc         proc      defaults            0      0
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0
tmpfs                  /tmp          tmpfs     defaults            0      0
usbfs               /proc/bus/usb usbfs  defaults            0      0

lilo.conf:

image=/boot/vmlinuz-2.6.14-ck5
        label=arch-ck5
        root=/dev/hda1
        read-only
        append="devfs=nomount video=matroxfb:vesa:0x18C"

i ran /sbin/udevstart, dbus/hal are running, but it still won't work. i must be missing something? when i kill hotplug, even the keyboard goes. luckily i had a ps2 kb to plug in to restart hotplug and get my mouse/kb back. tongue weird that the USB kb works if i boot with no hotplug, but it dies if i kill hotplug after booting. seems like that must be a clue. :?:

Offline

#4 2006-01-03 20:48:33

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: [Solved] udev: no mouse or cam

~bump!~

i didn't think it would come to this so soon, but now i can't upgrade because of the conflict. i've gotten around it for the moment by putting udev in the ignore list, but that's obviously not a good long-term solution. can anyone help me solve this?

[2] root:/home/sero # pacman -Syu
:: Synchronizing package databases... 
 current                  [################] 100%      48K    68.4K/s  00:00:00
 extra                    [################] 100%     228K   182.7K/s  00:00:01
:: xapps-20040920-1: ignoring package upgrade (to be replaced by xcompmgr-1.1.1-1)
:: kernel26-2.6.10-1: ignoring package upgrade (2.6.15-2)
:: Above packages will be skipped.  To manually upgrade use 'pacman -S <pkg>'
:: udev conflicts with hotplug. Remove hotplug? [Y/n] n

error: package conflicts detected


[3] root:/home/sero #

Offline

#5 2006-01-03 21:44:29

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,240

Re: [Solved] udev: no mouse or cam

your problems may be due to the version of archck you are using.

check these threads :
2.6.14-archck7

and     ArchCK - Current status and initrd/initramfs progress.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#6 2006-01-03 21:52:37

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: [Solved] udev: no mouse or cam

hmm, looks promising. i'm using my own kernel though, so what does that mean for my setup? will i have to abandon it and go with the arch kernel + ck patch (and initrd, which i don't use now) just to get udev to work? :?:

Offline

#7 2006-01-05 20:15:30

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: [Solved] udev: no mouse or cam

the more i think about it, the more it seems that can't be it. my mouse and cam work fine with this kernel and ck patch with hotplug, so how can it be the kernel? is there some special kernel requirement for udev? there's nothing in the wiki to indicate there is. :?:

Offline

#8 2006-01-08 00:51:20

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,240

Re: [Solved] udev: no mouse or cam

If i remember correctly in the latest udev a new group was added for camera users.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#9 2006-01-08 16:30:06

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: [Solved] udev: no mouse or cam

i checked and my user is added to the camera group (can't remember if i did that manually -- i guess i must have), still no luck. and that doesn't explain why the mouse won't work. i must be doing something wrong somewhere, but it's eluding me. i see the udev daemon start successfully on bootup, so it seems that there must be something wrong with my USB configuration or permission settings, right? or not? is there any way to check that, through dmesg, or checking the devices or something in the /proc directory etc. ?

thanks for your help on this, btw. i totally hate this dev stuff. i'd rather configure X on a hundred different machines than deal with this low level device crap. tongue

Offline

#10 2006-01-08 17:17:28

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: [Solved] udev: no mouse or cam

it sounds like you don't let the modules load either by loading them in MODULES=()
or enbable MOD_AUTOLOAD="yes"
or add hwd to DAEMON=()
MOD_AUTOLOAD="yes" is the default btw

Offline

#11 2006-01-08 18:39:40

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: [Solved] udev: no mouse or cam

hmm. i'm confused. i don't have MOD_AUTOLOAD in rc.conf, i only have a modules list. but you are saying that MOD_AUTOLOAD is the default? so then how can it be a modules problem if they're loading by default? :?:

Offline

#12 2006-01-08 19:46:32

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: [Solved] udev: no mouse or cam

take a look at rc.conf.pacnew there it is the default.
greetings
tpowa

Offline

#13 2006-01-08 21:38:31

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: [Solved] udev: no mouse or cam

okay, i thought you meant to autoload was the default behavior if it wasn't specified or included in the file. i'll try adding that option to my existing file and see what happens, thanks.


-------->
edit: with MOD_AUTOLOAD="yes" nothing works, not even keyboard. it didn't even work with hotplug enabled. so autoload is not autoloading something related to USB, apparently. what makes it even weirder is that the USB keyboard works with udev w/out autoloading. i wonder if i need some "evdev" module or something? i'm going to have to research it, i thought i had all the usb and mouse/kb, etc. modules i needed, but maybe i missed one. :?:

Offline

#14 2006-01-09 06:38:50

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: [Solved] udev: no mouse or cam

perhaps it's also the new kernel i have problems with usb mice here too, perhaps keyboards are also affected.
usbhid seems to have problems hmm

Offline

#15 2006-01-16 17:26:57

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: [Solved] udev: no mouse or cam

silly me, i commented out the MOD_AUTOLOAD and put hwd in the daemons instead, and now it's working. (unless i misunderstood that mod_autoload needs hwd? i thought it used hwdetect and didn't need any daemon.) anyway, now it's working, thanks for the replies, esp. tpowa. i see you pointed me in the right direction but i didn't get what you were saying. tongue

Offline

Board footer

Powered by FluxBB