You are not logged in.

#651 2013-10-28 13:47:54

jakobcreutzfeldt
Member
Registered: 2011-05-12
Posts: 1,033

Re: infinality-bundle: good looking fonts made (even) easier

donniezazen wrote:

@jakobcreutzfeldt How exactly have you solved Emacs box problem?

The suggestion by bohoomil worked fine for me:

(custom-set-faces
 '(bold ((t (:weight bold :family "Liberation Mono"))))
 '(variable-pitch ((t (:family "DejaVu Sans")))))

In fact, you probably only need the variable-pitch part.

Last edited by jakobcreutzfeldt (2013-10-28 13:48:23)

Offline

#652 2013-10-28 20:35:47

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

donniezazen wrote:

UPDATE:- I have removed infinality-bundle-fonts for now and Emacs seems to work fine with the above mentioned settings.

You don't have to do this. Instead of using this:

'(font-use-system-font t))

just set a default font and a variable pitch, like this:

'(default ((t (:family "Droid Sans Mono" :slant normal :weight regular :height 98 ))))
'(variable-pitch ((t (:family "Open Sans" :slant normal :weight regular :height 98 )))))

Try a different combination, e.g.:

'(default ((t (:family "TeXGyreCursor" :slant normal :weight regular :height 98 ))))
'(variable-pitch ((t (:family "TeXGyreHeros" :slant normal :weight regular :height 98 )))))

For some reason variable pitch can be set to anything but Noto Sans (or it's alias, which is Sans). I don't know why this particular typeface doesn't work correctly, so I'll have to look into it when I have some spare time. However, you still have a rich selection of typefaces to choose from, so there's no need going back to Arial only to avoid a simple reconfiguration of Emacs' defaults.

Last edited by bohoomil (2013-10-28 20:39:42)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#653 2013-10-29 04:19:18

donniezazen
Member
From: Salt Lake City
Registered: 2011-06-24
Posts: 671
Website

Re: infinality-bundle: good looking fonts made (even) easier

@boohomil Thank you very much, that did the trick.

Offline

#654 2013-10-29 18:20:46

Grima
Member
Registered: 2011-09-02
Posts: 58

Re: infinality-bundle: good looking fonts made (even) easier

First of all, thanks a lot for your infinality packages. They really do improve how the fonts look, and I've been using the infinality-bundle for some time now.

But yesterday, I decided to update my machine. I followed your instructions by removing the fontconfig package and then installing it again. Afterwards, I ran fc-presets since I wanted the settings that I've been accustomed to. So far, so good.

However, I've noticed some changes after the update, even though I thought I'd have the same settings as before. Here is an example:

OLp2Eh9l.png

The bold font seems normal, but the body text is larger and more "spacious". I have a harder time reading the right article than the left.

Is this "larger and more spacious" by design?

Also, another "issue" that arose after the update is that the url text in Chromium keeps jumping up and down while you type. The url isn't centered in the textbox either, as it was before the update. Strange.

Offline

#655 2013-10-29 20:13:01

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: infinality-bundle: good looking fonts made (even) easier

Also, another "issue" that arose after the update is that the url text in Chromium keeps jumping up and down while you type. The url isn't centered in the textbox either, as it was before the update. Strange.

I experienced the same. Make sure that in your settings you are using the GTK theme.

Offline

#656 2013-10-29 20:15:21

brebs
Member
Registered: 2007-04-03
Posts: 3,427

Re: infinality-bundle: good looking fonts made (even) easier

Grima wrote:

but the body text is larger and more "spacious"

It looks like a different font. E.g. the quotes are smaller on the bigger font.

Offline

#657 2013-10-29 22:03:58

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

@Grima, I too have the impression that it may not be the same font in both screenshots. This is what I can see when I load the site: click (and the entire browser area: click). Please, check the output of

$ fc-match Georgia
georgia.ttf:  "Georgia" "Regular"

The other issue you should be able to resolve following orschiro's advice.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#658 2013-10-29 22:11:21

el mariachi
Member
Registered: 2007-11-30
Posts: 588

Re: infinality-bundle: good looking fonts made (even) easier

is this right?

fc-match Georgia
LibreBaskerville-Regular.otf: "Libre Baskerville" "Regular"

I also feel fonts in my favourite newspaper's website increased (although it's not that much of a problem for me) (www.publico.pt)

Offline

#659 2013-10-29 22:16:02

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

el mariachi, Right, if you are using infinality-bundle-fonts. smile If you want to switch to M$ stuff, issue

# fc-presets set

and hit '2'.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#660 2013-10-29 22:25:18

el mariachi
Member
Registered: 2007-11-30
Posts: 588

Re: infinality-bundle: good looking fonts made (even) easier

I'm a happy MS-fonts free user wink thanks hehe

Offline

#661 2013-10-30 03:44:55

Grima
Member
Registered: 2011-09-02
Posts: 58

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:

@Grima, I too have the impression that it may not be the same font in both screenshots. This is what I can see when I load the site: click (and the entire browser area: click). Please, check the output of

$ fc-match Georgia
georgia.ttf:  "Georgia" "Regular"

The other issue you should be able to resolve following orschiro's advice.

You are right! It is not the same font:

$ fc-match Georgia
b018012l.pfb: "URW Bookman L" "Light"

Weird. How can I fix this?

The Chromium URL issue no longer remains after choosing to use the GTK theme. (I thought I was using it, but apparently not!)

Offline

#662 2013-10-30 03:46:39

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: infinality-bundle: good looking fonts made (even) easier

Mine matches your Grima...

Should this not be the case bohoomil?

Offline

#663 2013-10-30 04:15:13

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Grima wrote:

Weird. How can I fix this?

Do you guys happen to read this f***ing thread? Grrr… tongue

bohoomil wrote:

el mariachi, Right, if you are using infinality-bundle-fonts. smile If you want to switch to M$ stuff, issue

# fc-presets set

and hit '2'.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#664 2013-10-30 04:26:23

Grima
Member
Registered: 2011-09-02
Posts: 58

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:
Grima wrote:

Weird. How can I fix this?

Do you guys happen to read this f***ing thread? Grrr… tongue

bohoomil wrote:

el mariachi, Right, if you are using infinality-bundle-fonts. smile If you want to switch to M$ stuff, issue

# fc-presets set

and hit '2'.

And that's what I did after I updated the packages. That is what I meant by "Afterwards, I ran fc-presets ..." in my original post.

I'll try re-running fc-presets again within the hour to see if it works this time. To be continued...

Offline

#665 2013-10-30 04:36:25

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

And do you really have MS fonts installed then? Do you have the following symlinks in your /etc/fonts/conf.d (except quite a few others, of course)?

37-repl-global-ms.conf
60-latin-ms.conf
65-non-latin-ms.conf
66-aliases-wine-ms.conf
93-final-lang-spec-ms.conf

If you do have both, it's impossible you can't set MS fonts as your defaults. I switched to proprietary ones in a second, just to check if everything was OK to respond to your post, so even if you have both collections, you can use any you wish just by selecting a default set via 'fc-presets'.

Edit: I even didn't restart the X, just reloaded FF. I swear.

Last edited by bohoomil (2013-10-30 04:39:45)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#666 2013-10-30 04:44:28

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: infinality-bundle: good looking fonts made (even) easier

Ooohhh, sorry.  For some reason I thought that Georgia should be georgia.ttf with your free fonts... but now I realize that Georgia is not a free font.  Sorry for the noise.


Edit: BTW, your two threads are the only two that I think I actually do read every post.

Last edited by WonderWoofy (2013-10-30 04:45:31)

Offline

#667 2013-10-30 04:59:38

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Thanks a bunch, I truly appreciate it. I hope we will be able to find the missing link in the OP's issue, whatever its name can be (PEBKAC?)… wink


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#668 2013-10-30 05:28:21

Grima
Member
Registered: 2011-09-02
Posts: 58

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:

And do you really have MS fonts installed then? Do you have the following symlinks in your /etc/fonts/conf.d (except quite a few others, of course)?

37-repl-global-ms.conf
60-latin-ms.conf
65-non-latin-ms.conf
66-aliases-wine-ms.conf
93-final-lang-spec-ms.conf

If you do have both, it's impossible you can't set MS fonts as your defaults. I switched to proprietary ones in a second, just to check if everything was OK to respond to your post, so even if you have both collections, you can use any you wish just by selecting a default set via 'fc-presets'.

Edit: I even didn't restart the X, just reloaded FF. I swear.

Yeah, I have all the Microsoft fonts installed. The symlinks were also in place.

I re-ran fc-presets and selected "ms" again, but it didn't work. I then tried selecting "custom" just to switch settings, and then "ms" again. This time around it worked. I've got no clue as to why I had to do this though, but at least the problem is solved.

An odd thing I might mention is that when I tried the approach "switch to a different profile and then back to MS", I first tried [ms ->] free -> ms, but that didn't work! It was after I tried [ms ->] custom -> ms I could see georgia.ttf being used.

Once again, thanks for your work and time! smile

Offline

#669 2013-10-31 02:20:28

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle: good looking fonts made (even) easier

I just thought I would mention that I had some issues updating today. First, pacman couldn't download some package it wanted from your repos. Then it complained about conflicting files in /etc/fonts/conf.d. Basically, it complained about the 65-ttf-noto* files and possibly 60-latin-free but I'm not certain of the latter.

I deleted all unowned symlinks in /etc/fonts/conf.d which are not my own making (basically everything except something for TeX fonts) and reran the update. (For some reason, I could then only get pacman to do anything at all by passing it the verbose option though I have no clue why - I only passed it to try to figure out the problem.) Obviously this wasn't the ideal thing to do so the issue is of my own making (though my fonts look just the same - possibly because I have preferences set somewhere for droid). However, I thought that it would be helpful if fc-presets check could say something in the situation where it finds no symbolic links at all. Right now it produces no output - no error and no message.

<rant>Also, I personally don't think the script itself should insist on root privileges. Not only does this mean you need privileges even to check the current preset or read the help, but it seems quite unnecessary. Only if the sys admin has decided otherwise could the script write new defaults without privileges. The system itself enforces that. I don't think scripts and programmes should unnecessarily override local security configurations which is essentially what this does.</rant>

Last edited by cfr (2013-10-31 02:21:02)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#670 2013-10-31 02:40:22

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: infinality-bundle: good looking fonts made (even) easier

@cfr, I think that those symlinks are not provided by the font itself (so that if it is installed it will be enabled).  Because of this, in bohoomil's other thread, there are instructions to --force the noto-sans packages.

Offline

#671 2013-10-31 03:05:24

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle: good looking fonts made (even) easier

WonderWoofy wrote:

@cfr, I think that those symlinks are not provided by the font itself (so that if it is installed it will be enabled).  Because of this, in bohoomil's other thread, there are instructions to --force the noto-sans packages.

Yes. Thanks. I actually just saw that - too late, of course.

I am happy to say I shouldn't have deleted them. I still think it would be helpful if fc-preset check would say something. Not the least benefit of error messages is that they often indicate where I've screwed up!


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#672 2013-10-31 18:15:00

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

cfr wrote:

I still think it would be helpful if fc-preset check would say something. Not the least benefit of error messages is that they often indicate where I've screwed up!

This is on the 'Ooops' side: obviously a missing feature in the 'check' parameter. I'll modify the script and rethink the privilege matter as well. Thanks for reporting.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#673 2013-10-31 22:45:15

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:

This is on the 'Ooops' side...

Oh, I see. Sorry - I didn't mean to make a thing about it. It isn't always obvious what people will think is "obviously" a missing feature and what they thought unnecessary on the grounds that people shouldn't do dumb things!


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#674 2013-11-01 08:54:03

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: infinality-bundle: good looking fonts made (even) easier

@bohoomil

I am not entirely sure whether my issue with bold fonts is related to the free font collection or the infinality-bundle.

However, my bold fonts in the web browser are hard to read: http://i.imgur.com/t6VQm2n.png

I use the recommended free fonts in Chromium:

http://i.imgur.com/W3AHKyu.png

and

http://i.imgur.com/dmjIbAM.png

Any idea what is causing the bold font issue?

Offline

#675 2013-11-01 17:56:58

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

This is a known Chromium issue. Paste this

<match target="pattern">
    <edit name="dpi" mode="assign">
      <double>72</double>
    </edit>
</match>

in either $HOME/.config/fontconfig/fonts.conf or /etc/fonts/fonts.conf.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

Board footer

Powered by FluxBB