You are not logged in.

#1 2013-10-31 01:02:00

Gradient
Member
Registered: 2013-05-19
Posts: 87

Why is webkitgtk2 package staying at version 1.10.2?

Why isn't is updated to a newer versions? Is there something not working with Gtk2 in newer versions?

Offline

#2 2013-10-31 01:06:45

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: Why is webkitgtk2 package staying at version 1.10.2?

It isn't even marked out of date.
Can you please link to the new upstream release?


There's also webkitgtk package https://www.archlinux.org/packages/?name=webkitgtk - maybe you mixed them up (I often do).

Last edited by karol (2013-10-31 01:07:12)

Offline

#3 2013-10-31 01:13:46

Gradient
Member
Registered: 2013-05-19
Posts: 87

Re: Why is webkitgtk2 package staying at version 1.10.2?

What is the difference between them besides webkitgtk depending on gtk3 and webkitgtk2 depending on gtk2? In fact, I don't understand why they don't have the same version.

Last edited by Gradient (2013-10-31 01:17:16)

Offline

#4 2013-10-31 01:18:16

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: Why is webkitgtk2 package staying at version 1.10.2?

I know nothing about them ;P
https://projects.archlinux.org/svntogit … /webkitgtk
https://projects.archlinux.org/svntogit … webkitgtk2

Edit:

Gradient wrote:

I don't understand why they don't have the same version.

If I get it right, webkitgtk2 is a legacy version.

Last edited by karol (2013-10-31 01:23:33)

Offline

#5 2013-10-31 02:00:54

brebs
Member
Registered: 2007-04-03
Posts: 3,408

Re: Why is webkitgtk2 package staying at version 1.10.2?

webkitgtk2 will work with gtk2 apps (as opposed to gtk3), for e.g. claws-mail and midori.

I use webkit 2.2.1 (it seems to be nicely backwards-compatible), so I suggest you ask for that version in Arch.

Last edited by brebs (2013-10-31 02:02:45)

Offline

#6 2013-10-31 02:45:53

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,378
Website

Re: Why is webkitgtk2 package staying at version 1.10.2?

Isn't there gstreamer compatibility issues?

Offline

#7 2013-10-31 03:28:02

brebs
Member
Registered: 2007-04-03
Posts: 3,408

Re: Why is webkitgtk2 package staying at version 1.10.2?

I haven't used gstreamer through webkit, but it seemed to compile OK with gstreamer 1.0.10 - some snippets from webkit's compilation:

checking for GSTREAMER... yes

  CXX      Source/WebCore/platform/graphics/gstreamer/libPlatformGtk_la-GStreamerGWorld.lo
  CXX      Source/WebCore/platform/graphics/gstreamer/libPlatformGtk_la-ImageGStreamerCairo.lo
  CXX      Source/WebCore/platform/graphics/gstreamer/libPlatformGtk_la-PlatformVideoWindowGtk.lo
  CXX      Source/WebCore/platform/graphics/gstreamer/libPlatformGtk_la-VideoSinkGStreamer.lo

Offline

#8 2013-10-31 03:29:37

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,800

Re: Why is webkitgtk2 package staying at version 1.10.2?

The minimum system requirements for WebkitGTK 2.0+ are GTK+ 3.6 or greater. That's why the regular webkitgtk package depends on gtk3 and there is a legacy version that uses the last release compatible with GTK+ 2.

Offline

#9 2013-10-31 03:30:44

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: Why is webkitgtk2 package staying at version 1.10.2?

brebs wrote:

I haven't used gstreamer through webkit, but it seemed to compile OK with gstreamer 1.0.10 - some snippets from webkit's compilation:

checking for GSTREAMER... yes

  CXX      Source/WebCore/platform/graphics/gstreamer/libPlatformGtk_la-GStreamerGWorld.lo
  CXX      Source/WebCore/platform/graphics/gstreamer/libPlatformGtk_la-ImageGStreamerCairo.lo
  CXX      Source/WebCore/platform/graphics/gstreamer/libPlatformGtk_la-PlatformVideoWindowGtk.lo
  CXX      Source/WebCore/platform/graphics/gstreamer/libPlatformGtk_la-VideoSinkGStreamer.lo

Which makes it incompatible with a lot of gtk2 apps that still require gstreamer0.10... Or at least inconvenient.

Last edited by skottish (2013-10-31 03:31:36)

Offline

Board footer

Powered by FluxBB