You are not logged in.

#1 2013-11-05 17:49:44

pelpix
Member
Registered: 2013-07-06
Posts: 23

[SOLVED] E18 Segfaults on even the slightest hint of OpenGL

I've had this problem for about 4 months and I'm really sick of it.  All of the sudden, out of nowhere, after no change in graphics driver version, all versions of E18 do this--even versions that worked before.  It happens on both OSS and proprietary AMD drivers and even continues to happen with a full format and re-install of Arch.  The problem is that E18 segfaults whenever calling OpenGL in any way, shape, or form.  It segfaults during the initial setup.  After configuring manually to use software rendering, it segfaults every tme I set the composite engine to OpenGL.  It's really infuriating.

On top of that, it doesn't dump any telling logs even in debug mode.

Ideas?

Last edited by pelpix (2013-11-05 23:56:28)

Offline

#2 2013-11-05 17:59:15

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,984

Re: [SOLVED] E18 Segfaults on even the slightest hint of OpenGL

Just to clarify, we're talking about Enlightenment 0.17.99 (or now 0.18-alpha1)? If you have GDB installed, it should create a backtrace at ~/.e-crashdump.txt

Offline

#3 2013-11-05 18:06:37

pelpix
Member
Registered: 2013-07-06
Posts: 23

Re: [SOLVED] E18 Segfaults on even the slightest hint of OpenGL

Scimmia wrote:

Just to clarify, we're talking about Enlightenment 0.17.99 (or now 0.18-alpha1)? If you have GDB installed, it should create a backtrace at ~/.e-crashdump.txt

Yep.
I compiled it with GDB support and have GDB installed, but it hangs.  ~/.e-crashdump.txt is created, but it's completely blank.

Hey, there was a commit just an hour ago:

wsod: Fixed gdb hangs when generating backtraces

Perhaps this will fix my problem with the logs?  Time to test!

Last edited by pelpix (2013-11-05 18:12:20)

Offline

#4 2013-11-05 18:16:37

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,984

Re: [SOLVED] E18 Segfaults on even the slightest hint of OpenGL

Possibly, but it was more about the whole thing hanging and never showing the wsod than generating no backtrace. Worth a shot though.

Offline

#5 2013-11-05 20:41:35

pelpix
Member
Registered: 2013-07-06
Posts: 23

Re: [SOLVED] E18 Segfaults on even the slightest hint of OpenGL

Curiouser and Curiouser!  I have the white screen, but when I gdb into E, there's no sigseg anywhere!  By all means, the white screen was never called, but there it is!  It stops cold on "managing roots." before even starting the E session, without even an error or warning!

Last edited by pelpix (2013-11-05 22:10:49)

Offline

#6 2013-11-05 23:56:01

pelpix
Member
Registered: 2013-07-06
Posts: 23

Re: [SOLVED] E18 Segfaults on even the slightest hint of OpenGL

WAYLAND SUPPORT is what's causing it to crash! I figured it out! Disabled Wayland in E, EFL, and Elementary. Now it boots up without any SEGV's like there was never any problem at all!

Offline

#7 2013-11-06 00:04:29

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] E18 Segfaults on even the slightest hint of OpenGL

You should file a bug report over this.  I think this warrants one in both the archlinux bugtracker as well as to upstream.

Offline

#8 2013-11-06 07:41:39

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,984

Re: [SOLVED] E18 Segfaults on even the slightest hint of OpenGL

@WW; this is in a -git AUR package, not the repos so it doesn't make sense to file it in the Arch bugtracker.

@pelpix; were you ever able to generate a backtrace? I'd be interested in seeing just where it's happening, and I'm sure they'd be interested upstream as well. They're preparing to release to release EFL 1.8/E 0.18 on Dec 1 and a consistent segv is something to look into.

Last edited by Scimmia (2013-11-06 07:42:20)

Offline

#9 2013-11-06 18:59:10

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] E18 Segfaults on even the slightest hint of OpenGL

@Scimmia, ah so it is.  My bad.  I see now that it is e17 that is in the official repos.  Sorry for the noise in that regard.

Offline

#10 2013-11-06 19:24:22

pelpix
Member
Registered: 2013-07-06
Posts: 23

Re: [SOLVED] E18 Segfaults on even the slightest hint of OpenGL

Scimmia wrote:

@WW; this is in a -git AUR package, not the repos so it doesn't make sense to file it in the Arch bugtracker.

@pelpix; were you ever able to generate a backtrace? I'd be interested in seeing just where it's happening, and I'm sure they'd be interested upstream as well. They're preparing to release to release EFL 1.8/E 0.18 on Dec 1 and a consistent segv is something to look into.

The fact that working E18 builds were retroactively broken recently makes me think it may be some change or error in Arch's official versions of the dependencies, though.
Also, I could generate a backtrace, but it just...stopped.  No error.  The process just crashed, without even signalling that the E SEGV is being called.  It just freezes solid with no indication of what or where the error is.

Last edited by pelpix (2013-11-06 19:24:55)

Offline

#11 2013-11-07 05:40:53

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,984

Re: [SOLVED] E18 Segfaults on even the slightest hint of OpenGL

With everything up to date, everything should be pretty stable, even with wayland client support. E has actually been in a feature freeze for months and it's stabilized very well in that time for me and most people I've talked to.

I'm not sure what you mean you could generate a backtrace but it stopped. E should generate the backtrace itself whenever it crashes. Is E locking up?

Offline

Board footer

Powered by FluxBB