You are not logged in.

#1 2013-10-28 15:02:13

Visp
Member
From: Valencia (Spain)
Registered: 2013-03-02
Posts: 11

Disable F1 (Yelp) in Gnome 3.10.1

Hi!

How i can disable totally F1 (Yelp) in Gnome 3.10.1?

I try to disable F1 to assign a new shortcut on this button. But i need disable the help for this.


Thanks!


Visp

Offline

#2 2013-10-28 16:36:49

haaja
Member
Registered: 2011-03-30
Posts: 20
Website

Re: Disable F1 (Yelp) in Gnome 3.10.1

Gnome Settings -> Keyboard -> Shortcuts tab -> Launchers -> Launch help browser. Click launch help browser and press backspace and shortcut should turn to Disabled. Unfortunately many applications have their own help browsers bound to F1 key such as gnome-terminal. Gnome-terminal settings will allow you to disable the shortcut.

Offline

#3 2013-10-28 18:54:25

Visp
Member
From: Valencia (Spain)
Registered: 2013-03-02
Posts: 11

Re: Disable F1 (Yelp) in Gnome 3.10.1

Hi haaja,

"Launch help browser" is already disabled. But i can't assign F1 to new shortcut because this button open the help.

http://i.imgur.com/DMhlaba.png



Thanks!

Offline

#4 2013-11-08 13:00:21

Visp
Member
From: Valencia (Spain)
Registered: 2013-03-02
Posts: 11

Re: Disable F1 (Yelp) in Gnome 3.10.1

Anybody can help me? sad

Offline

#5 2013-11-08 13:08:50

haaja
Member
Registered: 2011-03-30
Posts: 20
Website

Re: Disable F1 (Yelp) in Gnome 3.10.1

Sorry, I completely forgot this thread. sad You are right the F1 key cannot be reassigned using the keyboard settings. It works for other key combinations though. Without going trough the source code I guess it's hard coded somewhere.

Offline

#6 2013-11-09 00:46:22

scatterplot
Member
Registered: 2013-10-15
Posts: 17

Re: Disable F1 (Yelp) in Gnome 3.10.1

I'm not sure F1 is hard-coded because tilda uses that by default to drop down the terminal. Which by the way, I happen to find extremely useful.


Load"*",8,1

Offline

Board footer

Powered by FluxBB