You are not logged in.

#1 2013-06-26 08:52:56

Potomac
Member
Registered: 2011-12-25
Posts: 507

[grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

Hello,

today I did a "pacman -Syu", grub was updated ( replaced by core/grub )

the update was ok, no problem,

but I notice now a quick error message during the boot process :

error: file '/boot/grub/locale/fr.gmo' not found

then the boot menu is displayed and I can boot arch linux without problem,

when I check the directory /boot/grub/locale/ I see no files, that's why I have this error message,

I use the MBR for booting grub and I have a pentium 4 laptop,

I try to reinstall grub :

grub-install --recheck /dev/sda

but I still have the same error message on boot,

the wiki says that "grub.mo" file is in /usr/share/locale/en@quot/LC_MESSAGES/ but I see no "grub.mo", no "fr.mo" in this directory, so I can not copy these files to  /boot/grub/locale/,

so I think there is a bug in grub package, missing "*.mo" files, because before this update I never had this error message

Last edited by Potomac (2013-06-26 09:29:55)

Offline

#2 2013-06-26 08:54:34

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,100
Website

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

Bug report?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3 2013-06-26 08:55:42

Potomac
Member
Registered: 2011-12-25
Posts: 507

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

You think I must create a bug report ?

edit: I have just created a bug report :

https://bugs.archlinux.org/task/35937?p … &sort=desc

Last edited by Potomac (2013-06-26 09:13:42)

Offline

#4 2013-06-26 11:16:33

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,100
Website

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

The bug report will get your observation into the hands of the packager who might otherwise miss it if he/she didn't read your thread.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#5 2013-06-27 07:08:15

aja
Member
Registered: 2013-06-27
Posts: 23

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

You can do like this and error goes away

cp /usr/share/locale/en_US/LC_MESSAGES/mit-krb5.mo /boot/grub/locale/en.gmo

Offline

#6 2013-06-27 07:46:00

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,100
Website

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

https://bugs.archlinux.org/task/35937

Packager to the rescue; the system works ;p


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#7 2013-08-14 09:17:05

MickeyKnox
Member
Registered: 2010-02-27
Posts: 156

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

@Potomac: Did the error message go away yet?
I'm still having a similar error message.

Offline

#8 2013-08-23 20:43:47

hamelg
Member
From: France
Registered: 2008-06-19
Posts: 118

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

It depends your locale setup : see /etc/grub.d/00_header

The simplest workaround might be to add
  LANG=C
to /etc/default/grub before generating grub.cfg.

https://bugzilla.redhat.com/show_bug.cgi?id=817187#c42

Offline

#9 2013-11-14 05:53:21

bpont
Banned
Registered: 2010-03-24
Posts: 161

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

graysky wrote:

https://bugs.archlinux.org/task/35937

Packager to the rescue; the system works ;p

Should be reopened, bug still present in 2.00.5086-1

e0kjv9.png

Last edited by bpont (2013-11-15 22:46:52)

Offline

#10 2013-11-14 08:51:57

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,100
Website

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

@bpont - So as that the bug be reopened... are you use your installed the new grub to your mbr and not just installed the new grub package?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#11 2013-11-14 09:03:25

bpont
Banned
Registered: 2010-03-24
Posts: 161

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

graysky wrote:

@bpont - So as that the bug be reopened... are you use your installed the new grub to your mbr and not just installed the new grub package?

It was a new install from archlinux-2013.11.01-dual.iso:

archlinux-2013_11_01-dual_iso/arch/pkglist.i686.txt

  core/grub-2.00.5086-1

Offline

#12 2013-11-14 09:10:10

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,100
Website

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

Then request a reopen; no need to post here.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#13 2013-11-14 15:15:13

bpont
Banned
Registered: 2010-03-24
Posts: 161

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

graysky wrote:

Then request a reopen; no need to post here.

Sure there is.  I found this thread by searching for a solution.  New problems should be documented in forums, not only bug trackers.  I already chatted with phcoder and supposedly it's being handled upstream; commit id: 6cd660435ec32266db31e2fe65fbc3997379cbd2

Offline

#14 2013-11-15 00:14:43

Potomac
Member
Registered: 2011-12-25
Posts: 507

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

bpont wrote:
graysky wrote:

https://bugs.archlinux.org/task/35937

Packager to the rescue; the system works ;p

Should be reopened, bug still present in 2.00.5086-1

http://i44.tinypic.com/27y1jev.jpg

you probably forgot to finish the installation of grub,

you must type some instructions in the console like "grub-install --recheck /dev/sdX" ( where X is the partition where grub is installed ), read the wiki :

https://wiki.archlinux.org/index.php/Grub#Installation

Offline

#15 2013-11-15 01:50:55

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 1,022

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

no no no no, This was a bug due to lack of .mo files in /boot/grub/locale
maybe copyn one of the grub.mo files there whit the correct name can fix the problem


Well, I suppose that this is somekind of signature, no?

Offline

#16 2013-11-15 17:37:34

bpont
Banned
Registered: 2010-03-24
Posts: 161

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

Potomac wrote:
bpont wrote:
graysky wrote:

https://bugs.archlinux.org/task/35937

Packager to the rescue; the system works ;p

Should be reopened, bug still present in 2.00.5086-1

http://i44.tinypic.com/27y1jev.jpg

you probably forgot to finish the installation of grub,

you must type some instructions in the console like "grub-install --recheck /dev/sdX" ( where X is the partition where grub is installed ), read the wiki :

https://wiki.archlinux.org/index.php/Grub#Installation

Read up-thread.  I didn't forget anything and there's no need to read the wiki.  These were two fresh installs on two different systems using the most current arch install discs.  There was no previous installation to upgrade from and I didn't forget to add the --recheck option either.  My previous post stands...grub is simply looking for a file that doesn't exist.  Both systems I installed on have the same modules listed:

142v5u9_th.jpg

I'd rather not hack around the problem, since it still boots normally.  I'll wait for upstream to correct this bug.

Last edited by bpont (2013-11-15 22:42:48)

Offline

#17 2013-11-15 18:05:30

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

bpont wrote:

I'd rather not hack around the problem, since it still boots normally.  I'll wait for upstream to correct this bug.

This bug has been corrected in upstream -git repo http://git.savannah.gnu.org/cgit/grub.g … 997379cbd2 . If you want you can use https://aur.archlinux.org/packages/grub-git/ .

Offline

#18 2015-06-20 08:30:31

fabioamd87
Member
Registered: 2008-11-22
Posts: 125

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/

I still have this error, does I need a specific package?

Offline

#19 2015-06-20 09:17:43

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,049
Website

Re: [grub2] Missing "*.gmo" "*.mo" files in /boot/grub/locale/


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB