You are not logged in.

#1 2013-11-28 01:45:30

cryptxero
Member
Registered: 2013-11-28
Posts: 2

choppy video in openbox

okay, so i installed arch on my new laptop which has a intel integrated gpu. my video playback under vlc and mplayer is a little choppy (small horizontal tears) when i am in openbox, if i play video in cinnamon, however, the video is fine... any ideas?
thanks

Offline

#2 2013-11-28 04:00:48

Roberth
Member
From: Norway
Registered: 2007-01-12
Posts: 887

Re: choppy video in openbox

This is most likely caused by openbox having no compositor, which normally provides vsync, you can use compton as a compositor which gives you vsync.

I don't know if compton has vsync enabled, but you can enable it if it isn't through .compton.conf in your home folder.

https://wiki.archlinux.org/index.php/Compton


Use the Source, Luke!

Offline

#3 2013-11-29 02:17:32

cryptxero
Member
Registered: 2013-11-28
Posts: 2

Re: choppy video in openbox

Roberth wrote:

This is most likely caused by openbox having no compositor, which normally provides vsync, you can use compton as a compositor which gives you vsync.

I don't know if compton has vsync enabled, but you can enable it if it isn't through .compton.conf in your home folder.

https://wiki.archlinux.org/index.php/Compton


well this is when it says in the vsync part of my compton config
refresh-rate = 0;        # For --sw-opti: Specify refresh rate of the screen. 0 for auto.
vsync = "none";            # "none", "drm", "opengl", "opengl-oml", "opengl-swc", "opengl-mswc"

and i have this command in my OB autostart
compton --config ~/.compton.conf -b &

Offline

Board footer

Powered by FluxBB