You are not logged in.

#1 2013-11-30 07:51:06

Registered: 2012-08-23
Posts: 14

Keyboard and Mouse frozen in second X server

Hey folks,

I am using the script provided in the Gaming article on the Wiki to play games in a second X server.

Now I recently discovered that whenever I open up anything in the second x server I get no input from neither keyboard nor mouse. However I see visible output on the server.
I checked the logs already but it didn't provide anything of use. I'm really curious if there might be a solution to this problem.

Since I have a "weird" dual head setup using a second X server is the only possible way for me to enjoy gaming.

Thanks in advance

Last edited by szt (2013-12-19 16:39:09)


#2 2013-12-19 16:38:13

Registered: 2012-08-23
Posts: 14

Re: Keyboard and Mouse frozen in second X server


I have now changed to the lts kernel just to check if things may get better. And yes they did. I can now escape from X by using Alt+SysRQ+K. That allows me to at least get back to my original X Server. Back on stock kernel, this did not work because it crashed the whole visual output why so ever.

Anyhow if I start the 2nd X Server again it's just a roll of the dice wether I can move my mouse and type text or not. I've checked the logs multiple times. Even the kernel.log and error.log. There were no errors at all.

Here are my specs

550W PSU
Mainboard GA-970-UD3
CPU AMD Phenom II X4 965
GPU nVidia GTX 550 Ti
Samsung SSD 830
An old playstation3 HDD with 40 GiB
An even older HDD SAMSUNG SP2504C
Just some ordinary Mouse and Keyboard

Here goes my nvidia xorg conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildmeister@swio-display-x86-rhel47-05)  Wed Oct 30 18:20:32 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "HannStar Display Corp HU196D"
    HorizSync       30.0 - 80.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 550 Ti"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DVI-I-1: nvidia-auto-select +1920+580, HDMI-0: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

As you can see I am explicitly disabling Xinerama as the wiki said it is broken. This config was auto-generated by nvidia-settings.

Here is the xorg.log:

starting /home/szt/bin/startsteam

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/devastator:1
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X.Org X Server 1.14.5
Release Date: 2013-12-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.12.5-1-ARCH x86_64 
Current Operating System: Linux devastator 3.10.24-1-lts #1 SMP Thu Dec 12 16:45:57 CET 2013 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-linux-lts root=UUID=8e41b9f3-9303-46dc-b11c-31ed322d0f0f rw cryptdevice=/dev/disk/by-uuid/a59de50e-bd0e-4871-884f-7541cce6100e:root:allow-discards ipv6.disable=1 quiet
Build Date: 13 December 2013  03:11:42PM
Current version of pixman: 0.32.4
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Thu Dec 19 17:14:40 2013
(==) Using config directory: "/etc/X11/xorg.conf.d"
setversion 1.4 failed
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
Loading extension NV-GLX
Loading extension NV-CONTROL
Loading extension XINERAMA
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
setversion 1.4 failed
Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically

And here are the contents of startsteam:


# And open a terminal as always
xfce4-terminal &

# Start steam and resolution in background

And here is the content of the game script (it's the one from the wiki):


if [ $# -ge 1 ]; then
  game="`which $1`"
  openbox="`which openbox`"
  echo -e "${openbox} &\n${game}" > ${tmpgame}
  echo "starting ${game}"
  xinit ${tmpgame} -- :1 || exit 1
  echo "not a valid argument"

I also couldn't find any hint to this bug on the web. I'd be so happy if someone could help me with this. It's really annoying.


Now I tried the following thing. I started a second X instance using sudo and suddenly I get keyboard and mouse working perfectly. But as far as I know X does not need any special permissions to use keyboard and mice.

Last edited by szt (2013-12-19 23:00:43)


#3 2014-01-01 16:32:47

Registered: 2012-08-23
Posts: 14

Re: Keyboard and Mouse frozen in second X server


Thanks to the people from the IRC I now found out that I have to supply the VT I am currently on to startx to make sure the permission are set up right. Now after doing that I get the following output:


It seems like the VT is INSIDE my X Screen. But everything seems to run normal. If I switch VT by using Ctrl+Alt+Fx I can see that the black bar is changing. Though I keep being on my X screen.
I have totally no idea what to do to solve this. All I know is that this worked back in the days. Half a year ago or so.

I really hope someone has at least a clue what I'm doing wrong or what's wrongly configured.

Thanks in advance



#4 2014-01-01 22:04:11

From: Cologne
Registered: 2014-01-01
Posts: 4

Re: Keyboard and Mouse frozen in second X server

problem is fixed now.

just told him to add

xhost +localhost

into his .xinit and voila.. permission problem solved.


Board footer

Powered by FluxBB