You are not logged in.

#1 2013-12-08 11:49:58

saalty
Member
Registered: 2012-04-06
Posts: 58

[Solved] e4rat-preload cannot work

Hi

After an system upgrade boots-libs package was upgraded yesterday.
Today when I tried to switch on my laptop found an error:
/sbin/e4rat-preload:error while loading shared libraries: libboost_system.so.1.54.0: cannot open shared object file: No such file or directory.

Could I solve this problem somehow?

PS: I commented e4rat-preload from syslinux.cfg and I can use now my laptop, but with e4rat is my laptop is much faster.

greetz saalty

Last edited by saalty (2013-12-08 14:55:54)

Offline

#2 2013-12-08 11:54:22

swanson
Member
From: Sweden
Registered: 2011-02-05
Posts: 759

Re: [Solved] e4rat-preload cannot work

Did you try to reinstall e4rat?

Offline

#3 2013-12-08 12:00:21

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [Solved] e4rat-preload cannot work

If you're using a package from the AUR, it's your (user's) responsibility to keep it in sync with pacakges from the official repos.
You have to rebuild and install it. Reinstalling using a package you've build before boost-libs update won't help.

Offline

#4 2013-12-08 13:48:49

saalty
Member
Registered: 2012-04-06
Posts: 58

Re: [Solved] e4rat-preload cannot work

Sadly I cannot reinstall e4rat, because I got an error message

==> ERROR: A failure occurred in build().
    Aborting...

Last edited by saalty (2013-12-08 13:49:03)

Offline

#5 2013-12-08 13:50:12

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [Solved] e4rat-preload cannot work

If the couple lines before '==> ERROR: A failure occurred in build().' have some info about the nature of the error in question, please post them too.


Edit: I get

==> Starting build()...
-- The C compiler identification is GNU 4.8.2
-- The CXX compiler identification is GNU 4.8.2
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Boost version: 1.55.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   regex
-- Found ext2fs: /usr/lib/libext2fs.so
CMake Error at src/cmake/Findaudit.cmake:17 (MESSAGE):
  Could not find audit
Call Stack (most recent call first):
  src/CMakeLists.txt:83 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/karol/test/e4rat/src/e4rat-0.2.3/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
    Aborting...

Read https://aur.archlinux.org/packages/e4rat/ comments:

swiftgeek wrote:

http://www.opendevs.org/kmvkk/staticlib … build.html
You need to recompile audit package with staticlibs option, thanks to new policies :<

At least It's only needed once since e4rat isn't developed anymore and it's static wink

(This package has far to low amount of votes to go back into community or extra)

Last edited by karol (2013-12-08 13:58:50)

Offline

#6 2013-12-08 14:19:37

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [Solved] e4rat-preload cannot work

Worked for me:

$ diff PKGBUILD PKGBUILD.old 
--- PKGBUILD	2013-12-08 14:06:10.681081932 +0000
+++ PKGBUILD.old	2013-12-08 14:05:58.201082743 +0000
@@ -12,7 +12,7 @@
 depends=(krb5 libcap-ng)
 makedepends=(libldap swig linux-headers python2)
 license=(GPL)
-options=(emptydirs staticlibs)
+options=(emptydirs)
 backup=(
 	etc/libaudit.conf
 	etc/audit/rules.d/audit.rules

e4rat installed fine.

Offline

#7 2013-12-08 14:57:19

saalty
Member
Registered: 2012-04-06
Posts: 58

Re: [Solved] e4rat-preload cannot work

Thank you for helps. Rebuilt audit with staticlibs option solved the problem so I marked this topic as Solved

Offline

#8 2013-12-23 09:41:26

ravicious
Member
From: Poland
Registered: 2011-06-07
Posts: 69
Website

Re: [Solved] e4rat-preload cannot work

Sorry for touching an old thread, but how do you exactly "rebuilt audit with staticlibs option"? I assume it's not about adding `staticlibs` to e4rat's PKGBUILD.

Offline

#9 2014-04-03 07:41:13

dbbolton
Member
Registered: 2008-10-08
Posts: 41

Re: [Solved] e4rat-preload cannot work

To anyone who happens upon this thread:

The staticlibs option is in the etc/makepkg.conf file. Enable it (i.e. remove the ! in front of it in the OPTIONS string), then build audit from ABS.

Now you should be able to build e4rat.

Offline

Board footer

Powered by FluxBB