You are not logged in.

#1 2004-02-04 11:32:57

zbled
Member
Registered: 2004-01-25
Posts: 56

Cannot mount /mnt/dvd

Hi, I'm experiencing a weird problem.  I cannot mount my dvd-drive under archlinux. when booting with another live-cd it work's fine...

here's my config:

dmesg | grep hdd
    ide1: BM-DMA at 0xc008-0xc00f, BIOS settings: hdc:DMA, hdd:DMA
hdd: Pioneer DVD-ROM ATAPIModel DVD-116 0122, ATAPI CD/DVD-ROM drive
hdd: attached ide-cdrom driver.
hdd: ATAPI 40X DVD-ROM drive, 256kB Cache, UDMA(66)

/etc/fstab:

/dev/dvd                /mnt/dvd        iso9660         user,unhide,noauto,ro,users

/etc/devfsd.conf

LOOKUP          ^dvd$           CFUNCTION GLOBAL mksymlink cdroms/cdrom1 dvd
REGISTER        ^cdrom/cdrom1$  CFUNCTION GLOBAL mksymlink $devname dvd
UNREGISTER      ^cdrom/cdrom1$  CFUNCTION GLOBAL unlink dvd

ls -al /dev/dvd
lr-xr-xr-x    1 root     root           13 2004-02-04 12:01 /dev/dvd -> cdroms/cdrom1

atithi [/home/atithi/] # mount /mnt/dvd
mount: No medium found

[root@heisl ]# mount /dev/dvd /mnt/dvd/ -t iso9660
mount: block device /dev/dvd is write-protected, mounting read-only
mount: No medium found

[root@heisl ]# mount /dev/cdroms/cdrom1 /mnt/dvd/ -t iso9660
mount: block device /dev/cdroms/cdrom1 is write-protected, mounting read-only
mount: No medium found

I'm using a self-compiled kernel (2.4.24) with the ck-patches. the kernel worked well with gentoo, so the kernel-config should be okay.

thanks in advance for your help, martin

Offline

#2 2004-02-04 11:43:15

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,444

Re: Cannot mount /mnt/dvd

Maybe your gentoo config was not compiled to use DEVFS file system. Check the config, you will compile it with the mount at boot option:

#
# Pseudo filesystems
#
...
CONFIG_DEVFS_FS=y
CONFIG_DEVFS_MOUNT=y
...

Furthermore, your dvd may be formated with udf, therefore you should compile this filesystem into the kernel. Also, when using devfs, your dvd should be recognized as /dev/cdroms/cdrom?, check it and change the fstab:

/dev/cdroms/cdrom2 /mnt/dvdrom iso9660,udf ro,user,noauto,unhide 0 0 

Parts may differ on your system, because I use a pure scsi machine, but I suppose it to be the same.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#3 2004-02-04 11:50:19

zbled
Member
Registered: 2004-01-25
Posts: 56

Re: Cannot mount /mnt/dvd

the devs-filesystem is already compiled in the kernel. I've also added udf now, editet /etc/fstab (filesystem, link) but it doesn't work - no medium found.

[edit]
erm, i've found a solution - but it's a bit confusing.... mount /dev/hdd /mnt/dvd works... hmmm, what happend to my good old /dev/cdroms/cdrom1?
[/edit]

Offline

#4 2004-02-04 15:26:01

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,444

Re: Cannot mount /mnt/dvd

I don't remember where I read about it, but could it be possible you are using supermount? Afaik supermount does that stuff. Why you have /dev/hdd to be mouted as /dev/dvd - puh, I donnow, I guess it must be an error tweaking of you.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#5 2004-02-04 15:59:46

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Cannot mount /mnt/dvd

What is in /dev/cdroms?  What do you get when you ls it?


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#6 2004-02-04 17:56:08

zbled
Member
Registered: 2004-01-25
Posts: 56

Re: Cannot mount /mnt/dvd

hdc is a cd-burner, which i access with scsi-emulation, so it looks like that the dvd-rom (hdd, ide without scsi-emulation) is /dev/cdroms/cdrom0 - and not /dev/cdroms/cdrom1 wink

thanks for your help

Offline

#7 2004-02-04 18:05:58

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Cannot mount /mnt/dvd

you do realize that you do not even have to have a separate /mnt/dvd setting? i have a combo drive and i mount it at /mnt/cd whether the dics is a dvd data disc or a regular cdrom and /mnt/cd  links to /dev/cdroms/cdrom0

if i need to play a dvd i  have all of my players set to read /dev/cdroms/cdrom0.  /dev/dvd was always just a symlink anyway so did away with it altogether.. oh and i don't have anything like those devfsd.conf setting you have.


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB